Windows Legacy OS forum

General discussion

Task Manager "Removable Storage" isn't working anymore !

by michlaz / May 6, 2005 8:39 PM PDT

Under Win XP Pro SP2, clicking on "Removable Storage" tab in Task Manager, application hungs showing that is "thinking".... I go there by : Right Clicking My Computer-Manage-Removable Storage (under item "Storage")-click or double click- application appears "thinking" and doesn't show anymore libraries, CD-ROMs....
Need Help !
Thanks in Advance

Discussion is locked
You are posting a reply to: Task Manager "Removable Storage" isn't working anymore !
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Task Manager "Removable Storage" isn't working anymore !
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
by AussiePete / May 6, 2005 9:42 PM PDT

Have a look in accessories/sys tools/systems info/components
then the following sub directories
CDROM, storage, problem devices
If you have trouble with the above your WMI data base must have got corrupted - if so let me know.

Collapse -
Everything looks good
by michlaz / May 6, 2005 10:24 PM PDT
In reply to: WMI

Dear friend, I followed your advise. Nothing looks having problem in System Information/Components Tables. CDROMs are OK, Storage is OK, no problem devices found. Is there something else we could look for ?
Thanks a lot !

Collapse -
Task manager
by AussiePete / May 6, 2005 10:31 PM PDT
In reply to: Everything looks good

You say "task manager" but do you mean:-
"admin tools/computer manager/storage/removable storage" ???

Collapse -
by michlaz / May 6, 2005 10:50 PM PDT
In reply to: Task manager

Yes, Peter, another way to go there is by right-clicking My Computer Desktop Icon, Select Manage, etc.

Collapse -
ctr+alt+del is "task manager"
by AussiePete / May 6, 2005 11:31 PM PDT
In reply to: Yes

Does everything look OK in "device manager" under; dvd,disk drives, SCSI and IDE folders??? - and do you have any other problems with your removable storage devices or any other problems??? - please tell me what removable storage you have, including virtual devices such as "Nero" image drive?

Collapse -
Removable Storage Devices
by michlaz / May 7, 2005 1:23 AM PDT

1. Device Manager looks allright, no yellow or red marks, no problems over there.
2. I had problems in the past with a Mass Storage Device (USB 2.0 JetFlash 512 Memory Stick), but I fixed it.
3. I give you my drives list:
a: Floppy
b: -
c: Fixed HDD (1)
d: CD-RW Plextor
e: DVD-ROM Toshiba
f: Fixed HDD (2)
g: Temporary drive for JetFlash Memory
created by "Alchohol 120%" program.

Collapse -
removable storage services
by AussiePete / May 7, 2005 3:59 AM PDT

First have a look in "event viewer" to see if there are any problems shown then
make sure the "removable storage" service is running and that all it's dependencies are up and running - go all the way up the dependency chain to "Remote procedure call" to "workstation" and so on - if you have been tinkering with the services this could well be the problem.

Collapse -
by michlaz / May 7, 2005 7:20 PM PDT

Thanks Peter, I was searching Services Problems some days ago but I didn't make it. It seems I have much work to do to find out what's happening. If I find something I'll give you a new post here.

Collapse -
Trouble shooting
by AussiePete / May 8, 2005 4:58 AM PDT
In reply to: Services

A few more things to try
1/ Log in as the administrator and see if you gain access.
2/ Run the "removable drive" snap-in from explorer - goto sys32/ntmsmgr.msc - right click on the file and select "author" - then right click on main folder and select properties/security, make sure you have rights. If you can view items with this method let me know
3/ repair the WMI repository - here is how you do it:-
4/ In msconfig run diagnostic mode - then remove all removable devices except your master CDROM - also remove any other non essential hardware eg pci cards, hard drives except C drive. Then try with your other CDROM installed by itself.
If when you run the "removable drive" snap-in it now works it then a matter of finding which of the above programs or hardware is causing the conflict - you can do this by adding the above one at a time.
5/ The WMI is very sensitive to incorrect or incorrectly installed drivers - Particularly SP2 - also make sure all your hardware is on the compatibility list.
Let me know how you go,

Collapse -
by michlaz / May 11, 2005 3:52 AM PDT
In reply to: Trouble shooting

Item by item answers in your previous message :
1. No change - problem persists.
2. It's stuck, this is the main Problem.
3. Repair of the WMI repository, successful.
Problem persists.
4. Before I go to the msconfig step some questions:
a. When I tried first time, it asked me to Activate
Windows and I did so. Every time I run msconfig I
have to Activate ?
b. I cannot understand the meaning of remove
hardware, you mean uninstall drivers from Device
Manager or to unplug any cables,e.t.c. ?
Anyway,uninstalling drivers of my CD-RW (master) in Device Manager,next time PC boots, fails to reinstall it in the first time, and fails to start
normally .....????
And when finally it makes it, "recovers from a serious error". Does it says something ?

Collapse -
by AussiePete / May 11, 2005 6:54 PM PDT
In reply to: Msconfig

Michlaz, maybe it is easier if we talk real time on one of the messenger programs
my msn name is: AussiePete747
my AOL name is AussiePete747a
So let me know if you want to talk this way as it will be much much easier???
To comment on your post:-
1/Using diagnostics mode in msconfig is step 1 - you will get a message when you reboot saying changes have been made - just tick the box for it not to ask you again. If after this you can view "removable drives" it is a program or service loading that is causing the trouble.
2/If the above doesn't work then you can take all your hardware out - as in unplug everything (not uninstall drivers). The reason why you had to reactive was because you unplugged the hardware not because you changed things in msconfig - to explain how "activation" works is a long story. But we can maybe solve this problem - But try removing all your hardware all at once - you may have to reactivate but at least we may then know if it is your hardware or it is a systems program problem that is stopping you reading the removable drives. You didn't say how you had to reactivate - if you did it by phone last time and this time your get transferred to a microsoft person then tell them you are having system or hardware problems and you are unplugging EXISTING harware to find the problem.
3/ You asked me "Does it says something ?" I am not sure what you mean - I gather you uninstalled the driver in the DVD/CDROM folder of device manager and when it booted you got the errors - this tells us there maybe something wrong with this device or driver, or perhaps your motherboard drivers - make sure you get any updates for the above as SP2 seems to be causing problems with CDROMS.

Anyway best if we talk on MSN messenger - or send me an email (look at my profile) and give me your email - dont give me it in a post!

Collapse -
Received your email OK but....
by AussiePete / May 14, 2005 2:46 AM PDT
In reply to: Talk

You will have to send your actual email address because when you send a message via CNET your email address is not given to me.
You can use windows messenger but you must have a .NET passport - when you start windows messenger for the first it will ask you to start one if you haven't already.
Then just add my user name (AussiePete747) and it will send me a message asking me to allow you to add me to your Buddy list.
Speak to you soon

Collapse -
Problem Solved !!!
by michlaz / May 16, 2005 7:34 AM PDT
In reply to: Talk

Peter, I finally solved the problem, look how :
The solution is in Microsoft's Article "Problems with a Damaged Removable Storage Manager Database"
(Article ID : 235032)
It concerns a problem of Windows 2000 !!!
Anyway, thanks a lot for everything.
Michael from Athens/Greece

Collapse -
Great!, but.....
by AussiePete / May 16, 2005 6:08 PM PDT

I did say to do the following:-
"First have a look in "event viewer" to see if there are any problems shown"
For future reference learn how to use the event viewer and see that is logging and functioning properly. Either you didn't look as I suggested or their is something wrong with logging - you should have seen an "error" and the error would have more than likely taken your directly to the knowledge base article.
Anyway I am glad you fixed the problem.
PS you have my email address so if you have any other problems let me know.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Meet the drop-resistant Moto Z2 Force

The Moto Z2 Force is really thin, with a fast processor and great battery life. It can survive drops without shattering.