General discussion

SYSTEM32 missing or corrupt, but PC will not activate OEM CD

When I switch on I get a message :
_____________________________________

"Windows could not start because the following file is missing or corrupt:
\WINDOWS\SYSTEM32\CONFIG\SYSTEM

You can attempt to repair this file by starting Windows Setup using the original Setup CD-ROM.
Select 'r' at first screen to start repair."
______________________________________

This is a custom-built computer that is four-and-a-half years old, which packed up about 18 months ago with a spent motherboard. So the original constructor put in a new and bigger and better motherboard, and then it worked fine for about another year or so - then this happened about two months ago. Since then I have been existing on an older but much smaller machine, just to stay on line.

The problem is that when I switch on, with the OEM Windows XP Home CD-ROM in place, the computer does nothing, and the message remains on the screen. I have tried all possible combinations of putting the CD in the tray before and after switching on, and putting the disk in both my DVD ROM tray and my usual CD ROM tray. Nothing happens. The machine does not acknowledge the disk's existence.

I very much want to get the Windows repair option functioning first, to see if it can work. If I can't, or if the repair facility does not fix it - then I'm not patching this machine up again. I'll get the hard drive out and have another new machine built around it. That will be a lot of time and money. Who can help me to get this original system disk going, please?

Discussion is locked
Follow
Reply to: SYSTEM32 missing or corrupt, but PC will not activate OEM CD
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: SYSTEM32 missing or corrupt, but PC will not activate OEM CD
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Look at the BIOS . . .

and make sure the first boot device is the optical drive. If not, make it so.

It sounds like the Master Boot Record is corrupt. If you can boot from the CD, go to the Repair Console (DOS-like screen) and type:

fixmbr

Agree to the warnings.

- Collapse -
Cannot get into BIOS

I've tried all keys. Some do nothing, but most put me straight back to the first message. When this computer last played up early 2009 it told me there was no C-drive (which was later proved wrong). At that time I went into BIOS several times using, I think, F8 key - but now, no key will take me there.

I've got a feeling you've given me the right track, but only if I can figure out how to get into BIOS from here.

I've tried MS-DOS, using an old start up floppy that I have, but I'm so rusty with DOS commands I don't really know what I'm doing. I'm still researching DOS commands for Windows XP on the web, but progress is very slow.

jb

- Collapse -
You can try

tapping the Delete key as soon as you turn on the power button. If that doesn't get you in try the F2 Key. 3rd suggestion if you have a floppy drive down load a win98 startup disk onto a floppy disk. Put that disk in and turn on your computer. Use the option start with CD-Rom support.

- Collapse -
As if by magic,

tapping the Delete key took me straight into CMOS Setup Utility, incorporating two specific BIOS applications in the twelve-piece menu.

Thanks. We'll see what happens from hereon in. Meantime, don't leave the country.

jb

- Collapse -
So far so good.

Coryphaeus - I'm replying to you now because once I got into BIOS, following the advice from Bob re. tapping on the Delete button, everything went exactly as you said. After entering fxmbr I was told the mbr I had was invalid, given all the warnings, went for writing a new MBR - and it then happened in about a tenth of a second. Naturally I am now highly optimistic, and that is the best time to reply.

I will now restart and see if I get back into windows OK. If not, then I won't sound so happy if and when I come back again.

Thanks anyway, jb

- Collapse -
A few hiccups (hiccoughs in old English) but.......

following on from my last post - having got past the Windows main welcome screen I then had (and could get) nothing. So, I thought about it and went into Recovery Console again via the OEM disk; got up the list of DOSlike commands via 'HELP' and activated FIXBOOT and got a rewritten boot sector done. Then I activated CHKDSK, and was told everything about the hard drive appeared so normal that they were not going to check the volume [the used and free space numbers looked just about right to me]. Then I went back into BIOS boot sequence and pushed the 3" floppy down to fourth and the other optical drive into second place.

Then I came out and rebooted the PC, got past the Windows page and again got nothing. I sat there and reset again a couple of times, and then, Glory Be, I got the standard Microsoft apology message saying Windows was having difficulty booting. Then came the usual and familiar options - and I plumped for 'Last known Good Configuration' and away we went. Everything has been fine since then - I've reset several times and also shut down once - and I'm now making this post on my biggest and best machine once more; which owing to this CNET forum now has a new lease of life.

Thanks, guys. jb

CNET Forums