Rant

SyncMaster SA350

The display will not show a picture when plugged into HDMI or VGA, the graphics card is not at fault due to I can plug another screen in. When I turn on the SA350 it flickers with the HDMI to the Analog symbol then turns it self off with a solid red light.

Help fixing this would be fantastic

Discussion is locked
Follow
Reply to: SyncMaster SA350
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: SyncMaster SA350
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
bump!

same problem, woke up this morning & it wont' show the desktop, but the screen works because I can see it try for HDMI/VGA. It must have a signal because my computer tries to put the display on it & it's got a solid red LED indicator. The LED backlights light up. The monitor menu button does nothing. I've got dual SA350s so I know its the monitor, doesn't matter if it's VGA or HDMI.

- Collapse -
I took a quick look

And can't find any user serviceable parts. Head to samsung.com and see what they say about arranging for service or repair.
Bob

CNET Forums