Windows Legacy OS forum

General discussion

svchost.exe

When I boot up svchost.exe system very often pegs cpu to 100%. This last a minute or 2. What can I do to stop this.

Richard

Discussion is locked
You are posting a reply to: svchost.exe
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: svchost.exe
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
svchost.exe and excessive cpu usage

In reply to: svchost.exe

I have spent some time at this and this is what I found. I am using WinXP Professional SP2.

When you end the svchost.exe process (there are many, I am refering to the one that is gobbling up the cpu) Windows Live one care will pop up to notify you that you have turned off Automatic Updates.

We used to have "Windows Updates" on our computers. At some point this changed to "Microsoft updates" and this is when cpu usage became an issue. "Microsoft updates" also updates Microsoft Office.

Microsoft has not, as of now, released a fix that can be trusted to end this problem. Many of us are trying to get them off their butts and give us a solution. For now, end the process in the Task Manager , go to the Microsoft Updater site for your downloads and contact Microsoft about fixing this problem.

Collapse -
Thanks for the reply

In reply to: svchost.exe and excessive cpu usage

and will contact Microsoft about a solution

Richard

Collapse -
svchost.exe and excessive cpu usage

In reply to: svchost.exe and excessive cpu usage

RUupTOit got it right. After downloading Microsoft Update Express two days ago, I've had freeze ups lasting several minutes, occasionally while on line, but ALWAYS just after booting up. Sure enough, a svchost.exe SYSTEM process was hogging 100% of my memory. I turned off Microsoft Update, (you can do this easily at its website, (http://update.microsoft.com/microsoftupdate/v6/default.aspx?ln=en-us), and NO MORE PROBLEMS!!!. Note: by turning it off at the above website, you can still receive "Windows Update", which always worked for me. If you use Control Panel - System properties to turn it off, you'll turn off ALL automatic updates -- I don't think you want to do that.

Collapse -
jackfrost64

In reply to: svchost.exe

Collapse -
Thanks

In reply to: jackfrost64

Have resd and downloaded the fix. Will try for a day or two and then will let you know how I make out. Thanks again

Richard

Collapse -
(NT) Your welcome,thanx for posting back

In reply to: Thanks

Collapse -
No dice

In reply to: Your welcome,thanx for posting back

Just installed and restarted and problem still there. Anyother suggestions? thanks again.

Richard

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

DEALS, DEALS, DEALS!

Best Black Friday Deals

CNET editors are busy culling the list and highlighting what we think are the best deals out there this holiday season.