learning from the fix i tried to apply in fedora, i started looking around with sfdisk and i think there is something fishy there (or it might just be me not knowing things)

when i read the kernel's idea of the geometry (i think with the command sfdisk -g /dev/hda) it says
38760 cylinders, 16 heads, 63 sectors/track

while the command fdisk -l /dev/hda says
255 heads, 63 sectors/track, 2432 cylinders

now, i believe there are 255 heads and 38760 cylinders (this is the number of cyls from the partition tool). so i tried forcing the number of heads and cylinders as told in the fedora fix (http://www.redhat.com/archives/fedora-devel-list/2004-May/msg00908.html)

CODE

warning HDIO_GETGEO says that there are 3221220836 heads

END CODE

then writes the old and new partition table and it looks ok, even with the right number of cylinders/heads

CODE

Re-reading the partition table..
BLKRRPART: Device or resource busy
The command to re-read the partition table failed
Reboot your system now, before using mkfs

END CODE

(but i thought i had given the command no-reread..)

still no improvement...

caterina