Spyware, Viruses, & Security forum

General discussion

suddenly being blocked from certain websites

by skissner / November 1, 2007 2:44 AM PDT

Help! My 3 PCs are suddenly being blocked from several websites I frequent, and I have no idea why.

We run Spybot weekly and have McAfee VirusScan.

My 2 desktops are networked for Internet access and printing, and my laptop has Internet access via WiFi.

None of the 3 of these can access these sites (which include forbes.com, expedia.com, dictionary.com)

System info: The "main" PC which controls the Internet access is a Dell Dimension 4550 running WindowsXP. Internet access is a cable modem running through a Linksys Router.

Any help would be greatly appreciated. Please be gentle -- I'm not very tech-savvy!

Discussion is locked
You are posting a reply to: suddenly being blocked from certain websites
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: suddenly being blocked from certain websites
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
What error message do you see when you tried to see any of
by Donna Buenaventura / November 1, 2007 5:29 AM PDT

those sites you mentioned?

"The page cannot be displayed"
"Cannot find server or DNS error"

If you see any of the above error message, try the solution of Microsoft at http://support.microsoft.com/kb/246725/en-us

Also, have you try to use another browser to "test" if the new browser e.g. Firefox, Opera can access those sites?

Collapse -
Tried both your suggestions to no avail
by skissner / November 1, 2007 5:49 AM PDT

I see both of the error messages you mentioned, depending on the site.

I did indeed try Firefox to see if the problem was IE, but I still could not reach those pages from within Firefox on my PC.

The Microsoft solution instructed me to clear selections in my security settings that were already cleared.

So, are there other things you would suggest?

Many thanks.

Collapse -
Review your hosts file
by Donna Buenaventura / November 1, 2007 6:00 AM PDT

Try to review the content of your HOSTS file.
The HOSTS file is located in C:\Windows\System32\Drivers\etc
Right-click then view it using notepad
Look for any the URL you mentioned in the list. Are they listed or none is listed?

Also, see if the solution by MS on the following will help:

http://support.microsoft.com/?kbid=303807 - "The page cannot be displayed" error message when you try to view a Web page on a secure Web site

http://support.microsoft.com/default.aspx?scid=kb;EN-US;241344 - Error message: The page cannot be displayed

Collapse -
A Solution That Has Helped A FEw
by Grif Thomas Forum moderator / November 5, 2007 3:55 AM PST

Try using the instructions/links below to download and install the latest version of Java and the Windows Script Engine:

Windows Script Engine Version 5.7

Sun Java
Click on the link to Sun's Java below, then click on the ''Java Runtime Environment (JRE) 6u3'' download button. Follow the prompts, accept the license agreement, then download the full ''Windows Offline Installation'' file to your desktop,(about 15 MB), scan it with your antivirus (just to be sure it's clean). Once that's done, if you've already got a Sun Java version on the computer, open the Control Panel, double click on the ''Add/Remove Programs'' section, then uninstall all previous versions of the J2SE Java listed there. Once that's done, then install Java JRE 6u3 from the downloaded installer.


Once Java is installed, if you're using IE7, then access the Internet Explorer "Internet Options" settings, "Security" tab, "Internet" icon, "Custom Settings" and change the security level to "Medium", instead of "Medium-High". If you're not using IE7, then set the same settings in IE6 to "Medium".

Hope this helps.


Collapse -
by ddbpack / November 5, 2007 8:44 AM PST

get rid of linksys! they are garbage, had one and couldnt get it to work with zyxel router. go to a zyxel as linksys only seems to work well other linksys products!!

Collapse -
Same Here
by Chandaxi / November 5, 2007 1:47 AM PST

Yeah, have experience such thing with my 2 computers. Since u've 3 computers there is not quite possibility that all got the same problem within, so, it's more likely to be a conectivity issue. Perhaps your isp got some filter, content limitation, or transfer amount-bandwith limitation. In my case i'm still not sure wot cause it, but usually got it fixed by restarting the computers and the modem generating fresh connection data.

Collapse -
internet security
by ocelot31454 / November 5, 2007 2:39 AM PST

Did you check the internet security options? Check the restricted sites tab and see if the sites your trying to reach are on the list. If so just remove them or put the in the safe zone. Had this happen once before but never figured out why.

Collapse -
see if you can access the sites ...
by Edward ODaniel / November 5, 2007 4:48 AM PST

by clicking the following links.

forbes.com is
expedia.com is
dictionary.com is

If you can connect via those links it would appear to be either a HOSTS file problem or possibly a DNS cache problem with a negative entry.

To check your HOSTS file browse to %WinDir%\system32\drivers\etc\hosts (it has no file extension) then simply open it in a text editor such as NotePad and look for the domains you are having problems with. Once found either comment out the entry by prefixing it with # or simply delete the entry.

To flush your DNS cache either re-boot or open a command prompt and type ipconfig /flushdns

If you wish to stop XP from placing negative entries into cache, you can make this change in your registry.

1. Goto HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ Dnscache\Parameters
2. Build a new DWORD value called NegativeCacheTime (the value is case sensitive) and give it a value of 0 (that is a ZERO).

Collapse -
modem or router
by ONE_HUMAN / November 5, 2007 4:49 AM PST

Since all three computers are affected and I assume they are all connected to the same modem and router, I think your problem lies with one of them. Something simple you can try is to power down both your modem and router for one minute. Turn them off, or unplug them from AC if there is no power switch. After a minute, restart them by powering them back up. This should reset them. Does this have any effect on your problem?

Also, have you tried connecting your ethernet cable directly from the modem to one of the PCs, bypassing the router? If everything works fine when you've done that, then you know the problem is with the router and not the modem.

Which model of Linksys router do you have? Have you upgraded the firmware for it recently? On the main router setup page, what is the MTU set to?

Collapse -
May not apply
by damnrhtdell / November 5, 2007 5:57 AM PST
In reply to: modem or router

I had the battery on the motherboard die, so the clock did not work. this kept me from getting on the web and gave security warnings. Until I replaced the battey I would boot up then right click the clock to manually set clock to current date this allowed me to log on web.

Collapse -
some sites load
by ONE_HUMAN / November 5, 2007 7:19 AM PST
In reply to: May not apply

He can get on the web. Just certain sites don't load for him.

Collapse -
by Capt.Daniel / November 5, 2007 6:25 AM PST
In reply to: modem or router

I have a D-Link Router that uses a air-card to connect with. Last night it had the same problems you are describing here. I only had success by removing the software program from the computer and reinstall the software. I was able to get to the site in question by installing the air-card into the computer but with the router I couldn't get to two different sites. After reinstalling the software I was able to go everywhere I wanted to. I have two different computers, Both have Vista Home Premium and both had the same problem till I reinstalled the software. I dumped all the bookmarks, cookies and all the settings back to default. Maybe this will help but I think there is a trojan or worm that pinged my router last night.I have had One other person have the same problem on my forum site but the tech hasn't been able to get them on-line yet!! I sent this to the forum tech, maybe it will help them to get on-line.

Collapse -
An update on my problem
by skissner / November 5, 2007 7:02 AM PST
In reply to: modem or router

Thank you all so much for the excellent suggestions!

Here's an update: I got out an older laptop with Windows98 on it and tried to go to these sites, using the same wireless connection as my other computers. Well -- I was able to reach the sites just fine!

Doesn't that seem weird?

Also, I tried reaching the sites using the IP addresses shown in Edward's post, and I could reach them but they did not load correctly (no graphics).

I did notice another weird thing that may or may not be related? When I'm looking at some of the style and formatting options within Outlook, it shows me the font in english, and also in something that looks arabic? Could this in any way be related?

Other updates: My HOSTS file has nothing in it. I have rebooted my router, my modem and of course the PCs numerous times. My clock is running fine. I checked with my ISP and they have no filtering.

So that's the latest. Your help is much appreciated!

Collapse -
by ONE_HUMAN / November 5, 2007 7:20 AM PST

And what about the stuff I suggested or asked you in my post?

Collapse -
by Capt.Daniel / November 5, 2007 9:58 AM PST
In reply to: router?

One thing that seems to help is the setting in Firefox or IE7, and thats checking the amount of storage in your browser cache. Should be around 50mb lower is better. Dump the catch and see if you can connect.

Collapse -
browser cache
by ONE_HUMAN / November 5, 2007 10:38 AM PST
In reply to: Router

While emptying the browser cache or deleting temporary internet files is always a good idea, as is setting the size of the cache to ~80 MB or less, I can't see that being the problem here since it's affecting all three computers and not just one.

Collapse -
by Capt.Daniel / November 5, 2007 11:03 AM PST
In reply to: browser cache

I cut back to 50mb and dumped the cache. I took out a firewall, [Vista firewall] I had it about a week. I don't think it did it but something had to change the software settings in th router. A friend on another site has been trying for two weeks to get to the forum when his computer died and he bought a new one with vista and his router wouldn't handle the vista and they are saying this is a incompatibility issue with older routers and vista. They say a service pack is coming out soon that will help with this issue. Now, as to what we are suppose to do until then, I don't know??

Collapse -
by Capt.Daniel / November 5, 2007 11:06 AM PST
In reply to: router
Collapse -
by Capt.Daniel / November 5, 2007 11:23 AM PST
In reply to: Router

Sorry that firewall should be Vista Firewall control 1.1

Collapse -
same problem
by nabilzul / May 20, 2008 6:13 AM PDT
In reply to: router?

my 3 pcs and 1 laptop being blocked by a website. i also use linksys modem+router+wireless. i can't get certain website even by using cable or wireless. if somebody use to solve this prob can i know how?

Collapse -
Can it be the router if I can connect via my old laptop?
by skissner / November 5, 2007 11:17 AM PST
In reply to: modem or router

In other words, does that point to an XP problem somehow?

But, to answer your questions -- Linksys Wireless G Broadband Router 2.4 ghz. Have not upgraded firmware, didn't know I needed to! Forgive my ignorance, but I don't know how to find the main router set up page...

BTW -- I am using IE6.

Collapse -
linksys router
by ONE_HUMAN / November 6, 2007 5:26 AM PST

Have you tried bypassing the router altogether like I suggested? Simply take the Ethernet cable that goes from your modem to your router and plug it directly into the PC which is closest. You'll have to free up the jack on your PC of course by unplugging the cable that is currently going from your router to PC. It's important to try this because it will tell you definitively if your router is part of the problem. If pages load fine when bypassing the router, then you know your PCs are fine.


There are some known issues with your router depending on the version and firmware being used. Look at the serial number sticker on the bottom of the router and you can determine which version it is by matching up the first four characters with the info found on this page: http://www.wrtrouters.com/guides/findversion/

It's possible that you need to upgrade the firmware on your router, but more on that later.

The following info is for when your PC is still connected to your router.

I'm a little surprised you would have never been to your router setup page. In your web browser, type the following into your address bar: or if you prefer. You will be prompted for a username and password. If you've never configured it before, I believe the default is to leave the username blank and type in "admin" for the password. If that doesn't work, try typing "admin" into both fields.

Once you are on the Basic Setup page, near the top you should see the setting for "MTU". It most likely will be set to "Auto". Select "Manual" from the drop-down menu and change the value in the field below it to 1450. Save your settings with the button at the bottom of the page. Does this have any effect on your web browsing? What about 1460, 1400 or even 1300? If none of these have any effect, you can change the value to 1492 if you're ISP is DSL, or 1500 if it's Cable, but then just set it back to Auto as well.

At the very top right corner of the router setup page, what Firmware Version does it say you are using?

Collapse -
by ONE_HUMAN / November 6, 2007 5:29 AM PST
In reply to: linksys router

* ...if YOUR ISP is...

(silly typo and I can't edit posts here)

Collapse -
linksys versions
by ONE_HUMAN / November 6, 2007 5:43 AM PST
In reply to: your
Collapse -
Linksys WRT54G Versions
by ONE_HUMAN / November 6, 2007 5:45 AM PST
In reply to: linksys versions

Actually, I guess I could just post the list here.

CDF0 = WRT54G v1.0 / ADM6996L Chipset / CPU 125Mhz
CDF1 = WRT54G v1.0 / ADM6996L Chipset / CPU 125Mhz
CDF2 = WRT54G v1.1 / ADM6996L Chipset / CPU 125Mhz
CDF3 = WRT54G v1.1 / ADM6996L Chipset / CPU 125Mhz
CDF5 = WRT54G v2.0 / ADM6996L Chipset / CPU 200Mhz
CDF7 = WRT54G v2.2 / BCM5325EKQM Chipset / CPU 200Mhz
CDF8 = WRT54G v3.0 / BCM5325EKQM Chipset / CPU 200Mhz
CDF9 = WRT54G v3.1 / BCM5325EKQM Chipset / CPU 200Mhz
CDFA = WRT54G v4.0 / BCM5352E Chipset / CPU 200Mhz
CDFB = WRT54G v5.0 / BCM5352EKPB Chipset / CPU 200Mhz
CDFC = WRT54G v5.1 / BCM5352EKPB Chipset / CPU 200Mhz
CDFD = WRT54G v6.0 / BCM5352EKBG Chipset / CPU 200Mhz
CDFE = WRT54G v7.0 / AR2317 Chipset
CDFF = WRT54G v8.0 / BCM5354KFBG Chipset / CPU 240Mhz
CDFG = WRT54G v8.0 / BCM5354KFBG Chipset / CPU 240Mhz

NOTE: The WRT54G v5.0 has 2Mb/8Mb Ram, it uses VxWorks OS and is incompatible with 3rd Party Firmware.
For more info see this thread: /forum/remark,14563605

CL7A = WRT54GL v1.0 / BCM5352E Chipset / CPU 200Mhz
CL7B = WRT54GL v1.1 / BCM5352E Chipset / CPU 200Mhz
CO61 = WRT54GL v1.1 / BCM5352EKPBG Chipset / CPU 200Mhz

CGN0 = WRT54GS v1.0 / ADM6996L Chipset / CPU 200Mhz
CGN1 = WRT54GS v1.0 / ADM6996L Chipset / CPU 200Mhz
CGN2 = WRT54GS v1.1 / BCM5325EKQM Chipset / CPU 200Mhz
CGN3 = WRT54GS v2.0 / BCM5325EKQM Chipset / CPU 200Mhz
CGN4 = WRT54GS v2.1 / BCM5325EKQM Chipset / CPU 200Mhz
CGN5 = WRT54GS v3.0 / BCM5352E Chipset / CPU 200Mhz
CGN6 = WRT54GS v4.0 / BCM5352E Chipset / CPU 200Mhz
CGN7 = WRT54GS v5.0 / CPU 200Mhz
CGN8 = WRT54GS v5.1 / CPU 200Mhz
CGN9 = WRT54GS v6.0 / CPU 200Mhz
CGN9 = WRT54GS v7.0 / BCM5354KFBG Chipset / CPU 240Mhz

Collapse -
anything new?
by ONE_HUMAN / November 8, 2007 8:45 AM PST

CNET.com must be one of the sites skissner can't access anymore!

Anything new to report? Did you see my latest and posts?

Collapse -
Still working through all the suggestions
by skissner / November 8, 2007 11:44 AM PST
In reply to: anything new?

Nothing new yet -- have been traveling and not able to finish trying all the ideas. Will keep trying and let you know the outcome! Many thanks!

Collapse -
facing same problem....please let me know solution
by website_blocked / February 11, 2008 12:34 AM PST

I am facing similar problem since last couple of days after my mcafee internet security suite got expired. only 4/5 websites are blocked which I used regularly but rest all are workig fine on my laptop. I tried installing latest version and resetting security setting including allow/blocked list in firewall but got no success.

Please help if anyone knows cause for this or has solution to this problem.

Collapse -
Blocked from certain websites
by daleberger / November 25, 2007 11:06 AM PST

I had this same problem recently. Found that I had inadvertently checked an item in the Internet Options.
the Security section and if TLS.1.0 is Checked...UN-Check it.

That fixed it for me.

Good Luck!

Collapse -
Un-check TLS 1.0
by nabilzul / May 20, 2008 6:34 AM PDT

i did what u said but still can't go to the blocked website. can someone tell me how to uninstall and reinstall fresh router software/driver into the computer. i think this problem comes from the router.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?