Question

stuck on bios splash!

The past 2 weeks I've had issues booting my computer, it gets stuck on bios splash screen and keyboard is unresponsive. I will list everything I've done so far trying to resolve this, and also my computer specs.

● I've tried all combinations of ram stick in slot placements (2 sticks 4 slots). In the week before this one it was able to boot with one stick, since then less and less consistently and today nothing has worked until just 5 minutes ago (hence urgent help needed)

● I tried removing the cmos battery to reset it earlier today, system managed to boot once with one ram stick and all USB devices unplugged, then back to square one the next boot (stuck on bios splash)

● During the successful boot after cmos reset i burned memtest86 to a cd. It's currently in the disk tray.

● what i did just now that got me to the screen in the picture below was try and boot with no ram stick in (obviously failed), then unplugging everything, put both ram sticks in and during startup desperatley and frustratingly spamming delete key and f11. A message showed "cpu or memory changed, press f1 to enter setup". I press it and get to the screen in the picture. I have absolutely no idea what to do now and i'm scared to death to do anything without consulting someone with more knowledge on this stuff first.

Specs: (I got this list from the company who put the computer together in 2012, i only have a vague understanding of what this all means)

MOBO: msi Z77A-GD55

RAM: Corsair XMS3 1600MHz 8GB (2sticks x 4gb) CL9

I noticed the ram sticks are 1600MHz but the bios splash screen i keep getting stuck on says 1333 MHz RAM or something, could this be the issue?

PSU: Silver Power SP - S750M 750W PSU

CPU: i5 3570k

GPU: Sapphire Radeon HD 7950

SSD: Intel 330 SSD 120GB 2.5" Sata 3.0 w/kit

HDD: WD Desktop Green 1TB SATA 3.0

Here is the screen im currently on:
http://imgur.com/CtPwpCV

Exactly what should I do now? Boot from the cd to run memtest86? Some other thread op with a similar issue resolvd his issue with something about XMP when talking about ram, is that something to do with 1333 mhz versus 1600 mhz?
Please help me.

Best regards,
Stressed hardware noob

Discussion is locked
Follow
Reply to: stuck on bios splash!
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: stuck on bios splash!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
heres the screen im on now

imgur.com/CtPwpCV

- Collapse -
Answer
About 1600 and 1333. Nope.

CNET Forums