I like to go to cmt.com and watch streaming videos myself and I found this problem to happen on my laptop that has Vista, 2gig processor, 2gig ddr ram, , nvidia geforce w/turbo cache. This is what seemed to have worked.
1. Went to control panel and clicked on system
2.On left column clicked on advanced system settings.
3. On the advanced tab, clicked on settings.
4. In the new window, click on the advanced tab,
5.Down in the virtual memory, clicked on change.
6. I unchecked the "Automatically manage page file size for all drives.
7. I ensured that on the bottom, the "System managed size" is selected in the lower part.

Hope this works.