Samsung forum

General discussion

Streaming to UN46B7000 fails with Upnp Error: 716

by rhfritz / March 28, 2010 12:51 AM PDT

I've been using Media Player to stream pod casts to my TV for months. Without any deliberate changes on my part, I now get the following error: Media is not available. Details: The device could not locate the media. Please make sure the media storage device is connected to the network and the media is available and try again. HRESULT: 0x80040374; UPnP Error: 716.

Media player identifies the TV on the network just fine. But I can't stream any more. And the error message doesn't indicate to me where the error might be. Any insight appreciated.

Discussion is locked
You are posting a reply to: Streaming to UN46B7000 fails with Upnp Error: 716
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Streaming to UN46B7000 fails with Upnp Error: 716
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Additional info
by rhfritz / March 28, 2010 12:56 AM PDT

I did recently switch from Trend Micro to Kaspersky Internet Security. But I've disabled it and still get the same error.

Collapse -
Same problem with UE37C6530
by nmg196 / July 7, 2010 7:35 AM PDT

I've got the same issue. Did you find a fix? I'm not using either of the AV products you mentioned and even if I disable my AV, I still can't stream Sad

Collapse -
Solution
by jcn79 / December 26, 2010 3:51 AM PST

I experienced the same error as above with codes matching the HRESULT and UPnP error when attempting to play through my Samsung TV. Try running through the following steps:

- Ensure that Windows Media Player Network Sharing Service (running as NETWORK SERVICE) has access to the files - if all users have read access, you're covered
- Ensure that the TV is enabled for streaming (Control Panel\Network and Internet\Network and Sharing Center\Media streaming options)
- Ensure that the network connection to the relevant TV isn't a public network in Control Panel\Network and Internet\Network and Sharing Center (I haven't investigated this fully but it may be a stumbling block)


INVESTIGATION DETAILS:

Checking the System event log (Start > Run > eventvwr), the underlying error from Windows' perspective (rather than from the TV's perspective) was as follows (I have replaced sensitive parameters with %s):

The Windows Media Player Network Sharing Service cannot process the request for URI '%s' from IP address '%s' due to error '0x80070057'.

0x80070057 corresponds with 'file not found' - if this code is different in your case, you should search Microsoft's website for the code to see what it means.

In my case, I had recently re-organised the file security of my media files and the local NETWORK SERVICE identity which runs the Windows Media Player Network Sharing Service (WMPNSS) no longer had access to browse the location so the following was occurring:

1. Right click on media file > play to > TV
2. The Play To dialogue box opens and Windows asks my TV to play the file
3. My TV makes an HTTP request to WMPNSS for the file
4. WMPNSS attempts to locate the file but does not have access, writes an error to the event viewer and cannot satisfy the HTTP request
5. The TV reports that it was not successful
6. Play To displays the HRESULT and UPnP error you observed

In my case, I used the security section of the relevant root director's properties and Computer Managemet (right click on My Computer > Manage) to grant NETWORK SERVICE access to the files and restarted WMPNSS from services.msc (or > Services and Applications > Services) and it all started working again. Note that your problem may be diffferent but this should help you troubleshoot.

Collapse -
Disable extra network adapters
by squishy2010 / May 12, 2011 6:28 PM PDT
In reply to: Solution

Hey guys just wanted to let you know, I have had this problem a few times myself, but everytime I look online for help I could never find any that really helped, so I went back and pressed a load of buttons until I think I figured it out or at least it does for me so I thought I would pass on the solution I found.

Ok so I had hamachi installed, for those that don't know this creates a local network (LAN) over the internet, this lets you and your friends do whatever you can do on a home network, share stuff, play games etc.
Anyway if you have something like this then there is a chance you have 2 networks connected to your computer home and over the net. Well I disabled the hamachi adapter and boom it worked straight away with no problems.
Now you probably thinking but I don't have hamachi or anything like that, well maybe you have two home networks or internet adapters in your computer, I suggest to try and disable the ones that will not be used to stream and hopefully that will fix your problem.

I really hopes this helps you and others with the same problem or even inspire someone to come up with a permanment fix to this

Good luck guys

Collapse -
Thank You
by addixon71101 / August 25, 2011 11:17 AM PDT

I registered just to express my gratitude to you for this post -- I had Hamachi installed and encountered the same problem.

Collapse -
thanks again
by rogeriw / October 18, 2011 8:54 PM PDT
In reply to: Thank You

Thanks guys - just had the same issue. I had heaps of 'virtual' network adapters, including astaro vpn, and virtual box, to name a couple. disabled everything except wifi and now 'play to' works.
Very hard to troubleshoot so glad i found this thread! Tv is a sony KDL NX 720

Collapse -
Yes!
by mathpie / January 19, 2012 8:53 PM PST

I've searched all over google to no avail to see what was wrong, and this is it! I disabled hamachi, and it worked like a charm. It would be interesting, however, if we could use hamachi on our TVs and control it away from home Happy

Collapse -
Sharing on/off
by damndamage / February 13, 2014 10:43 AM PST
In reply to: Solution

Easiest fix ever! I'm not real computer savvy, so I'm not sure if this is what jcn79 above was saying or not, but the fix for me was so simple i wanted to /bonk myself and have a V8.

Solution: Right Click internet/network, Turn Sharing between PCs and connect to devices on this Network ~ ON.

Collapse -
hotfix available for the problem now
by narssor / December 13, 2011 6:48 AM PST

Even though this thread is a bit old dated, I wanted to inform you guys that there is a hotfix for the problem on Windows official site that can be applied after SP1 on Windows 7.

Collapse -
Excellent - Thanks
by Junkers66 / April 26, 2015 12:00 AM PDT

Hi,

just wanted to say that the above solution did it for me.
Thanks!

I got rid of the VMWare adapter in my Active Networks list --> and presto it now works.

It seems that the WMP does not like it if there are other adapters available - beyond the one which is used for the streaming.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

Does BMW or Volvo do it best?

Pint-size luxury and funky style

Shopping for a new car this weekend? See how the BMW X2 stacks up against the Volvo XC40 in our side-by-side comparison.