General discussion

Strange Problem - Limited or no connectivity

Hey Guys,

Really hoping you can help, volunteered to set up a network/net connection for the 7 people in our house (never again), got 2 pcs I can't get online and have no idea why.

Have Dsl coming in through a router/built in switch, it has its own DCHP server and works fine when any pc is plugged directly into it.

One port is being used up by my PC, another by an access point. One goes to a switch upstairs running a few pcs that all work fine.

The problem is I have a line running downstairs that works perfectly when plugged directly into any machine. But if I go into a switch, then to the machine (any machine) i get about 20secs of xp searching for a connection then "limited or no connectivity".

I've tried everything I can think of: swapping the switch for the working one upstairs, another run of cat 5 from router to switch.Even tried converting it to a crossover lead, with made no difference being a switch and all. It's not the PC as it happens on 2 different desktops and my laptopSad

The only thing that showed any improvement was giving the machine a fixed IP/DNS servers, it seemed to connect ok, but still no network accesss.

Does anybody have any ideas? I work in IT and like to think I'm not a total mongoloid, but I'd love for somebody to point out the obviousHappy

Cheers
Dan

Discussion is locked
Follow
Reply to: Strange Problem - Limited or no connectivity
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Strange Problem - Limited or no connectivity
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
The usuals.

1. Out of date firmware in the router.

2. SSID disabled (sometimes you don't have a choice but to leave it on.)

3. Interfering neighbors wifi. Hint: change your channel.

Best of luck,

Bob

- Collapse -
a

Hi

Just to clarify, this isn't a wifi network problem, theres only one pc on wireless and thats fine. (afaik SSID relates only to wireless?) It's all cat5 - only thought I've had is are there any lenght limits? its probs about 20m from router to hub.

I could try firmware on the router but the fact every other machine works, even through hubs seems to eliminate this.

Thanks anywayHappy

- Collapse -
Passing up a well known issue.

I'll take it that you have seen this before and it didn't help. I've seen the opposite.

Go figure. Hope you figure it out.

Bob

- Collapse -
Link light

Have you checked the switch/hub for link light? You should have two lights currently lit, one for the uplink to your router and one for your computer.

- Collapse -
I would check if.....

any ports are disabled when uplinked to the switch. Some will have a button to bypass this function.

- Collapse -
bah

Theres no buttons as it is a dirt cheap hub, BUT, they work 100% if i use them as an itemideiate between the router and my pc (using 2 short patch leads).

I'd say its the long cable that runs downstairs, but I don't see how it can be when if i plug it directly into the pc it works instantly.
The only thing I can think is that lenght of the cable is an issue, but I'd say its 15-20meteres tops.

Bah,
Giving up for the night, be glad of the functional network at workSad

Dan

- Collapse -
Let me see if I got this straight...

You're going from modem to router, and then from router to two switches? Length of cable is not an issue - We've actually connected houses together underground.

Have you tried troubleshooting the problemsone switch? You say that the functioning switch upstairs works fine - try swapping the switches and see if both work. If the offending switch doesn't work upstairs, perhaps it's a problem with it.

I was going to suggest numbering (192.168.2.1), but I think that's only for routers. It might be worth looking into though...

- Collapse -
Try going wireless!

What a waste of money that you have spent so far. A wireless access point can easily handle up to 50 users and it a much better network management tool. The wifi access card be it usb or pci are cheap to come by but the ap may not be is the only problem. A good ap will easily cost you about 5 to 7 hundred dollars or more. If you are only networking seven people though you can easily get by with a wireless router which can usually handle up to 10 users. Just be sure that you use nothing less than the wireless G technology.

- Collapse -
same issue

don't know if you are still around reading answers to your post but I've recently ran into same problem and right now no clue on solution. The dumb hub I had set up in the garage connecting two computers to the cable modem does not work at the new place I moved the computers. Tried two different dumb hubs, two different Cat5 cables, each port in a different sequence but second computer will not find an ip address to connect to. Running cat5 straight from router before to uplink on hub then out to the two computers. Now it is straight from the modem to the hub without router and one computer always on but not the second; even if I switch the second computer straight to the hub without the other computer linked to the hub, still second computer has no connection so it is not a matter of a single computer on the hub. Right now can only think it is a windows problem since computer got knocked on side during move and video card was out of socket and network card so thinking interference some way and maybe reinstall Windows will straighten out the network recognition. Also tried different network card so don't think it is a hardware problem since used two network cards, two hubs, two cables. Only leaves Windows getting confused.

- Collapse -
link
http://forums.gamedaily.com/index.php?showtopic=102256
Just found this link relating to sounds like same issue, the answer points to Microsoft Windows corrupted winsock file. I haven't tried the fixes yet not til the morning. But makes sense it's a Windows problem and not a hardware issue.

CNET Forums