General discussion

Static picture, crackling sound on one TV channel

I only have the coaxial cable connection, not a box, on an upstairs TV. On occasion, one or two channels (the same each time) will get a static picture and crackling sound and it'll go away within a couple of days. About a week ago, the TV did it again and one of the channels corrected pretty quickly, the other is still bad. I brought in a small TV I have and connected it to the cable and that same channel works just fine. So what's with one channel on this particular TV??

Discussion is locked

Follow
Reply to: Static picture, crackling sound on one TV channel
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Static picture, crackling sound on one TV channel
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Me too.

I had an OTA channel (over the air) that did that. It was a problem at the station and not my gear. Months passed and then magically it cleared up. And yes it was fine on another TV.

The ONLY thing you can try is to make sure the TV firmware is up to date and if that is unacceptable, return the set as defective.

- Collapse -
(NT) Thanks for the response/advice

CNET Forums

Forum Info