Question

SSD won't format

Hi,

The company I work for lost the BitLocker key for a few of their laptops and a recent Windows update somehow prevented Windows from booting correctly (infinite boot animation, like this). When it does occasionally boot it asks for the BitLocker key.

We have resigned ourselves to the fact that we have lost all data on the SSD then, so have attempted multiple times to reformat the drive. If I do it with Windows 10 install USB drive, it claims to reformat the SSD successfully after working for 10 minutes. Then when I proceed to Windows install it stays at 0% for around 5 minutes then gives a 0x80070057 error. Google doesn't help much there.

Trying to format format with Linux distros shows other problems; I can delete the partitions, formatting them gives various errors and rebooting shows the drive unchanged! All partitions still there!

Please help me someone.

Technical specs:
Drive model XXM30 (256 GB)
Laptop model L322X

Discussion is locked

Follow
Reply to: SSD won't format
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: SSD won't format
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
Try the old GPARTED method.

Boot up GPARTED and delete then write out the changes. DO NOT PARTITION OR FORMAT.

Now boot again with GPARTED (what this is, is on the web.)

What happens?

Also, if this is that locked and there is no TPM etc, check the drive warranty.

- Collapse -
Tried that...

Thank you for your response. The drive appears unchanged yet again after that.

- Collapse -
Next up. DBAN.

Let's be sure to try this in some USB housing as well.

You call these expensive, I checked and about 150USD so not overly expensive.

It appears to be shipped in 2015 and most have more than a few year warranty. I do encounter folk that will buy a new one rather than call the maker for support.

- Collapse -
Some more information

This laptop needs to be ready for use again in 3 days. The price you found was probably from here, correct? Shipping to South Africa will take them 2-4 weeks.

Buying the same thing new here is near to the equivalent of $500. Second hand is much more realistic, but takes time too.

And I forgot to mention that the laptop does have a TPM chip.
Also a colleague did try using a USB enclosure. I am beginning to think that either BitLocker is derping around or the drive is broken.

- Collapse -
I was wrong about the part number

Turns out it's actually a 0XXM30

- Collapse -
Re: 0XXM30

That's $129.99 used or refurbushed at https://www.amazon.com/gp/offer-listing/B01EZVCD5O/ref=dp_olp_all_mbc?ie=UTF8&condition=all.

It's an 256 GB SSD with an mSATA-interface. Might be somewhat difficult to find a new one.

Anyway, if you don't keep spare parts in the IT dept for hardware that can't be delivered in 3 days, it's an unrealistic requirement that these laptops have to be ready in 3 days. Your manager should understand that.
And it might be an incentive to have a better procedure for storing Bitlocker-keys.

- Collapse -
I give up...

I agree with you completely. Unfortunately the Bitlocker-keys are in a password protected file that a previous employee has forgotten the password for.

I think I'll just find the best quotes and see what le boss has to say.
Thanks for trying.

- Collapse -
Re: agree

Let's say that registering Bitlocker-keys, serial numbers, license codes, service tags and such is a responsibility of the IT department that owns and maintains the laptops. Not of the employee that happens to use the laptop at a certain moment.

The acronym here is CMDB. See https://en.wikipedia.org/wiki/Configuration_management_database
Big companies can have complex systems for such. Small companies can use spreadsheets, for example.

- Collapse -
Maybe that's why he is no longer here...?

Funny enough, I am a replacement for him in the IT department in a small web development company...

We currently have all our assets managed in a SQL database that is backed up nightly.

- Collapse -
I worry you didn't try the erase in some USB case.

Yes, I get it that you may have to pay more, wait longer but if your IT isn't on the ball about bitlocker, keys and such, then demanding 3 day turnaround is just a fantasy.

I know some bosses are pushy about this so keep your cool and work the issue.

If there is no budget to fix this, then it may go unsolved.

-> HOWEVER I don't read where you are working with the laptop and SSD maker. Some IT staffers refuse to make calls.

- Collapse -
Yields the same results...

BIOS doesn't have the option to disable TPM, so one of the things we tried is a colleague took the drive home to use it with his laptop that doesn't have TPM, using an mSATA to USB adapter. Unfortunately same results; it claims to successfully have its partitions deleted, you cannot format it and rebooting has he partitions reappear.

On Friday night I took the laptop with the drive back in it to our supplier and I'll just wait on them and my boss's response.

- Collapse -
Perils of TPM and locked drives.

At least you know it's so secure you can lock yourself out too.

- Collapse -
If you just want now to clean it

Why didn't you use GPARTED in effort to repartition the drive? If that fails, there is a dd command in Linux that starts with the first bit on a drive and goes t othe last bit, zeroing the entire drive.

- Collapse -
Tried that too

Tried GPARTED, Unfortunately same results; it claims to successfully have its partitions deleted, you cannot format it and rebooting has he partitions reappear.
A Linux wizard tried a bunch of commands for multiple hours all returned various errors.

- Collapse -
Answer
Re: drive

A 256 GB SSD isn't so expensive. So considering it lost in stead of spending hours to reuse it isn't a very bad idea.

- Collapse -
Last resort

Thank you for your response. Unfortunately this SSD has a rather weird interface and exceedingly expensive in my area. A replacement is a last resort.

- Collapse -
Answer
Did you try Secure Erase?

There's a utility app/program called Secure Erase. It's included in a bunch of utility apps called Parted Magic. It's also included on another collection of apps called Ultimate Boot CD. And, it used to be available in DOS form from some University. All of the above are downloadable. For example:
https://partedmagic.com/

Secure Erase doesn't write 0's or 1's. It is an industry standard method of wiping a disc, including SSD's. Basically, it sends a precise voltage spike to the drive which instantly erases everything, leaving it ready to initialise and format again.

- Collapse -
I did not try Secure Erase

"Secure Erase doesn't write 0's or 1's. It is an industry standard method of wiping a disc, including SSD's. Basically, it sends a precise voltage spike to the drive which instantly erases everything, leaving it ready to initialise and format again." Where did you find that description? It violates logic...

But I have already returned the laptop to our supplier, thank you for your offer.

- Collapse -
Secure erase

That precise voltage spike works on a ssd by doing a bulk erase of blocks.

I doubt that will work on a hdd.

- Collapse -
Secure erase

I see. I'll take your word for it until I need to test it myself. Thank you

- Collapse -
A Quick Explanation

Couldn't find my original source for the ssd-erase-by-precise-voltage-spike comment, but here's a similar description of how it works:
http://www.overclock.net/t/1227597/how-to-secure-erase-your-solid-state-drive-ssd-with-parted-magic

I have used this secure erase feature of Parted Magic several times. They say it will take up to 2 minutes, but my experience on SSDs up to 480GB capacity has been that it takes about 2 to 4 seconds. After that, I checked the first couple of SSDs that were secure-erased and couldn't find any data on the drives when using good ol' Recuva software. Completely erasing all data in 2 to 4 seconds, with NOTHING recoverable afterwards, could NOT be done by writing 0s and 1s. No SSD can write that fast!

- Collapse -
Answer
In the interim...

You didn't say why this particular drive has to be SSD? If the delivery is so long or the local prices unrealistically high, why not offer your boss three options, buy local for many Rand, buy from overseas for less and wait or buy overseas for less and in the interim put a 7200 rpm spinning rust HDD (WD Black) in the laptop and transfer to SSD when the new drive arrives?

Also, since the data set/DB with the bit locker key in it is presumably not on the stuck SSD, you might have more success in breaking into that dataset/DB. What have you to lose?

- Collapse -
About the HDD option.

Unfortunately it's an ultrabook. The SSD is about the size of a flash drive, an internal HDD will never be an option. BUT I did experiment with an external Windows OTG which the clumsy owner of the laptop outright refused because he knows he will break it.

The only stuff we lose are some of the user's personal pictures, which were not supposed to be on a work machine anyway.

We tried retrieving stuff from the drive, but even cloning it is not possible as bitlocker doesn't present the drive as an actual readable storage device until it is unlocked.

- Collapse -
Answer
Format

Look around in the bios and see if you can disable the tpm.

If so then back to gparted to see if you can delete all the partitions.

- Collapse -
Option unavailable.

That setting is not in this laptop's BIOS and using gparted on another device without TPM gives the same results; it claims to successfully have its partitions deleted, you cannot format it and rebooting has he partitions reappear.

CNET Forums

Forum Info