Try the router set to WPA security. There are some other reasons such as failing routers and more but given so little details about the router settings I'll just note the one that helps the most.
Bob