Windows Legacy OS forum

General discussion

Spooler SubSystem App error - PC Hell! Help!

by jbobonline / April 5, 2009 8:48 AM PDT

Spooler SubSystem App error - PC Hell! Help!

I am really hoping someone can help with this because i am in PC Hell - spent hours and can't figure this out.

HISTORY
1 Had an HP DeskJet and Adobe Pro 6.0 installed - both worked fine. Used Adobe Pro to make PDFs which I believe uses print spooler to do so

2. Then made the HUGE mistake of installing an old (circa 2003??) Dell A920 all-in-one printer/scanner/copier

3. After Dell installed, it seemed to take over the system:
a) Adobe Pro would no longer make PDFs/print, HP DeskJet was "missing/could not find printer"
b) Tried to uninstall and reinstall Adobe and HP DeskJet using add/remove programs - it would not let me - said Error 1920 Service Print Spooler (Spooler) failed to start.

Verify that you have sufficient privileges to start system services. This is baloney as I AM the admin for the computer

4. Finally found a patch/app on the Dell site that (supposedly) uninstalled (fully?) the Dell A920.

BUT NOW:
5. I am still unable to print/make PDFs

6. When computer starts I am getting errors "Spooler SubSystem App has encountered an error and needs to close....."

7. I have tried bunch of things to fix #s 5 and 6, including checking services.msc to ensure spoolsvc.exe set to auto (it is), adding Spooler as exception in DEP.

8. Also, when I go into services.msc and look at status of spoolsv.exe it shows "Auto" but always says it is stopped. When I manually start it, I later get error pop ups when

trying to open MS Office docs "Microsoft Visual Basic Compile Error in hidden module...."

9. I am at a loss - I see MSFT has an article at http://support.microsoft.com/kb/324757 that MAY be applic/be a fix but the process they outline is ridiculously complex.

Does anyone have any other suggestions? This is driving me nuts and I can't print or make PDFs, which I do dozens of times a day.!!!!

My system runs XP SP2.

Thanks!!

Discussion is locked
You are posting a reply to: Spooler SubSystem App error - PC Hell! Help!
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Spooler SubSystem App error - PC Hell! Help!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
What would happen if...?
by MarkFlax Forum moderator / April 5, 2009 8:43 PM PDT

No expert here, and you may have tried this already, but what would happen if;

1] You disconnected the HP Deskjet printer from the computer, boot up, then delete it from Printers and Faxes in the Start menu, reboot.

Rebooting between each step removes any un-required registry entries that may otherwise still be present in memory.

2] Then uninstall Adobe Pro from the Add/Remove programs in the Control Panel, then reboot. Check the Adobe web site for any specific Adobe Uninstaller files/instructions.

3] Start the Spooler Service.

4] Reload the HP Deskjet printer software before re-connecting the printer. Close down, connect the printer, and boot up.

5] Install the Adobe software.

Amongst other problems that may arise, I can see one immediately at part 1]. If the Spooler SubSystem is not started, then "Printers and Faxes" will not show any installed printers, so see if you can start the Print Spooler manually from the Services console. If that fails in normal mode, see if you can do that in Safe Mode, (Instructions here).

One other thing. Since this is XP, any chance that you have a System Restore point set to sometime just before you added the older printer? If so it might be worth a try to restore to that point first.

Sorry I can't offer anything more concrete.

Mark

Collapse -
jbobonline
by PudgyOne / April 6, 2009 2:22 AM PDT

Here are a few suggestions.

Try system restore and go back to before the A920 was installed.


Do you have Internet Explorer 8 installed?


Did you ever fix your Error 1920 Spooler message?

http://kb.adobe.com/selfservice/viewContent.do?externalId=331727


Please include the important information here as Mark and the gang are more than willing to help you.


Rick

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?