have u tried using the default setting-
on mine its microsoft sam.

and have u tried using the accessibilty options,
it has a speech option in it also.