It's time to call HP. Some of their OEM versions required you use a HP supplied patch first. There is also some pirate version of XP out there, but I only bring it up since you are having an issue. HP doesn't use that version but I have run into it.

Bob