Hi mahaju,

Try this Microsoft fix-it.
Please ensure that the operating system has the latest service pack.You should have Windows XP SP3 for the fix-it to run.
If this does not help. try to start the audio service.
a. Click Start, then click on Run and type 'Services.msc' without quotes and press Enter.
b. Double-click Windows Audio Service.
c. Set the Startup type to Automatic.
d. Start the Service.
e. Click OK.

This could also occur due to disabled sound options in control panel. Please share the name of the devices listed in Sound, video and game controllers as an image(if possible). Try these steps to fix it:
1. Click the Start button, then click Control Panel.
2. The Control Panel window appears.
3. Double-click System.
4. The System Properties window appears.
5. Select the Hardware tab, then click the Device Manager button.
6. The Device Manager window appears.
7. Click the (+) symbol next to Sound, video and game controllers.
8. Double-click the audio driver in Device Manager and select the Properties tab.
9. Click the (+) sign next to Audio Devices and select the system's audio controller(an example is shown in the image): Image
10. Click the radio button next to Use audio features on this device, apply the settings and restart the system: Image

Hope this helps.
Please reply if you have any further questions.

Thanks and Regards,
Manpreet C