HolidayBuyer's Guide

Linux forum

Question

Sound Juicer unstable/crashes

by 69Rixter / September 8, 2014 5:19 AM PDT

Afternoon:

Since install of LinuxMint17, the use of Sound Juicer has been an overall, total failure. I've installed/uninstalled 3 or 4 times. When I 'reinstall", S.J. works fine for a bit, then gets buggy and ultimately crashes. Tried to use VLC, but it only wants to rip a song at-a-time (not entire CD). haven't messed with Brasero. #1. Can Sound Juicer be fixed? #2. How can I access Ubuntu Software Center? The reason being: I want to have options for other CD/DVD player/rippers, install "resticted extras" and have access to other programs not available by LM17 Softmare Mgr.
[HP2000-210 LinuxMint17 cinnamon 64bit]
I certainly hope I don't have to enter the "rant" forum!
THANX:
Rick

Discussion is locked
You are posting a reply to: Sound Juicer unstable/crashes
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Sound Juicer unstable/crashes
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
No Rant zone.
by R. Proffitt Forum moderator / September 8, 2014 5:33 AM PDT
Collapse -
Answer
synaptic package manager
by James Denison / September 8, 2014 5:53 AM PDT

is available on Mint Linux. You can find all sorts of programs there to use. My preference for CD's and DVD's is K3B.

Collapse -
Syn Pac Mgr reply
by 69Rixter / September 8, 2014 9:09 AM PDT

Evening James:

I really need to address the issue of getting S.J. to operate properly. As far as getting any other program for ripping, could not find K3B in LM17 packages and have to get U.S.C working before I can check there. You know...dammed if I do, dammed if I don't. THANX
Rick

Collapse -
Get whatever you want
by itsdigger / September 8, 2014 9:23 AM PDT
In reply to: Syn Pac Mgr reply

using the Terminal. sudo apt-get install synaptic

Digger

Collapse -
Whatever
by 69Rixter / September 8, 2014 10:01 AM PDT
In reply to: Get whatever you want

Hey Digger:

Thanx for replying. OK, I did what you said but did so in this way: delightlylinux.wordpress.com/how-to-install-unbuntu-software-center-in-linux-mnt-17/. After doing so, when I open U.S.C. it comes up, then almost immediately vanishes???? Can you give me the "fix" for it? BTW, I like to use copy/paste from the keyboard and am not able to do so w/ LM17. What's going on? Three problems all at once where it had been operating good for 2 1/2 weeks.

Collapse -
I'm not really a Mint user
by itsdigger / September 8, 2014 10:06 AM PDT
In reply to: Whatever

but why not open the terminal and type in " sudo apt-get update" put in password ..hit enter follow any instructions

I reboot and see if it straightens out

Digger

Collapse -
copy paste
by James Denison / September 8, 2014 12:06 PM PDT
In reply to: Whatever
BTW, I like to use copy/paste from the keyboard and am not able to do so w/ LM17. What's going on? Three problems all at once where it had been operating good for 2 1/2 weeks.

Yes, it is supposed to do copy paste and mine does. Was it doing it before and then quit doing it?
Collapse -
I guess I was too vague.
by R. Proffitt Forum moderator / September 8, 2014 9:31 AM PDT
In reply to: Syn Pac Mgr reply

The wiki I linked to tells us "Sound Juicer is an GTK+-based graphical front-end" to some other tools. The failure therefore must be in those other tools or is just another laptop in need of some TLC.
Bob

Collapse -
When Sound Juicer is installed using synaptics
by itsdigger / September 8, 2014 9:39 AM PDT

Brasero-common
gstreamer 1.0-plugins-ugly
and
libbraseromedia3-1 are installed

Digger

Collapse -
that should read
by itsdigger / September 8, 2014 9:43 AM PDT

libbrasero-media3-1

Digger

Collapse -
Used Pkg. Mgr
by 69Rixter / September 8, 2014 10:03 AM PDT
In reply to: that should read

hey Digger:

No, I used the Soft. Mgr. in LM17 to install.

Rick

Collapse -
Too Vague
by 69Rixter / September 8, 2014 9:50 AM PDT

Bob:

Just what are you saying?

Rick

Collapse -
That it's likely to be something other than sound juicer.
by R. Proffitt Forum moderator / September 8, 2014 9:59 AM PDT
In reply to: Too Vague

The wiki noted it as a graphical front-end to the cdparanoia CD ripping library. Now there are some that want a step by step on that but think it over. It's unlikely that front ends fail but what they are using can fail. Look over the other packages.

And then again, the machine it's on looks like something we see in the shop a lot with folk griping about virus, failing apps and it's the same old story of canned air and heat sink compound work. There are a few that dig in their heels on the work so we thank them for considering our shop, close the bill and send them on their way. Sometimes they are back to get it done since they had other shops take them to the cleaners.
Bob

Collapse -
dependencies
by James Denison / September 8, 2014 12:25 PM PDT

when you install the program from package manager or apt-get make sure to include all "recommends". Previously Mint did that, but without a hack it no longer does automatically, unless you tell it to each time. That's in the filters section of package manager.

Here's an informative thread on it.

http://forums.linuxmint.com/viewtopic.php?f=90&t=167424&hilit=+recommends

In the info or man page you can find this concerning recommends.

OPTIONS
All command line options may be set using the configuration file, the
descriptions indicate the configuration option to set. For boolean
options you can override the config file by using something like
-f-,--no-f, -f=no or several other variations.

--no-install-recommends
Do not consider recommended packages as a dependency for
installing. Configuration Item: APT::Install-Recommends.

--install-suggests
Consider suggested packages as a dependency for installing.
Configuration Item: APT::Install-Suggests.


--reinstall
Re-install packages that are already installed and at the newest
version. Configuration Item: APT::Get::ReInstall.


Here's the shorter help file, it doesn't mention recommends, so have to consult the man page on that command.

~ $ apt-get -h
apt 1.0.1ubuntu2 for i386 compiled on Jun 13 2014 17:41:42
Usage: apt-get [options] command
apt-get [options] install|remove pkg1 [pkg2 ...]
apt-get [options] source pkg1 [pkg2 ...]

apt-get is a simple command line interface for downloading and
installing packages. The most frequently used commands are update
and install.

Commands:
update - Retrieve new lists of packages
upgrade - Perform an upgrade
install - Install new packages (pkg is libc6 not libc6.deb)
remove - Remove packages
autoremove - Remove automatically all unused packages
purge - Remove packages and config files
source - Download source archives
build-dep - Configure build-dependencies for source packages
dist-upgrade - Distribution upgrade, see apt-get(8)
dselect-upgrade - Follow dselect selections
clean - Erase downloaded archive files
autoclean - Erase old downloaded archive files
check - Verify that there are no broken dependencies
changelog - Download and display the changelog for the given package
download - Download the binary package into the current directory

Options:
-h This help text.
-q Loggable output - no progress indicator
-qq No output except for errors
-d Download only - do NOT install or unpack archives
-s No-act. Perform ordering simulation
-y Assume Yes to all queries and do not prompt
-f Attempt to correct a system with broken dependencies in place
-m Attempt to continue if archives are unlocatable
-u Show a list of upgraded packages as well
-b Build the source package after fetching it
-V Show verbose version numbers
-c=? Read this configuration file
-o=? Set an arbitrary configuration option, eg -o dir::cache=/tmp
See the apt-get(8), sources.list(5) and apt.conf(5) manual
pages for more information and options.



Also you can use "aptitude show" followed by the package name and see what it is supposed to have and what you have. For instance, here is the k3b information being shown on my mint 17 linux system.


~ $ aptitude show k3b
Package: k3b
New: yes
State: installed
Automatically installed: no
Version: 2.0.2-7ubuntu1
Priority: optional
Section: universe/otherosfs
Maintainer: Kubuntu Developers <kubuntu-devel@lists.ubuntu.com>
Architecture: i386
Uncompressed Size: 1,848 k
Depends: kde-runtime, libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libk3b6 (= 2.0.2-7ubuntu1), libkcddb4
(>= 4:4.3.4), libkcmutils4 (>= 4:4.4.95), libkde3support4 (>= 4:4.4.4), libkdecore5 (>=
4:4.4.95), libkdeui5 (>= 4:4.5.85), libkfile4 (>= 4:4.7.0), libkio5 (>= 4:4.4.4),
libknotifyconfig4 (>= 4:4.4.4), libqt4-dbus (>= 4:4.5.3), libqt4-qt3support (>= 4:4.5.3),
libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.8.0), libqtgui4 (>= 4:4.8.0), libqtwebkit4,
libsolid4 (>= 4:4.4.4), libstdc++6 (>= 4.1.1), k3b-data (= 2.0.2-7ubuntu1), wodim |
cdrskin, cdparanoia, cdrdao, genisoimage
Recommends: dvd+rw-tools, vcdimager, growisofs
Suggests: k3b-extrathemes, k3b-i18n, normalize-audio, sox, movixmaker-2, kde-config-cddb,
libk3b6-extracodecs
Replaces: k3b-data (< 1.66.0~alpha2-1)
Description: Sophisticated CD/DVD burning application
K3b provides a comfortable user interface to perform most CD/DVD burning tasks. While the
experienced user can take influence in all steps of the burning process the beginner may find
comfort in the automatic settings and the reasonable k3b defaults which allow a quick start.
Homepage: http://www.k3b.org


Collapse -
PS - at the bottom of linked thread
by James Denison / September 8, 2014 12:38 PM PDT
In reply to: dependencies

You will find an easy way to use the package manager to install all suggests and recommends to any package you are installing.

Collapse -
it's there
by James Denison / September 8, 2014 12:04 PM PDT
In reply to: Syn Pac Mgr reply
Collapse -
Sound Juicer Failure
by 69Rixter / September 9, 2014 3:38 AM PDT
In reply to: it's there

To Everyone:

First of all, I appreciate all who've replied. To Bob: Care to elaborate on "canned air and heat sink compound"? OK, I've installed SJ via the terminal: follwing is a detailed step-by-step of ripping 9 CD's:

OK, I installed/launched SJ from terminal. First 2 "rips" ran the best/fastest I've ever had it run. 3rd rip: took a while "retrieving tracking list", but ripped . 4th rip: couldn't get it to open CD, had to "close" program/relaunch from terminal. Took awhile, but opened and ripped. 5th Cd rip: launched from "menu" and would not retrieve tracks-no rip. 5th CDrip- re-launched from terminal; took great deal of time to 'retreiving tracking list"; started ripping from 5.7x, -2.4x-4.2x-5.1x-5.7x-6x-6.3x-6.7x, then started ripping at regular speeds(anywhere from 8x to 10+ x) 6th CDrip- had to 'launch" from terminal twice: (first would not retrieve listing) same ripping pattern as above; i.e. started ripping very slow and slowly built to regular ripping speed) 7th CD rip; started ripping, then crashed; re-open from menu and started ripping @ 4x gradually to 6.3x, then back to 6x and again gradually rose to "regular" ripping speeds. 8thCD; started ripping @ 9.4x, slowly reverted to 8.7x and at end of rip(9 songs) was @ 8.9x 9th CD: (still launched from menu) started @ 8.8x stayed there till 4-5 song rip; then slowly rose to 9.6x by10th song (end of CD).
So, there it is. I know this was rather redundant, but I hope by showing a "step-by-step" it might provide something to someone who'll figure it out. Perhaps(?), it may run correctly now. Seems the last 2 rips were fairly stable.(?) Well, we'll see what happens when I get a few more CD's to rip. I really hope I don't have to come back here for an explanation and/or "fix:. Would welcome comments on this post!
THANX:
Rick

Collapse -
The thing is
by R. Proffitt Forum moderator / September 9, 2014 3:45 AM PDT
In reply to: Sound Juicer Failure

Canned air use and replacing heat sink compound has many videos on YouTube. I can't duplicate those fine tutorials but once in a while a member will insist. At this point I think I have to write they need to take it to a shop counter and have it done?

Sorry about my thought about it not being Sound Juicer at all but the underlying tools it is calling or the hardware. Given the machine's creds it looks like the usual and the fact you are asking about how to use the common cleaning tool and compound leads me to believe it needs to be done even more.
Bob

Collapse -
As James referred to
by itsdigger / September 9, 2014 3:50 AM PDT
In reply to: Sound Juicer Failure
Collapse -
seems the program
by James Denison / September 9, 2014 4:20 AM PDT
In reply to: Sound Juicer Failure

has a limited cache size that it's failing to dump between rips.

Collapse -
In fact, it could be swap limited
by James Denison / September 9, 2014 4:23 AM PDT
In reply to: seems the program

Open system monitor next time before you start the rip, see how much swap is used, then while it's ripping the CD or even better a DVD, watch the swap in system monitor, see if it starts filling up. If so, then you may need to expand the size of SWAP.

Collapse -
Good ideas.
by R. Proffitt Forum moderator / September 9, 2014 4:28 AM PDT
In reply to: seems the program

I can't check the member's prior posts but one member has installed Linux is some tight space and it was a sure bet they would have issues like this one.

It's a 3GB PC from the looks of things so cache and paging sizes may need to go way up.
Bob

Collapse -
yes, this thread indicates
by James Denison / September 9, 2014 5:33 AM PDT
In reply to: Good ideas.
Collapse -
Given a CD can be about 700MB
by R. Proffitt Forum moderator / September 9, 2014 6:08 AM PDT
Collapse -
Reply to "Yes, this thread indicates" -JAMES
by 69Rixter / September 9, 2014 7:31 AM PDT

Filesystem 1K-blocks Used Available Use% Mounted on
/dev/sda1 73833688 56123852 13936192 81% /
none 4 0 4 0% /sys/fs/cgroup
udev 1455752 4 1455748 1% /dev
tmpfs 294256 1324 292932 1% /run
none 5120 0 5120 0% /run/lock
none 1471260 32464 1438796 3% /run/shm
none 102400 20 102380 1% /run/user
/dev/sdb1 7602860 6364684 1238176 84% /media/rick/Tiny One
/dev/sdc1 1949340 1313952 635388 68% /media/rick/MYLINUXLIVE

Does this tell you anything significant? THANX

Rick

Collapse -
that should be enough room
by James Denison / September 9, 2014 8:06 AM PDT

56 GB used, 14 GB available. I see plenty of room if the program is caching the rip correctly and then releasing when it goes to a different DVD to rip. Some software will hold the last rip on cache in case it's to be done again, but should dump when it's told to rip a different DVD. I would suspect the program causing the problem at this point. All I can say is k3b, use the small letters and find in package manager and give it a try. Be sure to let all recommends load with it too as outlined above, and maybe suggestions too.

Collapse -
Enough Room Reply
by 69Rixter / September 9, 2014 8:43 AM PDT

Evening James:

So, we've determined it wasn't a "space" issue. And the fact that it did a 'decent" job of the last "rip", well, what do you think? Bob, want to weigh in? You're correct in stating we may have to wait until the next rip before determining anything. I'll check out K3b (once I find it), and would like to get UBu Sft. Cent. straightened out so I can use it. I would also like to check out RubyRipper, if I can find it! So, I hope we can get this bug worked out for I'm sick of fighting with this laptop/LM17 already. Might I ask: could you or anyone recommend a good tutorial on setting up partitions on a HDD. I don't like that the installer divided equal space to music and video. Anyways, THANX for all your help!! I've appreciated it.
Rick

Collapse -
Should be enough reply
by 69Rixter / September 10, 2014 10:26 AM PDT

hey James.

Looking over the info I provided, just how did you determine the use/availability aspect of the HDD? Also, ripped 1 more CD today and it(SJ) seemed to work without flaw. I don't know what to say except that it's like takin' your car to the dealership when you detect a problem...when you get there, there problem disappears! Do you agree with or know of why Bob is insistent on cleaning the laptop to solve the problems? I'm not saying cleaning it isn't always a good step, but overheating is not (I'm almost certain) causing the strange problems I was having.
Thanx:
Rick

Collapse -
interpreted
by James Denison / September 10, 2014 1:57 PM PDT
In reply to: Should be enough reply

Filesystem 1K-blocks Used Available Use% Mounted on
/dev/sda1 73833688 56123852 13936192 81% /


It says the file system currently booted aka root (which it reports first in order) is on device sda1, and the sizes are given in KB's sized blocks.

Size = 73,833,688 KB's
Available = 56,123,852 KB's
Used= 13,936,192 KB's

And the used part is 81% of the total space on the root / drive.

two other physical drives were 17.6 GB and sdc1 was definitely a 2GB size flashdrive.

there was other info, that first line is a descriptive header line and then you look at what's under the columns, easier maybe to put in a text file and make the columns wider.

Cleaning doesn't hurt if done right, only you can make that call for sure.

Collapse -
Interpreted reply
by 69Rixter / September 11, 2014 5:31 AM PDT
In reply to: interpreted

Afternoon James:

OK, now I see (said the blind). Thanks for explaining. OK, back to the aggravation. This morn. I started "ripping" again to see how it would perform. THIS IS FOR EVERYONE:

Opened from terminal (which I shouldn't have to be doing). 1st CD: took inordinate amount of time "retrieving tracking listing" ; ripped @ 2.3x to 7.4x 2nd CD: took inordinate amount of time "retrieving tracking listing" ripped@ 7.4x steadily regressed to 5.4x, then gradually back to 7.9x 3rd CD: From here on every CD took inordinate amount of time retrieving tracking listing ripped @ 7.4x to 5.3.x- steadily back to 8x. 4th CD: @8x to 6.7x back to 9.3x 5th CD:
9.3x gradually back to 6.7, then gradually back 8.4x 6th CD: 8.4 slowly back to 7.3, then back to 9.3x 7th CD: 9.3x back to 8.7 then quickly rose to 10.4x eventually climbing to 11.4 8th CD: @11.4x gradually back to 8.2x (over 9 songs).
Here is terminal readout: for the most part it read---unrecognized relation attribute: 'type-id' (over and over again) occasionally it would spit out; unrecognized release element unrecognized work element unrecognized track attribute: 'id'. On the 5 or 6th CD it spit out: (sound-juicer:3523) :GStreamer-CRITICAL **: gst_buffer_unmap: assertion 'GST_IS_BUFFER (buffer)' failed and (sound-juicer:3523) :GStreamer-CRITICAL **: gst_mini_object_unref: assertion 'mini_object !=NULL' failed So, here it is and here we go! Anyone got an idea of what's going on/ what I need to do to correct? This is getting on my nerves!!

THANX:
DevilRick

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

The Samsung RF23M8090SG

One of the best French door fridges we've tested

A good-looking fridge with useful features like an auto-filling water pitcher and a temperature-adjustable "FlexZone" drawer. It was a near-flawless performer in our cooling tests.