Camcorders forum

General discussion

Sony HDR-FX7 Capturing Problem

by Chase C / November 25, 2008 8:11 AM PST

Hi I'm hoping someone can help me out. I have a Sony HDR-FX7 & I can't seem to capture from it. I'm using firewire & my computer(PC) only recognizes it as a AV/C Tape Subunit Device & is unable to read from the camcorder.
I was wondering what the problem is, Do I need to upgrade my video card in my computer or new capturing software(I'm using roxio) or is there something else that can fix this?

Thank you for your time & I look forward to any repsonses.

Discussion is locked
You are posting a reply to: Sony HDR-FX7 Capturing Problem
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Sony HDR-FX7 Capturing Problem
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Capturing problem...
by Papa Echo / November 26, 2008 6:15 AM PST

?What program are you using to capture the footage ?
?Which computer OS ?
?Drivers installed for the mother board ?(if you have reformated)
?How were you informed that it was a AV/C Tape Subunit Device ?

Collapse -
Capturing problem
by Chase C / November 27, 2008 2:18 PM PST
In reply to: Capturing problem...

I'm using Roxio 7.5 to capture, I have used it before with an old 8mm digital.
The operating System is Xp Pro.
The original drivers are still installed to the mother board & using an onboard firewire.
I know that it comes up as AV/C Tape Subunit Device through using Roxio, but when I click on it to capture from it it says unexpected application error.


Collapse -
Papa Echo - I don't mean to butt-in... but
by boya84 / November 27, 2008 11:33 PM PST
In reply to: Capturing problem

Roxio 7.5 appears to be from about 2005. Fine for analog and likely Digital8 and DV... But the HDR-FX7 captures HDV by default (and can capture DV when that option is selected).

I poked around the Roxio support area for a bit and did a light stroll through some of the discussion groups that hit, but there is no detail available on what video formats version 7.5 supports (Roxio appears to be at version 9.x, now).

I found more detail here:
and still no mention of HDV.

This would explain the visibility of the camcorder (the firewire connection), but inability to get the HDV encoded video.

If you record in DV (not HDV) and try that import, what happens?

Collapse -
No problem....
by Papa Echo / November 27, 2008 11:51 PM PST

It is nice to share ideas. This forum is for every one.

Collapse -
Applicartion error ?
by Papa Echo / November 27, 2008 11:49 PM PST
In reply to: Capturing problem

That's probably the clue. Roxio is no longer doing its job - reinstall or get a newer version.

Try using Windows Movie Maker - it comes free with Windows XP

Collapse -
Windows MovieMaker
by boya84 / November 28, 2008 1:55 AM PST
In reply to: Applicartion error ?

in the XP version - cannot deal with HDV, either... only the version that ships with Vista.

Consumer HDV was new in 2005.

Collapse -
Free stuff....
by Papa Echo / November 28, 2008 8:56 AM PST
In reply to: Windows MovieMaker

Maybe something can be found HERE....

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?