Question

Sony DSC-W350 date & time freeze problem

Hi guys!

So, I bought this camera 2 yrs ago and I didn't have any problems till now! So, once I turned on the camera and suddenly the camera asked me to enter the date and time, I entered it and I after pressing OK, the camera froze! There is no way to pass this date and time entering since it appears each time when I turn on the camera. I tried everything: from reseting, to initializing...I managed to initialize the camera by plugging it with usb to computer. After unplugging it from the computer, the camera works normally, and there aren't any problems but once I turn the camera on without having it plugged to a pc, the date and time window appears and the camera freezes once again after pressing OK.

I suspect this is a software problem but I honestly don't know how to solve it. Any ideas? Is there any way to reinstall the firmware?

Discussion is locked
Follow
Reply to: Sony DSC-W350 date & time freeze problem
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Sony DSC-W350 date & time freeze problem
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
One Question

Sounds like a battery problem.

You didn't say, so I have to ask.
Have you charged the battery?
Charge for 4 hours according to Sony.

..

- Collapse -
Still appearing

Hm...I guess that would be it...

I have charged it but still it appears. Any other suggestion?

- Collapse -
Your Reply is not clear

Are you saying that after charging the battery that it no longer hangs?

But the enter date/time question still appears?

It should appear after you charged the battery and turned-on the camera for the first time.
It should stop appearing the next time you turned the camera-on.
Depending upon how they built the circuit to power the date/time memory, it could take several on-off cycles to provide enough power to maintain the date/time memory.

- Collapse -
Sorry for the bad reply

So, I charged the battery as you said, for a very long time but this screen still appears and there is no way of passing it. I mean, when I click OK for the entered time and date, as I mentioned, the cameras freezes... I tried to pass it for more than 100 times and the battery is full so I do not quite understand what could be the problem...Thanks!

- Collapse -
Thanks for the update

Sorry for the delay, my Internet service has been down.
It sounds as if the camera firmware is hanging up.
I suggest you call Sony service.
See if they have a solution.
If not they can possibly give you a guesstimate for repair costs.
..

CNET Forums