HolidayBuyer's Guide

Laptops forum

General discussion

Someone Please Help

by StargateFan / August 15, 2007 12:09 PM PDT

I realize that this should be in the Windows Vista forum, however nobody responsed in that forum, so becaue Vista is running on my laptop, I figured I could get away with it here. Alright here is my dilema, I am doing Windows Vista boot screen modifications, I have done everything but replace the current system file containing the instructions for the boot screen with my own modified file. Simple solution right, I copy the new file in the C:\Windows\System32\Boot\en-us\ and replace the old one with the new one.

Here's the thing though as a security precaution that I could understand, Microsoft has locked the system files, in order to do anything other then read only, you have to take control of the files. Alright so I go and do that by running the usual commands:

by running the Command Prompt in Admin mode I executed the takeown command

takeown /f %systemroot%\System32\Boot\en-us\winload.exe.mui

winload.exe.mui is the name of the file it is a multilingual user interface file. That app executes successfully. However I don't have control of the file yet. I have to take full control by executing a new command called icacls, which is a new form of cacls which is now depreciated.

therefore I exectue the command

icacls %systemroot%\system32\boot\en-us\winload.exe.mui /g <my username>:f

This is where my problem is the app returns this statement "no mapping between account names and security IDs was done"

I have even attempted to use the older cacls command in place of the newer icacls command, but still it returns the same error message.

And I have no control or permissions over this file. Any idea's any one? Thanks in Advanced.

Discussion is locked
You are posting a reply to: Someone Please Help
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Someone Please Help
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Just a guess
by PudgyOne / August 15, 2007 1:48 PM PDT
In reply to: Someone Please Help

do this in the safe mode and/or call the new startup screen the same name of the one you're replacing.

I don't get into these things.


Rick

Collapse -
RE: Just A Guess
by StargateFan / August 15, 2007 2:24 PM PDT
In reply to: Just a guess

Thanks for the response, finally. I have posted this message twice already under different titles once in the Vista forum and once in the laptop forum. I figured my current title would grab this post a little more attention.

As for your suggestions, first about safe mode. Safe Mode will make no difference when trying to edit system files. The reason being is that system files are protected by Vista's new security code, to be honest I forget what they call the code. I can see the point and reasoning of the security code.

About your second suggestion. The modified file is the same name as the file it will be replacing, I am doing a copy and replace, that is I am replacing the current file, the winload.exe.mui file, with my own modified file also entitled winload.exe.mui. It does not matter about the name of the files, I am touching a system files, which trips the security code. The only Microsoft allows a system Admin to modify a system file/files is for them to take ownership of the file, to prevent any old person from messing with the files.

But I can't take ownership as you have read from my post, that's where my problem lies, I can not seem to find a solution to the icacls/cacls return statement I get when trying to execute the commands. I can not even find a infromation on the error to even create a starting point where I could figure out a solution on my own. Thanks for the help though.

Collapse -
Something here says
by PudgyOne / August 15, 2007 6:48 PM PDT
In reply to: RE: Just A Guess

this might be apart of the answer

http://technet2.microsoft.com/WindowsVista/en/library/00d04415-2b2f-422c-b70e-b18ff918c2811033.mspx?mfr=true

I was also reading the Vista Security for developers. A little over my head but I understood a good amount of it. Look at these articles

http://www.google.com/search?hl=en&client=firefox-a&rls=org.mozilla%3Aen-US%3Aofficial&hs=arF&q=only+Microsoft+Vista+allows+a+system+Admin+to+modify+a+system+file&btnG=Search

From what I'm reading, Administrators can read system files and folders but cannot write to them. Note that this differs from previous versions of Windows.


Rick

Collapse -
RE: Something Here Says
by StargateFan / August 16, 2007 2:39 AM PDT
In reply to: Something here says

I appreciate the help. I have skimmed through most of the sections of that MS article you gave me. Unfortunately I am left with the same option, it is possible to modify System Files, however I the only way to do so is to take ownership of the files directory or the file, in my case I choose to take control of the file.

Now I take control of the file by executing the takeown command, now I own that file. Think of it has like a locked box, you can buy the box, and you own it, but you don't have the key to open it and use whats inside.

To get the key and open the box I need to use either the icacls or cacls command. This is the only possible way I have to modify, that system file or any system file for that case. I have to figure out a solution to the mapping error, I have to somehow map the account names with the security IDs.

But to be honest I have never seen this before, and I am advanced with computers and Windows, but I have never seen this before. I have tried to modify my security permissions via Local Security Policy.mmc, no luck. I have to figure out what the mapping error is trying to tell me is wrong. And from my current point of view, my security permissions should allow me to do this.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

The Samsung RF23M8090SG

One of the best French door fridges we've tested

A good-looking fridge with useful features like an auto-filling water pitcher and a temperature-adjustable "FlexZone" drawer. It was a near-flawless performer in our cooling tests.