Linux forum

General discussion

Some linux questions

by peenuts220 / August 3, 2004 3:29 PM PDT

I installed Fedora Core 2 for x86_64 systems. I am trying to get support for ntfs so i can mount my windows hd but when i run the rpm thing for it. It says it could not be installed. Is this cause by the x86_64 architecture, and if so is there another or a fix for it. Another thing does anyone know if there is a x86_64 linux version of Wolfenstein ET? Thanks

Discussion is locked
You are posting a reply to: Some linux questions
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Some linux questions
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re: Some linux questions
by R. Proffitt Forum moderator / August 3, 2004 11:15 PM PDT
In reply to: Some linux questions

Sorry, I don't know RH. But will share the Suse 9.1 comes with the 64-bit version good to go.

Also, KNOPPIX64 is ready and being upgraded as we speak. That's a no-install version you can see if they have it nailed in.

Bob

Collapse -
Re: Some linux questions
by David Utidjian / August 4, 2004 2:38 AM PDT
In reply to: Some linux questions

Where did you download the NTFS RPM from? What is the exact name of the RPM? Was it from here:
http://linux-ntfs.sourceforge.net/rpm/fedora2.html
What kernel are you currently running?
(output from uname -a)

If you can not gett he correct RPM to install the NTFS module you will need to re-compile the kernel with NTFS support enabled.

Note: In any case you will only be able to read from the NTFS partitions NOT write to it.

I have no idea if Wolfenstein ET will run in x86_64 Linux systems. Install it and tell us?

-DU-...etc...

Collapse -
Re: Some linux questions
by peenuts220 / August 4, 2004 2:51 AM PDT

alright well i wasnt really planning on writing in my windows hd i just want to access some media files. when i type "uname -a" i get this

Linux dhcppc2 2.6.5-1.358 #1 Sat May 8 09:01:26 EDT 2004 x86_64 x86_64 x86_64 GNU/Linux

Im running fedora core 2 with an amd64 processor.
I tried wolfenstein and it said it only supports 32 bit Sad maybe someone ported it hopefully. It would make my day if i got my windows hd mounted. Thanks for the help.

Collapse -
Re: Some linux questions
by David Utidjian / August 5, 2004 12:08 AM PDT

I looked on the site I gave you a link to and I could not find an RPM for your kernel. That site is usually pretty up-to-date but they don't seem to supply any RPMs for x86_64 systems. Possibly because the maintainer doesn't have one him/herself.

From what you told us you are still running the original kernel which has been updated at least once since then.

First thing you should do is upgrade (you are going to have to do it sooner or later) as root:

yum update

That should upgrade your kernel to 2.6.7-1.494.2.2.x86_64 (phew!). Reboot so you are running the new kernel.

Next make sure you have the latest devel environment for the kernel:

yum install kernel-sourcecode

If it updated in the previous step it will tell you that you already have the latest installed. If not it will update it to the latest and install any other dependencies you may need.

Next you will have to rebuild the kernel with support for NTFS enabled:

cd /usr/src/linux-2.6.7-1.494.2.2
make mrproper
cp configs/kernel-2.6.7-x86_64.config .config
make gconfig

In the Options window select 'Filesystems' then 'DOS/FAT/NT Filesystems' then you will see a list of filesystems. The box to the left of
'NTFS file system support' will be unchecked... double-click on it to select it (a - should appear in the box). A couple of other selections will open underneath that. Do not select them.

Click Save then File --> Quit.

Your kernel build configuration should now have all the original support configured with support for reading NTFS filesystems added.

Now build the kernel. This will take a looong time even on your fast system. Easiest for maintenance is to do:

make rpm

Which will build the kernel as an RPM package which you can then install (and uninstall) easily. Once it has built it will tell you where it is at the end. Then just:

rpm -ivh /usr/src/redhat/RPMS/x86_64/<your-new-kernel>

It should also automatically configure grub to make that kernel a selection. When you reboot you will see the new kernel with the word "custom" in the name. Boot to that kernel. Once you have booted to the new kernel you should be able to mount your NTFS partition like this:

mount /dev/hda1 /mnt

Then you should be able to browse the NTFS partition under the folder /mnt.

Note: Each time you upgrade the kernel you will have to go through most of this process (or just run the custom kernel).

Let us know if you have any problems.

-DU-...etc...

Collapse -
Re: Some linux questions
by peenuts220 / August 5, 2004 6:22 AM PDT

yea well i got it to work thanks so much man. Only thing im not really liking is how i cant run alot of the programs i wanted to with the x86_64 architecture. I also tried and installation of SuSE 9.1 32 bit but im having some graphics trouble with that

Collapse -
Re: Some linux questions
by David Utidjian / August 5, 2004 9:30 PM PDT

Cool you got NTFS working.

Those programs probably wouldn't work in their Windows versions with a 64-bit Windows kernel either (is there such a thing?)

Might a regular x86 Linux kernel work on your hardware? Then the programs you have, if they work in Linux at all, should work. You just won't be using any of the 64-bit goodness.

-DU-...etc...

Collapse -
Re: Some linux questions
by peenuts220 / August 6, 2004 3:12 AM PDT

yea well there is currently a beta of XP-64 i hear its not too good. Yea i do notice a difference in the speed of fedora core 2 64 bit and SuSE 9.1 32 bit. Although i find SuSE to be slightly easier and nicer looking.

Collapse -
Re: Some linux questions
by tmick / August 20, 2004 11:31 AM PDT
In reply to: Some linux questions

I think what you are trying to do is dual boot RH Fedora and Windows right? If so then the easiest way I have found to get this to work is to:
1) go to disk management and format the drive you are trying to install Fedora on as Raw.(this will set it as FAT 16
2) use the disk druid to change to linux type of partition
3) choose the defaults and install
that should be it and it should let you do that.
If you are trying to share files between RH & Windows use Samba.

Collapse -
Re: Some linux questions
by lilsim89 / September 11, 2004 4:50 PM PDT
In reply to: Some linux questions

try typing "rpm -Uvh" then the file addresse. case sensitive

Popular Forums
icon
Computer Help 51,912 discussions
icon
Computer Newbies 10,498 discussions
icon
Laptops 20,411 discussions
icon
Security 30,882 discussions
icon
TVs & Home Theaters 21,253 discussions
icon
Windows 10 1,672 discussions
icon
Phones 16,494 discussions
icon
Windows 7 7,855 discussions
icon
Networking & Wireless 15,504 discussions

REVIEW

Meet the drop-resistant Moto Z2 Force

The Moto Z2 Force is really thin, with a fast processor and great battery life. It can survive drops without shattering.