HolidayBuyer's Guide

Computer Help forum

Question

Software Network Connection Issue - AD/GP Enviroment

by Premier_Pyrus / January 28, 2016 11:25 AM PST

So, I've been having an issue at the office for a while now, and literally nothing I've tried has worked.

We have a set of software, called Lacerte (a tax program). It's separate for each year (as in for 2015, 2014, 2013, ecs) but otherwise almost identical. This program has both a network installation (on a Group Policy Shared Drive policy) and a workstation installation. Th actual software runs mostly on the local side, but uses the server side for its database, installing updates, maintaining settings, and a few other files.

My problem is that Lacerte (for all years) seems to randomly lose it's connection to the shared drive. Lengths of time seems to vary from as little as less then a minute up to around 20 minutes. This is a problem because the software will try to keep running for a minute or so before the information disappears, or freezes, which causes the work done since disconnected to be lost.

I've tested our network, and it seems to work well, as well as be up to speed. Our network hardware and software has also not been changed in a while and been active longer then we have been having these problems. Thus, I've pretty much eliminated this being the problem.

By default Windows Server will automatically sever local connections that have been inactive for a period of time (default 15). I've gone in a changed this settings via CMD (run as administrator), and later via registry edits on both the server and 2 workstations (which I was testing on). No success.

It also crossed my mind, that it maybe those files were being accessed/read by something else, and that maybe that was causing the disconnect. This would have explained the unpredictable time it takes to lose the connection. To test this I temporarily disabled our automatic files sync to a local back up, Firewall, anti-virus, and anything else I could think of that could be scanning those files. No success.

Obligatory. I already reinstalled the software many, many times.

The weird thing however, is that I have one workstation that is completely unaffected by these problems. I have a W7 machine that runs perfectly. I though my problem might be a Windows 8+ issue, but when I tested our only other W7 machine the problem persisted on it as well, as well a our only W10 machine.

And I've tried tons of other things that I can't even recall at thing point. I'm stumped, and losing my mind over this.

Any ideas? Or suggestions on what else I can try?

Discussion is locked
You are posting a reply to: Software Network Connection Issue - AD/GP Enviroment
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Software Network Connection Issue - AD/GP Enviroment
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
Next stop. Lacerte.
by R. Proffitt Forum moderator / January 28, 2016 11:28 AM PST

It's a sure bet they get this call all the time.

Collapse -
More Info.
by Premier_Pyrus / January 28, 2016 12:15 PM PST
In reply to: Next stop. Lacerte.

So, it completely flew by me to mention, but I've already tried asking a few folks for help.

1. I've contacted Lacerte twice, and spent almost 2 hours with them on both occasions. They were unable to help me, and suggested that it may be a compatibility issue with Windows 8/10 like I had though. This does not seem to be the case however, since I have 1 working W7 machine, and one that is not working.

2. I have a server provided by Dell. I called their server support and spent a while with them. I even had them check my settings, which they said were good. They did, however, suggest that I disable the power saving options on the NICS on the server and the workstations. I did, but have seen no benefit.

3. I have a good friend that is a system admin (or whatever his title is). He is one of there top guys. I talked to him twice (he suggested that the files might be accessed by other processes), and still no success.

Collapse -
There are so many priors about file shares that drop
by R. Proffitt Forum moderator / January 28, 2016 12:54 PM PST
In reply to: More Info.

And here I can't be sure any priors can help. It's odd that a current app would not be ready for W8 and W10. That's not good news.

I see the power settings were changed but are there more clues? Besides the W7 machine.

There is one area that continues to create work for my friends in the industry. It's the corporate install of Windows. That is, I rarely see IT get the drivers right. For example http://answers.microsoft.com/en-us/windows/forum/windows8_1-networking/windows-81-network-constantly-drops/6e30c599-ea96-494c-89ff-8d9a519b16ea?auth=1 notes a NIC driver.

I'm not there to try things and can't tell you I know what's up. I can only share that at our office (which is full of software programmers) we never have this issue. But then again, we are tuned into the hardware, OS, drivers and will not allow IT staff to interfere with operations.

Collapse -
Finally figured it out!
by Premier_Pyrus / January 29, 2016 9:27 AM PST

Good news, I finally found out what was causing my problem as well a solution (you can skip to the bottom [in bold] for the solution).

This was how I figured it out.
I temporarily created another shared drive with the database that the software uses on another workstation (shared folder with Authenticated Users). I connected the software on that machine to the local database to test for local occurring issues. I also connected the software of 2 other workstations in the office to the temp. file share to test for issues occurring outside the local workstation environment.

My logic was as follows:
1. The local machine test will rule out the possibility of local workstation issues.
2. If the issue persist on the LAN connected workstation, then the problem is the way the software interacts with the network, and eliminates the possibility of server environment issues.
3. If the test is successful then the issue is server environment bound.

Both test were successful, which pointed me to issues with our server (AD/GP) environment. My immediate guess was that there may be an issue with Group Policy and the permissions for file access on the Shared Drive.

To test for that I went into the server and straight up shared that drive with Authenticated Users instead of through Group Policy like I had it before, and this fixed my issues across all workstation.

Conclusion: Although the problem is now fixed, I still need to figure out why the issue occurred with the GP share (which is done at a User level and looks to be perfectly fine). My guess at the moment is that our software possibly tries to access the data as something besides the User. At this point we have a fix I don't have the time to follow up on this until after tax season, so I'll try to do so then.

Collapse -
Good find.
by R. Proffitt Forum moderator / January 29, 2016 9:41 AM PST

May want to feed that back to Lacerte.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

HOLIDAY GIFT GUIDE 2017

Cameras that make great holiday gifts

Let them start the new year with a step up in photo and video quality from a phone.