Question

SmartHub Won't Download Terms and Conditions

I just purchased UN55JS8500 and for some reason when I try to do my initial set up of the SmartHub it won't download the terms and conditions and take me on to the next step. It says it is connected to the router and has internet connection, but I've let it sit for 30+ mins and it just continues to attempt the downloading process. I've done a speed test for my internet and it seems fine. I've never had any issues connecting equipment wirelessly. Any thoughts would be greatly appreciated.

Discussion is locked
Answer
Follow
Reply to: SmartHub Won't Download Terms and Conditions
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: SmartHub Won't Download Terms and Conditions
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
ALWAYS CALL THESE IN.

A friend bought a Samsung device and it was unusable for 3 days because Samsung's registration service was down. They ended up calling Samsung to learn this service was down but it was a rude choice by Samsung because why would they lock you out of using a tablet if their service was down?

They returned the tablet.

During your call they usually have you check firmware versions, try another DNS and if on WiFi get wired for a test run.

- Collapse -
Answer
Re: Terms & Conditions.

Hello,

I'm sorry to hear about the trouble you're having with the unit. It may require a firmware update. Are you completely through the initial set up of the television? If so, just go to Menu>Support>Software update to check for new updates. If this is the initial set up you may have to unplug the router so that it skips past this portion of the set up, and reconnect to perform the update.

Please let me know if you have any other questions.

Regards,
HD Tech

- Collapse -
Any other solutions?

I've had my Samsung smart TV for 2 months now and never got past the smart hub terms and conditions page. Internet works fine, tried wired and wireless, tried manual DNS, tried resetting. When I had a Sony smart TV it just worked instantly, this one had been awful.

Is there any actual solution as I'm really tired of trying things that don't work now. I've left the terms and condition page downloading for hours now.

Thanks

- Collapse -
Always call those failures in.

If Samsung can't resolve it, either on the phone or a service call, then you have a defective TV and need to get a refund. It may be tough at 2 months but keep at it.

- Collapse -
SAME PROBLEM HERE IN GUAM

All 2015 Samsung Smart TVs being sold at Navy and Air Force bases here in Guam have this issue. Samsung is blaming the ISPs here on island. Just hoping for a refund now.

- Collapse -
Re: Guam

Are you really saying that the sales assistants in the shop don't know that what they sell doesn't work? What a bad shops you have at that navy and air force bases!

Kees

- Collapse -
These "smart" TVs are regionalized.

So many of the smart TV features blow up as you move across borders.

There is a recurring issue with ISPs so Samsung is right to point at them. Did they try the old 8.8.8.8? And my recurring advice is to get a "TV." Add streaming with a Roku or PC.

- Collapse -
Tried using different DNS

You're right. These TVs are made for North America and unfortunately, Guam is a US territory geographically located in Asia. But really, Samsung should be able to fix this kind of issue. It might just be a matter of releasing a software update for JU series...

- Collapse -
Sounds like a legal issue not a tech issue.

Did you change the region to USA and try?

It would take paragraphs to dive in the legal issues. So I won't.

- Collapse -
Cannot change region

We can't change the region to USA without downloading Terms and Conditions and that's where we're getting stuck at.

- Collapse -
The same issue

I face the same problem. I bought my Samsung smart tv in Portugal, crossed the borther to Cape Verde Island, West Africa, and can not download terms and conditions page. So, have you solved this issue? Best.

- Collapse -
Back to Samsung.

Their code and only they can tell you how to fix it (well, maybe there's a hack but for this round it's you and Samsung.)

- Collapse -
conseguiu?

Olá, sou da Praia e também tenho o mesmo problema com o meu smarttv samsung. Conseguiu resolver?
segundo já pesquisei, tem a ver com a velocidade de internet banda larga. Creio que exigem um minimo de 20 mbps.

Hi, I'm from Praia and I also have the same problem with my samsung smarttv. Managed to solve?
As I have researched, has to do with the speed of broadband internet. I believe they require a minimum of 20 mbps.

Post was last edited on March 16, 2017 6:36 AM PDT

- Collapse -
Cabo Verde

Estou com o mesmo problema em Cabo Verde, mas no meu caso comprei a UHD SMART TV Series 6 aqui na cidade da Praia. Você conseguiu encontrar solução?

- Collapse -
Google says.

"I have the same problem in Cape Verde, but in my case I bought the UHD SMART TV Series 6 here in the city of Praia. Were you able to find a solution?"

Samsung has to answer if it's possible to change regions.

- Collapse -
Samsung TV

It's not a smart TV after all. Same problems here in Japan. AAFES should refund all TV samsung purchase and penalize the company and not sell their products anymore!!! Had the TV since January and still not working.

- Collapse -
Fixed for me

So I know this is an old post but it might help some of you on the island of Guam or wherever else your from. When your stuck in the terms and conditions screen when your in the start up for the smart hub, press mute vol+ ch+ mute. It should bring up the region menu. For Guam users select United States of America. For others choose whatever region you’re from.

- Collapse -
This works

Gracias. This worked on a Samsung UN43NU6900. Purchased from Big Navy. Hope others can find useful.

- Collapse -
How

Just got mine. Stuck on terms and conditions. I'm on saipan. What did you do to get past that?

- Collapse -
In saipan too

Did u return your tv? If u did, maybe I bought the one u returned? Lol I’m also stuck on the terms and conditions page

- Collapse -
It didn't work

I tried it and nothing pops up

- Collapse -
Out of ideas!

Samsung couldn't help on phone, ended up blaming the broadband provider. Which is odd as no problems on any other devices and previous smart TV worked. Can't get a refund now so stuck with a fairly useless TV. I mainly use apps and catch up services, so hugely frustrating, the TV just doesn't get watched now.

Thought Samsung would be more keen to fix the issue, still can't believe there isn't an easy solution, the smart hub should just work automatically. I'll never buy anything from Samsung again anyway just annoying I'm stuck with this for a few years.

- Collapse -
this simple fix worked

I had the same problem (couldn't get Smarthub to work) and fixed it this way....
- find the factory reset menu (I think it was in security or support menu)
- when I clicked on factory reset I was asked for a PIN
- I had never created a PIN so couldn't get the reset to work (?????)
- I was told by Samsung that the pin was 0.0.0.0.
- once I entered the PIN (of 0000) I was able to select "home use" instead of "demo use" (I asssume that was a store setting to use the TV as a demo even though the TV was brand new)

After the factory reset everything worked, including SmartHub, Netflix etc

- Collapse -
Answer
SAME PROBLEM

I am having the EXACT same problem. Brand new JU7100 65" will not pass the terms and conditions page. I installed the most recent update with no luck. I hope someone can post an actual answer here.

Does your TV allow remote access from the support menu?

- Collapse -
Re: Same Problem

I'm sorry to hear this! Have you tried the above steps? As well as changing the DNS server to 8.8.8.8 or 4.2.2.1 to help with the connection to our servers?


Regards,

HD Tech

- Collapse -
Same problem

I tried 8888 previously, and just tried 4221 with no luck. I have installed all software updates on my tv previously to trying this.

- Collapse -
Update

I tried updating the software and changing the DNS, but nothing worked. I ended up returning the TV this morning. The new TV fired up right away. Even the start up was different from the original TV I had...must have had a software related issue.

Other than an issue with the TV stand hanging to one side slightly more than the other (which we fixed by loosening the screws and putting a lot of pressure on the other side as we tightened them...works for now), it seems to work perfectly.

Overall, the TV seems to be good, but the issues we had with the SmartHub, the original stand (which would not get secure and wobbled), and the new stand, does make me question the quality especially for one of the higher priced UHD TVs...and did impact my decision on the 3D BluRay player that we purchased (ended up with the Sony).

In summary, I think you are best to return the unit. If it is hanging up on the T&Cs then there is a issue with the TV (at least in my case). The T&Cs should load up almost instantly.

Hope this helps you.

- Collapse -
Answer
Had thesame frustrating experience. I was able to fix it!

I was getting the same issue. I had bought a new Samsung ju8500 tv and when installing the Suhd Hub it never got passed step 3 "downloading terms and conditions", i even left it four 5 hours scince samsung advised it may just be my slow internet, ti was just about to give up but my brotger is a nit more techy then me he fixed it! The problem is the DNS server so all you have todo is change it manually to 8.8.8.8 this should resolve it, hope this helps

- Collapse -
Answer
If all else fails....

I had the same problem with SmartHub getting stuck on the terms and conditions section. I tried changing the DNS number and the firmware was up to date so I got on the phone with someone at Samsung and started arguing. During their diagnostic inquiry they asked me to reset the TV so they could remote access and see if they could find what was wrong. So I did that and suddenly smart hub was downloaded and working. So if all else fails trying resetting TV.

- Collapse -
Answer
Finally fixed it!

Hey guys, I have been having this problem for a few months now, and after a TON of troubleshooting and research, I have finally come up with a definitive solution.

So, I had originally purchased this 32 inch UN32J5500AF TV from Best Buy. It worked perfectly at first, but I had it mounted to the wall, and my component inputs got bent up and ruined. So I took it to Best Buy, and since I purchased the insurance, it was covered. They sent it in for repair, and when it came back, it had a whole new motherboard in it (go figure).

There was no flashy setup intro like there was the first time. It was pretty much good to go, or so I thought. Later, I Went to access the smart hub features, and found that I had to go through the smart hub setup. That's when I ran into this dreaded issue. I was stuck downloading the terms and conditions for hours.

I set up a network monitoring tool to see if there was actually any downloading going on, and found the TV wasn't doing anything at all. I tried several different internet connections. Mine, friends house, neighbors, cell phone hotspot. Same issue on every connection. I went in to menu, support, self diagnosis, Smart Hub Connection Test. It went though the test up until the last step "Samsung apps connection" which it failed.

I tried changing the DNS settings, resetting Smart Hub, nothing worked. I called Samsung support, and they said since I had the device repaired by Best Buy (even though best buy sent it to Samsung) I would have to bring it back to Best Buy to get the unit fixed.

So.. back to digging on the internet for more info... Guess what, there's a secret menu. YEP!

The procedure to get into this secret menu is.. Turn off the TV so it goes into standby mode. Then, quickly press the buttons on the remote in this order.

Mute + 1 + 8 + 2 + Power

Wait a few seconds, the TV will turn on, wait a few more seconds, up to 30 seconds. It should pop up. If not, try the code again. If that code doesn't work, try the other codes listed on this site: http://www.askvg.com/secret-service-codes-for-sony-and-lg-tv/

When the menu pops up, you will have "Option" selected. Press the right arrow button, you will see "Factory Reset" press the select button, and the TV should power off.

When you turn it back on, it will be like you just turned it on for the first time after unboxing it from the store. You will see the fancy initial startup animation, go through the initial setup, and service agreement will pop up with no downloading required, Smart Hub will be set up, VIOLA!!! Your Smart TV is now SMART AGAIN!!!

You're welcome.

CNET Forums