Question

Slow Wi-Fi on Galaxy S9 Phone

I noticed that the wi-fi on my phone is 760 KBps when I my laptop is connected to the same connection, even when my laptop is idle. Wi-Fi on my laptop tests above 80 MBps. If I turn off my laptop, the wi-fi speed on my phone jumps to 40 MBps! I am thinking of buying a new router soon. Is there anything I should check before spending money on a new router? BTW, I have turned off bluetooth with no effect. I have a tablet which runs well on my Wi-Fi connection when my laptop is connected. When I use data on my phone instead of connecting to Wi-Fi, it is quite fast!

Thanks.


Rob

Discussion is locked
Answer
Follow
Reply to: Slow Wi-Fi on Galaxy S9 Phone
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Slow Wi-Fi on Galaxy S9 Phone
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
My suggestion.....

Try comparing the internet connection speed with your Samsung phone and another mobile phone on the same network. Don't try comparing to a laptop or any other device. If at all possible, try with another Samsung handset.

I upgraded my Samsung S9 plus to Android Pie with no negative effects on my Wifi speeds like you explain.

Post was last edited on April 25, 2019 7:27 PM PDT

- Collapse -
I will try comparing phones

Thanks. I never thought of that! I should be able to find someone who has a phone to come over.

Thanks.

Rob

- Collapse -
My Suggest for phones

I will help you . Thank you

- Collapse -
Answer
I've seen this.

If possible change the laptop or phone connection to another band. It would take a small dissertation to explain why this happens but there are many modes in the WiFi connection so the router has to jump through hoops to service both. So the easy thing to try is to get the laptop on 5GHz and the phone on the 2.4GHz or vice versa.

If that isn't possible be sure to try WiFi settings in the router to allow only 802.11g and that has helped some cases.

The last thing which is my first thing is to be sure the router firmware is current.

CNET Forums