Question

Slow Download Speed (WiFi) On One Device Only

Good morning,

I seem to have a problem with my laptop's internet connection. Only this one laptop has around 3mbps down but full 10mbps up speed. Another laptop connected gets full down speed (44mbps).

Those are the things I tried:

- direct LAN connection to router yields full speed.
- AVG Protection and Windows firewall disabled - no change.
- uninstalled wifi adapter (Qualcomm Atheros AR956x) and re-installed with newest driver I could find (10.0.0.263)
- automatic windows network diagnostics - results said it fixed a configuration issue but slow speeds persist
- read all threads about that problem that I could find here and on other boards, unfortunately non solved my problem

Running Windows 8.1 and had no speed problems until recently.
One suspicion I have (without wanting to lead you in the wrong direction) is that I installed a wireless connection to my HP all-in-one printer the other day and that might have screwed something up that I can't figure out how to undo.

Any help with this little head scratcher would be very much appreciated!

Looking forward to hearing from you and wishing you a great day,

Philip

Discussion is locked
Follow
Reply to: Slow Download Speed (WiFi) On One Device Only
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Slow Download Speed (WiFi) On One Device Only
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
What band you using? n b or g?

If the laptop does "n", does the router do that also? At those speeds you could limit the laptop to b or g bandwidth.

- Collapse -
Answer
If no one solved it, it's time to move on by doing this.

Go get another USB WiFi adapter and use that instead. Remember I'm taking your word no one solved it so it's time to move to how I solve failed WiFi cards.

- Collapse -
About cost.
- Collapse -
???

R. Proffitt, I'm not entirely sure what you mean. I just posted this question...

- Collapse -
I'm taking your word as above.

"read all threads about that problem that I could find here and on other boards, unfortunately non solved my problem"

That means you tried it all, including a system restore, factory reset and trying 802.11g 20MHz OFDM on the router. Since you wrote that I figured it was time to head to the exits. At least it's cheap.

- Collapse -
system restore

System restore didn't work. Unfortunately I don't have a backup CD, will look into the possibility of establishing one.
Unfortunately I don't have the login information for my router. ISP technician just installed the new one 6 weeks ago and didn't leave me the new login. Will contact my service provider for that information.

Anything else I can try in the meantime?

If nothing else works I will spend the $15 to buy a dongle from Amazon, but money doesn't come easy for everyone and I'd rather try everything else first.

Your help is much appreciated!

- Collapse -
System Restore never required a CD/DVD or USB.

I'm guessing you mean system recovery to the factory condition. About no CD/DVD or USB.

I'd like to look up how to create recovery media and I do respect folk's need for privacy but here I'd need the make and full model number of the laptop to see if it's documented. Hope you can see why that's needed and will share those details.

As to 15 bucks, the #1 seller is a little less plus it's cheap compared to a repair counter today.

- Collapse -
model info

Model number of the laptop is Acer Aspire E1-532P-4832, comes with the wireless network adapter Qualcomm Atheros AR956x.

Sorry if my answer was a little confusing. I did the system reset, however the more radical version that the Windows 8.1 offers is to do a complete sweep and it is looking for a system image when starting that. Hope that is a little clearer.

Do you have a specific dongle in mind that you made specifically good experiences with?

Thank you very much!

- Collapse -
The last thing. The wifi driver.

Post was last edited on November 18, 2015 7:37 PM PST

- Collapse -
Let's Make Sure

Good morning,

Thanks again for your help.
Just to make sure that I haven't messed up anything (as I'm sure your knowledge is way more detailed than mine), and of course only if you are up for it, what would all the things be that you'd try first?
When it comes to network settings, my adapter options screen looks relatively Spartan, and I didn't find anything to adjust (not saying that this there isn't any).

The driver: yes, that was what I tried. However, with the system to be still in the new and reset mode, I'd like to follow your advice how to go about installing the new driver to install it "clean".

In case checking the network settings will involve logging onto the router: the ISP tech installed a new one 6 weeks ago, and I am not aware of the login information. I tried it as outlined here, but get the "no valid username" prompt. Any ideas in that regard? model number is Cisco DPC3848VM.

I will try to follow as many of your instructions as possible today and tomorrow morning. Over the weekend I will be traveling, hence not be able to work on the laptop (just so you don't think I'm unresponsive).

- Collapse -
Sorry no I never did that!

When you wrote " I'd like to follow your advice how to go about installing the new driver to install it "clean". " I'm not helping as in decades I've yet to do that. Tried it for years and didn't see any difference.

Sorry that all the internet advice and mine didn't work out. On such calls I pull out the USB WiFi and see if that nails it.

Again, you lead with the internet priors didn't fix it so it's time to fix it.

- Collapse -
Answer
(NT) The first thing I'd do would be System Restore.
- Collapse -
Definitely an option

Was hoping I'd be able to solve it without the hustle of reinstalling all software and such...

Is there any quick way to check if all printer drivers have been de-installed completely? I've hit uninstall in control panel, but not sure if that is the cleanest way to get rid of them.

- Collapse -
Thanks!

Did a system restore now, unfortunately no positive results.
While I try to establish a boot CD, any other advice?

Thank you very much for taking the time to respond.

- Collapse -
Answer
try safemode with network

a couple of things to try,

1. try safemode with network to see if you still have the problem there
2. do a power cycle on both the modem and router. unplug both for a 20 count. plug modem back in and wait for all the lights to come back on, then plug in the router and wait for everything to come back on.

CNET Forums