Assuming the re-install went well, (all drivers including motherboard, etc), it may be that on a fresh install XP's Indexing Service is running. This is BlackViper's description of the Indexing Service;

"Default Description:
Indexes contents and properties of files on local and remote computers; provides rapid access to files through flexible querying language".

BlackViper recommends disabling this if it is running;
http://www.blackviper.com/WinXP/Services/Indexing_Service.htm

How to do that. Goto Start > Run, type in services.msc, click OK. In the Services console scroll down to Indexing, double click the entry, then stop it, and disable it it.

There may be other services running that you don't need, and The Elder Geek can help you there.

Since re-installing, have you re-downloaded and installed all of the XP Windows Updates?

Mark