"Wake on LAN" or "Wake on Link" can sometimes do that. Open Device Manager, then check the "Properties/Advanced tab" of the "Network Adapter" devices.. If the "Wake on Link" or "Wake on Settings" items are enabled, try disabling them both.

Another place to look if the above doesn't help....Many BIOS settings also have the "Wake on LAN" that can be disabled..

Hope this helps.

Grif