Networking & Wireless forum

Tip

Simplify FiOS - dump Actiontec and use your own router

by Geekery / March 17, 2016 2:42 PM PDT

There are many ways FiOS network is configured inside the user’s premise depending on the bundle of services the user subscribes to. If you have Internet AND TV, and have both Ethernet (Cat 5) AND Coax cable connections coming from the ONT into a FiOS Actiontec router, this write up is for you.
My FiOS setup (as it was installed):
• ONT -> Cat 5 cable -> Actiontec Router (WAN interface)
• Actiontec Router (LAN interface) -> My router (WAN interface)
• My router (LAN interface) -> My 8-port switch -> Computers and other Home network devices
• ONT -> Coax cable -> Splitters -> Actiontec Router (Coax interface), DVRs, STBs
• Coax cable runs all around the house (basement, main floor, 2nd floor). FiOS DVRs, STBs connected to Coax cable in different rooms.
• Actiontec wireless DISABLED. I use my own AP for wireless access around the house – mainly for better coverage and dual-band. This is unrelated to the removal of Actiontec.
• The Actiontec router model is: MI424WR Rev I

The main reason I wanted to dump the Actiontec router was so I could use my own router with specific features that I want (e.g., both SSL and L2TP VPNs, timed internet access, application control on firewall, etc). With the Actiontec router in the middle, I was unable to get all the services of my router working, no matter what I tried – such as putting my router in Actiontec’s DMZ, setting up required port forwarding on Actiontec, and more. After weeks of attempts (including helpful calls to VZ tech support), I finally decided to try and remove the Actiontec router all together and connect my router directly to the FiOS ONT Ethernet cable.

From Google search, numerous forums postings, VZ tech support, and other sources I learnt that in order to get the FiOS DVRs and STBs to work fully especially for VOD, Program Guide, and DVR functionality, they needed to connect to the Actiontec router and so removing Actiontec was not recommended.

Notwithstanding, I concluded the following:
• Internet access to my home was being provided over the Ethernet Cat 5 connection on the Actiontec router
• Only TV signals were distributed over the coax cable from the ONT.
• The ONT did not use the coax (MOCA) connection for any of its communications with the Actiontec router.
• Actiontec router provided Internet access to DVRs and STBs connected on its coax network by simply ‘bridging’ the coax to the Ethernet Cat 5.
• The only reason DVRs and STBs are connected to the Actiontec router coax port was so they can connect to the Internet and access VOD and Program Guide servers.
If my above assumptions were correct, then removing the Actiontec router and just using my own router should not disrupt any of my services, so long as I provided way for the DVRs and STBs on the coax network to have Internet access.
To be safe, I followed a step-by-step process as detailed below, so that I could recover to the original state by simply reversing the steps at any point, if things went haywire along the way. Good news – I didn’t have to reverse the steps! And now I have a FiOS setup that has no Actiontec router in the network and has only my router and is providing the full gamut of services as before. And more in terms of firewall functionality.
The step-by-step process:
Step 1: Noted important WAN interface configuration information of the Actiontec router (especially the MAC address which needed to be ‘cloned’ on the WAN interface of my router). Actiontec WAN interface was set for DHCP and therefore did not have any IP and DNS address information to bother about.
Step 2: Procured and had ready for install an Actiontec MOCA-ethernet bridge device (ECB6000S02 - available on Amazon, cost around $90) so that the DVRs and STBs on the coax network could eventually be connected to the Ethernet port of my 8-port switch and thus have Internet access.
Step 3: Disconnected the coax cable going into Actiontec router’s coax interface and connected that cable to the MOCA bridge coax interface. Connected the Ethernet interface of the MOCA bridge to one of the free LAN interfaces of the Actiontec router. Connected the power adapter of the MOCA bridge (effectively turned it ON). Technically, this step can be bypassed and Step 4 done. But I performed this step just to be sure that the Actiontec MOCA bridge device worked as advertised and did not introduce any new problem.
During Step 3, none of the DVRs, STBs or the Actiontec router was powered off or power cycled. They remained ON right through. Figured that if they all had IP addresses etc. already, and the MOCA adapter was simply that – an adapter, then they should continue to have internet access – after a momentary glitch at worst.
When I completed Step 3, all the DVRs, STBs continued to function normally including displaying Program guide, and accessing VOD. This seem to confirm one of my assumptions that the Actiontec router simply bridged the MOCA coax interface to its Ethernet LAN interface on its internal switch. I verified this further by disconnecting the MOCA bridge Ethernet port from the Actiontec LAN interface – and seeing no Program guide. Also, the DVR self-diagnostics showed ‘no internet connectivity’. When I reconnected the MOCA bridge Ethernet port, everything went back to normal.
Step 4: Disconnected the MOCA bridge Ethernet port form Actiontec router LAN interface and connected it to my 8-port switch. Knowing that this would connect the DVRs and STBs to a different subnet (my router’s and not Actiontec’s), I power-cycled the DVRs and STBs so that they could get new IP addresses etc. from my router and connect to the Internet via my router.
After the power cycle, confirmed that the DVRs and STBs continued to function normally including Program guide and VOD. Yet another confirmation that all that the DVRs and STBs need is internet access – doesn’t matter through which router and over what medium.
Time to remove the Actiontec router all together.
Step 5: Details of this step are specific to the brand and model of your router. I use a Watchguard XTM-25 series router/firewall. Regardless of the details, the important part of this step is to configure the WAN interface of your router to mimic the Actiontec router’s WAN interface, so that your router can get the IP address etc. from the FiOS ONT.
On my XTM device, I configured the WAN (‘External’) interface for DHCP (just as the Actiontec router was setup), and to ‘override’ its MAC address with the MAC address of the Actiontec router as noted in Step 1.
After confirming my router’s WAN interface configuration, a) powered off both the Actiontec router and the XTM router; b) disconnected the Ethernet cable coming from the ONT into the Actiontec router WAN interface; and c) connected the Ethernet cable coming from the ONT to the WAN (‘External’) interface of my XTM router. THIS REMOVED THE ACTIONTEC ROUTER ALL TOGETHER.
At this juncture, my FiOS connections looked like this:
• ONT -> Cat 5 cable -> My router (WAN interface)
• My Router (LAN interface) -> My 8-port switch  Computers and other Home network devices
• ONT Coax cable -> Splitters > DVRs, STBs, Actiontec MOCA adapter
• Actiontec MOCA adapter Ethernet port -> Free port on my 8-port switch
Step 6: Powered on My Router (XTM 25) and waited for it to complete its boot up. And (drum roll…..) all FiOS services were fully back up and normal. Internet access, TV with Program guide, VOD, etc.

Post a reply
Discussion is locked
You are posting a reply to: Simplify FiOS - dump Actiontec and use your own router
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Simplify FiOS - dump Actiontec and use your own router
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
You are THE MAN.
by HappyCloud9 / August 18, 2016 12:28 PM PDT

This helped me out so much. Thanks. Do you go to some genius school or something?

Collapse -
Downside of using Actiontec router as MoCA adapter
by jirbo / September 3, 2016 3:36 PM PDT

I'm curious if there is a downside to just using the Actiontec as the MoCA bridge instead of purchasing a separate adapter... I'd prefer to not spend anymore money and it seems that by putting the Actiontec behind the XTM connecting a XTM LAN port to an Actiontec LAN port and leaving the STBs connected to Actiontec via coax, that the functionality outcome would be the same, just having the Actiontec still playing a role albeit only for the STBs.
Thanks

Collapse -
RE: Downside of using Actiontec router as MoCA adapter
by Zamotic / September 9, 2016 11:28 AM PDT
Collapse -
Re: RE: Downside of using Actiontec router as MoCA adapter
by jirbo / September 12, 2016 12:34 PM PDT

So am I!
I tried it but could't get an IP on my Netgear R7000 when I connected it directly to the ONT. I got switched from Verizon to Frontier, so I am not sure if that matters, but after "spoofing" the Actiontec WAN MAC on the Netgear WAN and then rebooting and plugging Netgear WAN into Ethernet ONT... no IP. The WAN settings from the Actiontec showed it using DHCP, so I am not sure what's going on. I have had to put everything back the way it was Sad
I can't find anything on the web for folks moving their own router in front of Actiontec on Frontier Fios... <sigh>
I want to try again, but can't think of what I could do differently to make to worth trying.

Collapse -
Success!
by jirbo / September 17, 2016 10:01 AM PDT

So I missed the "release" the IP on the Actiontec step. I tried again by releasing the IP, then shutting down actiontec, then removing ethernet from Actiontec WAN and plugging into Netgear WAN and viola... then plugged actiontec wan into netgear lan and turned on... VOD and guide are working.
I did not need to spoof actiontec IP.

Collapse -
Help!
by KPT27 / November 29, 2016 7:56 PM PST
In reply to: Success!

Jirbo can you supply me with a list of steps you used to get this working? I also have a netgear r7000 that I am trying to get to work with fios!

Collapse -
The actiontec gets assigned an IP
by James Denison / November 29, 2016 8:13 PM PST
In reply to: Help!

which it then can use to contact Verizon. For instance, Verizon at their website can even tell me the security and password I use on the ActionTec, something I'm not happy about. He's saying he plugged it's WAN into a LAN port on back of his Netgear WAN which was hooked to the ActionTec previously. If instead you have a cable hookup to the ActionTec, then some other method would need to be used, or would need a tech come and connect you to the LAN port on the ONT.

Collapse -
I followed the steps in the article
by jirbo / November 30, 2016 6:51 AM PST
In reply to: Help!

All I did was follow the steps in the article. The first time I skipped a step which led to my initial failure, but when I went through them a second time I included the missed step (release IP) and it just worked.

My summarized steps:
1) release IP on actiontec and power down.
2) with Netgear powered down, remove ethernet cable from actiontec WAN and plug it in to Netgear WAN.
3) Power on Netgear, test internet connectivity for computers, etc.
4) Plug new ethernet cable from LAN port on Netgear to WAN port on actiontec.
5) Power on actiontec and test guide/VOD
I left all the existing coax connections untouched.

Collapse -
good to hear
by James Denison / November 30, 2016 10:17 AM PST

NT

Collapse -
Confirming this works
by DanSpenge / March 18, 2017 1:12 PM PDT

The steps outlines by Jirbo are on-point and worked completely for me (after calling Verizon and having them switch the ONT output from COAX to ETHERNET). Difference is I own my Verizon router so after putting my own router ahead of it, the Verizon router is only acting as the MoCA bridge to pull down the TV guide. Plus I can switch the LAN cable going into my own router to the Verizon router at any point if they refuse to provide tech support because it's an "unsupported configuration".

Collapse -
Yes
by James Denison / January 11, 2017 4:01 PM PST

Verizon has total access to your LAN and even know your encrypted passwords for WEP and WPA. If they can access that info, they can let others (think law enforcement) or hackers may have broken into it also.

Collapse -
Access from Verizon Web Site/Mobile App
by rtrainer / September 20, 2016 9:01 AM PDT

Does this still allow programming the DVR from the Verizon web site and mobile app?

Collapse -
RE: Access from Verizon Web Site/Mobile App
by jirbo / October 24, 2016 2:32 PM PDT

I doubt it, but I got shuffled from Verizon to Frontier earlier this year and Frontier has poor features an I expect that one to be gone so I decided not to care about impacted services like remote DVR scheduling or using he mobile app for the DVR remote control (which i tested and doesn't work, but that's because my phone connects to a different network segment than the actiontec router is on.

Collapse -
Works with Frontier
by newtechstuff / December 10, 2016 11:49 PM PST

I have only tested this on Frontier... the Mobile app works for all features except programming/scheduling the VCR.

Frontier doesn't have a website (at least that I could find for DVR management)

You can watch TV on the app.

M

Collapse -
Fios router
by Peteyshitz / October 24, 2016 2:06 PM PDT

I have read the info on dumping fios router and i will be doing it soon. I have one additional question. Will this work for phone TV and internet?

Collapse -
RE: Fios router
by jirbo / October 24, 2016 2:34 PM PDT
In reply to: Fios router

I have TV and Internet (Frontier after Verzion sold me to them but I use the same router). It works fine for those two.

Collapse -
FIOS and Quantum TV MULTI ROOM DVR?
by cdlinc / December 7, 2016 8:48 PM PST

Has anyone tried the above solution and still maintained Multiroom DVR, VOD, Guide and FIOS App functionality?
I am planning on trying this with and leveraging the actiontech as the MOCA Bridge http://support.actiontec.com/doc_files/Configure_MI424WR_as_a_LAN_MoCA_Bridge.pdf
Curious if anyone has run into issues.
Also going to use EERO router..
is it necessary to spoof the Actiontech WAN MAC address?
thanks again..

Collapse -
It's working for me!
by malkolmx / December 14, 2016 8:17 PM PST

I just tried this tonight, and everything seems to be working.

I got an Actiontec MoCA 2.0 Ethernet to Coax Adapter from Amazon and plugged that in to my coax splitter, and the ethernet into my internal network. I then unplugged the coax from the FiOS router. I tested the cable box and verified the guide and on demand were not working. I restarted the cable box and it received a DHCP address on my internal network. Everything seemed to be working as normal. The guide, and on demand were working as expected. I don't have a DVR so could not test that. Next, I released my IP address in the FiOS router and shut it down. I removed the ethernet cable from the WAN port on my FiOS router and plugged it into my internal router's ethernet port. I changed the mac address on my router to match the FiOS router's mac address and enabled DHCP. I received an address immediately and everything worked as expected. The FiOS mobile app works as expected as well. I have phone service, which also works.

I tried briefly to get a DHCP address without spoofing the mac address and it didn't seem to work. As soon as I updated the mac address and re-enabled DHCP it picked right up. So I think this is a necessary step.

Collapse -
I lied... you don't need to spoof the mac address
by malkolmx / December 14, 2016 8:31 PM PST

I guess I didn't test it enough. If you don't spoof the mac address of the FiOS router, you can get a DHCP address. It won't be the same one, but it seems to work anyways. If I spoof the mac address and restart the DHCP client I get my previous address again. Not really a big deal if you can update your DNS, if you're into that sort of thing.

Collapse -
Are you able to return the Fios router back to Verizon?
by Jaychu8888 / June 20, 2017 4:14 PM PDT

Great post! I would like to try this out but I'm currently renting the Fios router and if I clone the MAC Address and return the router back to Verizon will my services (TV Guide/VOD/Mobile App) still continue to work? Thanks.

Collapse -
Want to the same but with Tivo
by Gcrewss / December 21, 2016 2:19 PM PST

Great article, I'd love to the same thing, only difference is I dumped all my Verizon boxes and switched to a TiVo DVR with Verizon cable card inside and two TiVo minis. Would I even need to bother with a Moca bridge if the TiVo get all their guide data from the internet? Is anyone running a similar setup and tried this?

Collapse -
Me too....
by wyzards_ghost / January 11, 2017 3:16 PM PST

I'm looking to do this. Verizon coming out next Tuesday. Hopefully all will work fine. Have my Netgear R7000 with DD-WRT running from my Verizon ONT through ethernet. Hoping to run coax from the ONT to my TiVO Bolt using a CableCard then using my minis to pick stuff up over the network like I currently do with my OTA setup.

Collapse -
Update
by Gcrewss / January 11, 2017 5:38 PM PST
In reply to: Me too....

Hi. Would you mind posting an update after you get this done? Curious to see if you run into any issues and how smoothly it goes. Thanks!

Collapse -
follow up
by Gcrewss / January 25, 2017 5:48 PM PST
In reply to: Me too....

Hi,

Hate to bug you, but how did the install go? Did it work, did you run into any issues? Thanks,

Collapse -
Success!
by Gcrewss / February 12, 2017 7:00 AM PST
In reply to: follow up

Ok,

No responses on this one, so I just decided to go for it and see what happens, could always put the Actiontec router back if I had to. I'm happy to say for anyone that has or wants to have an all tivo setup with Verizon Fios using their own router, not only is it possible, but works quite well! Here is my current setup AFTER removing the Actiontec router:

ONT=>Cat5e=>Ubiquiti EdgeRouter Lite=>TP-Link 24-Port Gigabit Ethernet Switch (TL-SG1024)

On the router, I just had to configure the WAN port with the MAC Address of the Actiontec router. Then I removed the actiontec, plugged in the EdgeRouter Lite, and then plugged in the switch. Internet was back and up and running in minutes. For wireless, I went with just one Ubiquiti Networks Unifi 802.11ac Dual-Radio PRO Access Point (UAP-AC-PRO-US) mounted in my attic wired directly to the switch with a POE adapter.

My Tivo Setup is as follows:

1 Tivo Roamio Pro (connected to the internet via wired cat5e cable)
3 Tivo Minis (all three connected via MOCA)

Since the Roamio is capable of creating its own MOCA network, this is why I was able to eliminate the actiontec without having to re-purpose the actiontec router as a MOCA bridge, or purchasing a separate Actiontec Ethernet to Coax Adapter (ECB2500C), which saved me at least $70.00.

I just had to rerun the network setup wizard and have the tivo create its own moca network, and that was it, at no point did I have to reboot the tivo minis or the Roamio itself. I do have wired ethernet connections in every room the minis are in, and may try a strictly ethernet connection instead of MOCA at some point in the future, but for now, this was more about getting up and running quickly using the same settings I had in place before.

I hope this helps someone who was on the fence or thinking about going this route, I can tell you it does work, and you will definitely save money in the long run by using your own equipment instead of Verizon's.

Collapse -
Same setup help
by Moxyman / October 11, 2017 12:04 PM PDT
In reply to: Success!

Hi! Thank for this. I basicly have the same devices. An action tech router, A tp-link 24 swtich for hard wired rooms, TiVo Romaio with cable cards, and minis. I want to get rid of the actiontech and use the new velop mesh system.

Only problem is, when fios did the install they did coax and not Ethernet.

I am kind of a noob when it comes to networking. My question is... can I just buy the actiontech adapter ECB6000 (it’s the new 2.0 version). Then plug the coax that comes from the box outside into the adapter, then take the Ethernet out of the adapter and into the velop router and then out of velop into tp-link switch which controls all my other devices?

I’m assuming that’s the way to get the best speeds, and have thee least issues.

Collapse -
Update
by Gcrewss / October 11, 2017 1:13 PM PDT
In reply to: Same setup help

Hi, glad you found this helpful. I would recommend calling Verizon and have them switch the ONT from coax to ethernet, they can do this right over the phone. Then you just run an ethernet cable from the ONT to your router, avoiding having to buy the adapter, which is one less piece of equipment to worry about and a simpler, cleaner setup.

Collapse -
Update
by Moxyman / October 11, 2017 11:55 PM PDT
In reply to: Update

It’s nit really possible for me to run a new wire. Which is why I was hoping the adapter would work.

Collapse -
Ok I did it..
by Moxyman / October 12, 2017 1:59 PM PDT
In reply to: Update

Disregard my previous reply. I just ran an Ethernet cable from the ONT to wheremy router will go. So just to be clear... I don’t need to do anything to my actiontech before I disconnect it? Or do I just call fios and ask them to switch to Ethernet and then plug it into my new router and done?

Collapse -
ok
by Gcrewss / October 13, 2017 4:28 AM PDT
In reply to: Ok I did it..

Leave the actiontec connected with the coax, then call Verizon. Once they switch it over, they will tell you when to plug the ethernet in and disconnect the coax permanently. Once you have verified the actiontec is working over ethernet, then you can proceed with the rest of the Velop setup.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?