HolidayBuyer's Guide

Storage forum

General discussion

Simpletech 320GB external hard drive not recognised any more

by Hippymidget / January 25, 2010 12:45 AM PST

I have the 320 GB Simpletech (Hitachi) Signature mini Pininifarina external hard drive, bought in August 2009. Since then I have had the occasional minor glitch, such as when trying to unplug it from my laptop (Acer Aspire 5735, running Windows Vista Home Premium) I would get a message saying: ?Cannot disconnect; ?Generic Volume? still in use?. And a couple of weeks ago the cable stopped working properly, but I found another to fit it and it has functioned perfectly well since then.
Then on Saturday night it suddenly stopped working properly. I was listening to music and the files suddenly wouldn?t open. It was late so I simply disconnected the hard drive, turned off my computer, and left it til morning. On Sunday morning, when I plugged my hard drive into my laptop, I heard the usual ?du-du? sound Windows makes when you insert a USB device. But then nothing. No autoplay options, nothing detected in Windows Explorer. Hmm? Changing the cable, unplugging and re-plugging, restarting my computer, all did nothing. I tried it on a different computer; still nothing. The device is initially detected when I plug it in, but nothing further happens. Occasionally it does show up under ?Computer management > Device management?. It has a little yellow exclamation mark, and a notification saying ?This device cannot start?. If I click ?Check for solutions? Windows does a search and then tells me that the device driver is up to date, nothing more can be done. Crap.

On the hard drive itself, there is a red light to show connection and a blue light to show when it?s busy doing something. The red light illuminates and stays on constantly, but the blue flickers weakly once and then stays off. There is also a faint tapping sound from the hard drive, like a heartbeat. It ticks rhythmically 36 times (yes I have been dejectedly sitting here with my ear pressed to it), then makes a sound like a video being rewound for a few seconds, then starts another 36 clicks. It repeats this six or seven times, then sounds like it is spinning normally. But still nothing happens. Double crap.

Ok, so now I?m getting a little worried. That thing contains all my music and pictures, and some documents. I have a few bits and pieces backed up on my laptop, but the rest ? ah! Not to worry, they?re on the family computer at home! (I should explain, I?m living in France at the moment, but originally from the UK) Quick phone call to my Dad ? only to discover that in updating the home computer to Windows 7, they decided I obviously didn?t need my user account any more, cos I don?t live with them at the moment, and besides I have everything I need on my external hard drive; so they deleted it?????

Triple crap.

Ok so now I really need to get this Signature Mini working! I look around online, and a few forums suggest checking the BIOS ? hmm, I?m not very computer-y minded so I?m not entirely sure how to change those, but as far as I can see it?s not that. Reinstalling the drivers ? nope, that doesn?t work either. If I try to reinstall from scratch I get a little popup saying ?Installing device drivers, click here for status?. The status scrolls for a little bit, installing? installing? still installing? failed. Quadruple.. well you get the idea by now.

As a last ditch attempt I followed the advice of several hundred people online saying ?Omg this really works?, and put my hard drive (well wrapped) in the freezer. That was 5pm on Sunday; it is now midday on Monday and on getting my chilly hard drive out of the freezer I have found no change whatsoever.

Is there Anything, absolutely ANYTHING, that can be done??
Or am I just going to have to shell out on data recovery? I know that since my hard-drive is under a year old I can send it back to Simpletech, but they don?t do data recovery which is the vital part of my problem!

Sorry to blab on, guys, but I thought you should have as much detail as possible.

Please please help me Sad

Discussion is locked
You are posting a reply to: Simpletech 320GB external hard drive not recognised any more
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Simpletech 320GB external hard drive not recognised any more
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
So no backup?
by R. Proffitt Forum moderator / January 25, 2010 12:51 AM PST

The story reads like others that didn't plan for the crash so this forum has the usual at the top of the forum. Try those and progress from free to trial to payware and finally

"We only lose what we didn't backup."

Collapse -
About all there is to try
by Steven Haninger / January 25, 2010 12:52 AM PST

is to take the hard drive out of that enclosure and put it into another. If it still doesn't work, it's likely a goner. That sort of thing happens every day. It's not a matter of "if" but a matter of "when" this is going to happen. The ticking you hear sounds like what some would call the "click of death" but I can't be sure. Sorry to tell you this.

Collapse -
Simpletech 320GB external hard drive not recognised any more
by hails1982 / June 21, 2011 5:56 PM PDT


You suggest taking out the harddrive and replaceing can I find another harddrive to put in this case?

Thank you

Collapse -
Re: new hard drive
by Kees_B Forum moderator / June 21, 2011 6:00 PM PDT

All my local computer shop sell hard drives. And so do all computer webshops where I live.
Might be comparable with you.


Collapse -
External Hard Drive Does Not Registering on Mac
by PowerMaxNW / October 6, 2011 6:33 AM PDT

We've had a few PowerMax customers ask us the same question so we decided to post an answer on our resources page. For troubleshooting ideas, please see this post: External Hard Drive Not Registering on a Mac. Hope this helps!

Collapse -
Have identical problem
by sridc2 / October 2, 2012 8:55 AM PDT

I am having an almost identical problem with mine. Curious to hear solutions.

Collapse -
Have Identical problem....
by cretemaniam / September 17, 2013 7:47 AM PDT

with one of my Western Digital drives ......on another forum someone answered me the following "you might need to crack the case open and plug the hdd directly into the pc , could be the usb controller on the case gone." That was verbatim and all he said . Good luck ! Mine's still not fixed . To a shop when can afford . Hate to ask , but someone else on here needs to know the voltage output specs on the same drive as yours . Can you pleas tell us ? Thanks and good luck.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Cameras that make great holiday gifts

Let them start the new year with a step up in photo and video quality from a phone.