Your router can talk 100 but your network top speed is at 10 base T. That will explain why you need your card to talk at 10 base T. Your connection to the internet via the cable router is based on the 10 base T. so that is your max.

Not the issue though. the router is the holdup. You can try to reset the router and then access it. make sure it is set for dhcp to recieve the IP from the cable company. If it dosen't recieve it, then you may need to set the router to clone the hardware address of the network card you connected to the cable modem with.
This fools the cable modem into thinking it is a single connection (Your net card) and is connected to it.
Then the router will work as it was designed to open up the connection on the back side.

The next fix you may try is to replace the network cables there may be a connection problem. Remove them and replug them is the simple option but if you have others that work, try them in place of the ones you are useing! TTFN Chris