Attention: The forums will be placed on read only mode this Saturday (Oct. 20, 2018)

During this outage (6:30 AM to 8 PM PDT) the forums will be placed on read only mode. We apologize for this inconvenience. Click here to read details

Windows Legacy OS forum

General discussion

Seagate HD will not set to DMA mode

by MelH / November 19, 2007 9:13 PM PST

XP Home, Asus P4C800-E MB, 2 hard drives on IDE 1: both work fine at UDMA 6.
Second IDE has my DVD burner in the master position and works fine at UDMA 4.
I'm using the proper cable, plus I also tried a new one when installing the drive.

I installed a 320 gb Seagate ST3320620A ATA100 into the Secondary Slave position and jumpered it as shown on Seagate's website (no jumpers). I made three partitions, and formatted them as per instructions in XP's Disk Management. They all show as 'healthy' in Windows.

The only thing is that my computer has slowed to a crawl, with a re-boot taking about 7 minutes. I checked Dev. Mgr. and saw that the burner was at UDMA 4, but the new drive was at PIO mode, even though 'DMA if available' was selected.

I tried Bob's suggestion of changing the settings back and forth and also deleting the secondary IDE channel and rebooting, but nothing works. It remains in PIO mode.

I checked all the settings in the bios and they seem correct. Tried alternatives too, but it didn't change anything.

On bootup, the bios screen shows all the drives correctly, the drive in question as UDMA 5.

I have Windows 98SE on drive 1 on the Primary IDE with Windows XP Home on the second drive, to allow a dual boot. It has worked well until I tried installing this new hard drive.

I removed it and installed it in a second machine and it is the Master on the Secondary IDE, with nothing in the slave position. Still in PIO mode. This other machine is also a dual-boot with 98SE on the first HD and XP Pro on the second, both on the Primary IDE.
The 3 partitions are in NTFS format and all drives are visible in Dev. Mgr. and all partitions are visible in My Computer.

I've googled and checked many sites for a solution with no luck.

I'm open to suggestions.

Discussion is locked
You are posting a reply to: Seagate HD will not set to DMA mode
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Seagate HD will not set to DMA mode
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Have you tried another drive?
by R. Proffitt Forum moderator / November 19, 2007 10:28 PM PST

It won't be the first time I've had to swap the drive.

Bob

Collapse -
I'm all out...
by MelH / November 19, 2007 10:46 PM PST

All four of my drives are in use with O/S's on them. You think maybe I got a dud?

Collapse -
Since the issue follows the drive...
by R. Proffitt Forum moderator / November 19, 2007 11:17 PM PST
In reply to: I'm all out...

It appears so. Does it pass their test software?

Collapse -
It did...
by MelH / November 19, 2007 11:42 PM PST

...when I had it installed on the first system. I just did the short versions of the test and they all passed. I'll see what other programs they have to test and use those as well. Thanks.

Collapse -
Suggestion if you haven't tried it
by Steven Haninger / November 20, 2007 9:11 AM PST
In reply to: It did...

Replace the cable...make sure it's 80 conductor....and set both drives on the IDE port to "cable select" rather than force it as a slave by removing all jumpers.

Collapse -
Tried that...
by MelH / November 21, 2007 5:20 AM PST

My old cable was 80 conductor and the new one I tried is the same, but no luck.
I tried cable select on both systems with the same negative results.
Seagate's support outlines exactly what I have already done as the solution to this.

This new drive works in PIO mode/NTFS in my second computer, and I'm past my RMA date, so I'm stuck with it but at least it's not a total loss.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!