Storage forum

General discussion

Sata Raid 5 Help (Silicon Image 3132 PCI-e card - SATARAID5)

by jhon614 / May 15, 2009 3:26 PM PDT

I'm trying to set up a RAID 5 array. Let me give you the details of the system.

HP m8457c PC, Windows Vista Ultimate 64 bit, Silicon Image 3132 Sata Raid 5 card with 2 eSata ports, 8 bay hotswappable hard drive enclosure with 2 built in port multipliers (supports up to 10 drives over 2 eSata wires)

The software that came with the card and hard drive enclosure is called "SATARAID5 Management Software". I believe my problem is with the software. The bios on the card is up to date. The driver for the card is up to date. The SATARAID5 software is the newest version. I can see all the drives on the card in - Control Panel (Classic) -> Silicon Image SATA Controllers. I select SiI3132 revision 1 and there is a combobox titled "device location" and the 4 drives are in there, so I know the card is at least able to see the drives and communicate this info back to Windows. The RAID5 volume that I created in Windows Disk Management is still available and functioning properly as far as I can tell.

I can not get the SATARAID5 software to launch anymore. When I try, an error message comes up saying "Silicon Image RAID controllers are NOT detected in the system. Please make sure that all controllers are installed and configured correctly. Press "OK" to exit this application." I've reinstalled the management software, I've removed and reinstalled the device driver, and I've flashed the card bios to the most recent version. Nothing fixes the problem. The management software still won't find the controller.

Why can I see the card and the drives in the storage tower in Silicon Image SATA controllers (and in device manageer) but the SATARAID5 software says the RAID controller isn't detected?

I guess what I need is a way to get the software to work or a suggestion of some other software that will work for what I'm doing. It you can suggest alternative software, it would be nice if the software included the ability to expand to additional drives for additional storage space without taking the array offline, but at this point I just need something that will work. If it matters, the 4 drives are 1.5TB Seagate ST31500341AS drives.

A little history if it helps. This may not be necessary.

I plugged in the card and installed the hard drives in the tower and then I wired the hard drive tower to the eSata ports on the card. Windows Vista automatically installed the card driver. Then I installed the SATARAID5 management software. Everything (including the management software) was working fine. I created a RAID array. I used Windows Disk Management to set up a volume and format it. The array was being formatted and I forgot and restarted the computer. When the computer came back up, the software still worked, but the array was rebuilding or something, I assume because I stopped it before the format was done. It was taking forever and the volume I created was still available and working, so I ignored it, and I restarted the computer again. I don't think the software was ever able to load correctly after that, even though the RAID volume is still working. Why doesn't the software work anymore???

Discussion is locked
You are posting a reply to: Sata Raid 5 Help (Silicon Image 3132 PCI-e card - SATARAID5)
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Sata Raid 5 Help (Silicon Image 3132 PCI-e card - SATARAID5)
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Can you
by samkh / May 16, 2009 11:42 AM PDT

see the SiI BIOS during boot up? If not, the BIOS is not integrating with your mobo BIOS in which case the Raid mgmt sw probably won't work since it most likely calls on the card BIOS.

Collapse -
Re: Bios question
by jhon614 / May 16, 2009 1:08 PM PDT
In reply to: Can you

I can get into the bios version of the manager, but the bios version doesn't see any of the drives. There is nothing in the space marked "Physical Drive" and nothing in the space marked "Logical Drive". I assume the 4 drives connected should be in there but they aren't. Also none of the 5 options work either, I assume because it doesn't see any drives. If I select "Create RAID set", it says "Not enough single drives to create Raid set!". If I select "Delete RAID set", it says "No Raid set exist !".

So the bios version can't find anything, the management software that runs in vista won't come up except to say it can't find any Silicon Image Raid controllers (even though in Control Panel/Silicon Image Sata Controllers you can see the four drives, so there must be a controller), and the RAID 5 volume is still available!

Some new info:

The software is meant for 64 bit systems, but it installed into the Program Files (X86) folder? Shouldn't it be in Program Files if it was a 64 bit program?

When I log in on using a different user name, I get a different error when I try to oper the managemet software. It says "Could not acquire application lock! Please press the button to exit". I assume the software isn't installed to All Users and so this probably has nothing to do with the problem, but I thought I'd throw it out there in case it meant something to someone.

Collapse -
By process of elimination
by samkh / May 17, 2009 12:18 AM PDT
In reply to: Re: Bios question

1. insert in another PCIe slot
2. insert card in another PC
3. RMA and exchange card
4. incompatible BIOSs
5. live with it or trade for a different brand (was it bundled with SATA box?)

You should have full RAID mgmt in BIOS i/f. Mgmt in Windows just presents a GUI.

Collapse -
Found a Solution that might help someone else
by jhon614 / May 25, 2009 11:58 AM PDT

I fought with it for awhile and found that it must be a problem with some of the new software (possibly conflicting with Vista Ultimate x64). There are essentially 3 things that have upgradeable software, the bios on the card, the driver for windows, and the Management Software to access the card. I found that with the newest driver, newest bios, and newest management software, it didn't work.

I fixed the situation just by using all the software that was one generation old. Now it works without any problem. Also, if you read the description closely about the software you're downloading from Silicon Image, it's clear what software will work together (this bios works with this driver and this management tool).

Helpful Resources:
There is a link for Driver, SATARAID Tools (management software) and BIOS. Just read to get the software that matches. If the newest software doesn't work, try the older stuff. It worked for me.

Collapse -
SATA RAID 5 startup problems
by daw456 / June 3, 2009 7:22 AM PDT

I am using SATA RAID 5 (Silicon Image 3132 PCI controller) with Windows 7 RC on a Dell Studio XPS 435MT, Intel Core i7-940 processor(8MB L2 Cache 2.93GHz).

Initially the SATA RAID 5 screen would start automatically, but none of the menu functions would work. I got things working by installing an updated version of Java, but now I can only get SATA RAID 5 started by initiating it from a batch file under administrator priveleges. (A workaround I found on the web.) Gan anyone suggest the sequence of installation steps for SATA RAID 5 on WIN 7 RC so that everything starts up normally and works as intended?

A SECOND PROBLEM is how to shut down the system properly. It seems I always get messages (if I look in the SATARAID5 log) that show recovery from a previous improper shutdown each time I start the system. The RAID5 volumes each spend about 4-5 minutes recovering after system boot (and SATARAID5 display goes from yellow to green on these drives). Any suggestions welcome.

Collapse -
win7 x64 pro sataraid 3132 card with DAS
by mltaylo3cnet / March 21, 2012 5:11 PM PDT

Used the following: management software = 3132r5_standard_15190_logo_win7, card bios = sil3132_r7702 (the "r" is significant, so pay attention as there will be three choices when you download), win 7 driver = 3132r5_x64_15190_logo_win7. Management software took a long time to install; not sure what's up there, but this is the combination that worked for me. Credit goes to Jhon614 for the link to manufacturer website and advice to find the correct matching combo. Just wish he would've specified which he actually used, so I did that here.

Collapse -
Sata Raid 5 Help (Silicon Image 3132 PCI-e card - SATARAID5)
by petekat03 / July 6, 2009 6:13 PM PDT


Sounds like when you flashed the cards bios you might of flashed it with bxxxx.bin instead of rxxxx.bin. The bxxxx.bin file configures the card as a standard SATA controller. The rxxxx.bin configures the card as a SATA RAID controller.

If you reboot after re-flashing the cards bios, the SATARAID5 software should come up OK.

Collapse -
SataRaid5 Software solution
by bryanhe / October 27, 2009 11:57 PM PDT

The problem is that the software cannot see the service. I solved this (in Windows 7 x64) by setting the Sata service software to "Automatic (delayed)".

Now, the Redundancy repair after each reboot is killing me....


Collapse -
It's UAC causing the problem
by LOVELYsaleem / November 5, 2009 10:09 AM PST

The solution with the delayed start did not work for me.

I found out is was the User Account Control that was interfering with it in Windows 7.

Once I turned UAC off, the SATA RAID manager had no problem starting.

Collapse -
Accessing Sataraid5 Software Without Disabling UAC
by nhelder5 / October 26, 2011 10:50 PM PDT

You can leave UAC enabled if you grant your user full control over the:
C:\Program Files (x86)\Silicon Image\3132-W-R\logs\AppLock
file - or, if not on a 64-bit machine:
C:\Program Files\Silicon Image\3132-W-R\logs\AppLock

Right-click on the AppLock file, select the Security tab, click the Edit button, add your user to the list, click OK and then in the lower pane click the checkbox for Full Control.

- Nathan

P.S. Thanks to KBeee for the no-rebuilding-on-restart trick and to bryanhe for the tip about the software not being able to see the service.

Collapse -
Reboot issue
by sagig76 / November 26, 2009 5:57 PM PST

Were you able to solve the restore redundnacy after reboot issue? i have the same problem and it is making me crazy

Collapse -
Fixed "Repair Redundancy" reboot problem for me
by KBeee / January 12, 2010 10:32 PM PST
In reply to: Reboot issue

This worked for me. I advise you to back up your data first, though for me no data was lost.
In the Sataraid5 software delete your array. In File->configuration->advanced options check the "Advanced RAID Features" box. Recreate your Raid group, but setting the checkpoint option to OFF instead of the default ON. Mine now reboots OK.

Collapse -
(NT) good job, Brian! that worked for me. Thanks!
by pkokkinis / February 24, 2010 2:59 AM PST
Collapse -
by croca64 / March 6, 2011 12:29 PM PST

I've also had this problem, both with the Silicon 3114 and now with Silicon 3132. I found out it was running in the background but the Raid controllers were not detected.

When I disabled Windows Firewall and rebooted, the software works perfect. I also tried to "allow" the software in the Firewall but I couldn't get it to work - I had to disable the Firewall completely.

Collapse -
I installed the driver from Windows Auto. Updates
by loann2846 / August 18, 2014 2:39 AM PDT

I run Windows 7 Ultimate. I chose the optional driver update from Windows Automatic Updates. It updated to version and I did not get "controllers not detected" error message anymore.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


iPhone 8: Everything we know so far

This is all the iPhone 8 reports and rumors in one place. From a 5.8-inch OLED display, reports of wireless charging and even a 3D scanner for facial recognition, it's all here.