Windows 7 forum

General discussion

SATA HDD showing up as removable drive

by MarkFlax Forum moderator / January 31, 2011 5:08 AM PST

This is a new install of a genuine Windows 7 64 bit Ultimate OS onto my Alienware Desktop.

Quadcore i7 Intel, 12 GB RAM and 1 TB SATA hdd.

The system was running Vista 64 bit on 2 x SSD in Raid 0, but the SSDs kept failing, so I disconnected and removed those and installed Win 7 on the remaining hdd.

The install went well although I had to change the BIOS Storage Configuration from Raid to ACHI and set the hdd in boot order.

However, the "Safely Remove Hardware and Eject Media" icon is in the Win 7 Action Center in the Notifcation Area, and clicking that shows "Eject STSST31000528AS ATA Device".

What did I do wrong?

Also in Device Manager, the disk drive is listed as ST31000528AS ATA Device but in the Policies tab of it's Properties I see options for "Quick removal".

Image here;

Seems I have set this up wrongly, but not sure where. Anyone point me in the right direction?


Discussion is locked
You are posting a reply to: SATA HDD showing up as removable drive
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: SATA HDD showing up as removable drive
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
That's find for sata.
by R. Proffitt Forum moderator / January 31, 2011 5:20 AM PST

That's the support for eSATA kicking in. Be sure to install Intel's Rapid Storage Technology driver to help transfer times too. This happens if the SATA controller is set to AHCI mode. AHCI supports hot swapping, so all is working as expected.

I consider this to be nothing more than an annoyance.

Be sure to leave it as "Quick Removal" for now.

Collapse -
Typo. fine for find.
by R. Proffitt Forum moderator / January 31, 2011 5:22 AM PST
In reply to: That's find for sata.


Collapse -
That's good, and
by MarkFlax Forum moderator / January 31, 2011 6:21 AM PST
In reply to: That's find for sata.

thanks Bob.

I will change to Quick Removal and search for Intel's Rapid Storage Technology driver. I have a Vista driver's disk. Any chance it will be on there? I know, how could you possibly know if I don't. If not I will search Intel's site.

Just as I thought I was getting to grips with hhd interfaces you go and mention eSATA! If that means external SATA drives do you know any reason why the OS thinks my primary drive is an external?

Much obliged.


Collapse -
by R. Proffitt Forum moderator / January 31, 2011 8:46 AM PST
In reply to: That's good, and

EHCI supports hot plug of all SATA ports so it's proper for this to show that way.

There is no electrical difference from internal to external SATA connections (and yes it is a different mechanical connection.)


Collapse -
Ouch, that was painful
by MarkFlax Forum moderator / January 31, 2011 8:53 PM PST
In reply to: Why....

Things seem to be working OK now, but I changed the Device Manager setting for the Disk Drive Policies tab to "Quick removal", and rebooted as requested. The reboot stalled during POST where it was searching for a CD/DVD disk. The normal countdown time is 35 seconds, but usually that times-out much earlier with 'No media', then proceeds to the hard drive. This time it didn't, and the 35 seconds countdown was very slow, more like 15 seconds for each numbered countdown.

I did a hard turn off, (depress the on/off button for 5 secs), started again and entered the BIOS and had to re-order the boot priority, and also reduce the IDE search countdown and Optical disk search countdown to 10 secs. BIOS restarted and it booted up OK.

The system seems slower (disk access), and that's a concern but I'm delaying judgement for now.

I'm still searching for information on Intel's Rapid Storage Technology driver and as usual none of what I have found so far is in easy to understand words of one syllable. I have found this,

but I am hesitant to just push ahead and download/install without knowing more. I'm reading the Readme file there. It is in Greek! Or may well far as my understanding is concerned. But I am pushing on.

I've just finished installing 49 Windows Updates.

Thanks again Bob.

Collapse -
Not to discourage you
by samkh / February 1, 2011 2:04 AM PST
In reply to: Ouch, that was painful

but life is simpler when you set SATA to IDE in BIOS. You didn't say what mobo you have and I'm assuming all X58 mobos would have the option.

Hot plug isn't a popular activity so I don't miss it, but I do miss some Linux-based backup utility not recognizing ACHI or RAID. IDE emulation works great, for SSD too, and no noticeable speed disadvantage.

You could try using one of the 30GB SSD as boot drive if you don't load a lot of apps (try this tip:; preserves your previous speed even w/o striping. Actually striping doesn't offer much speed over single disk when using SSD.

Collapse -
Not that easy.
by MarkFlax Forum moderator / February 1, 2011 9:16 PM PST
In reply to: Not to discourage you

Thank you for your comments, and you're right, I didn't say what the mobo is. It is an;
Intel? X-58 Chipset Motherboard- Socket 1366 Core i7 Ready, Triple Channel DDR3 Memory

It seems to be running well and despite my comment about the hdd performance I think it's fine. I guess I was spoilt with the apparent instantaneous read/write of the SDD, but access times with this hdd seems fine.

This motherboard does have the options to choose Raid, ACHI or IDE, and I had read up extensively about ACHI and IDE options in the BIOS but I am not technically minded. However, the general consensus seemed to be that ACHI was better than IDE, so that is what I chose.

As to using the SSDs as a boot drive, I suppose I could separate them and use one of them, but my experience with SSDs has been problematical, so I will see how I go wit the normal hdd's.


Collapse -
You should be OK now
by samkh / February 1, 2011 11:30 PM PST
In reply to: Not that easy.

with HDD. I was just giving you ideas that sometimes can be injurious if you're not careful, so stay with the tried and true until you're ready again to be adventurous.

There's just no good reason anymore I can see for arrays in a PC. In olden days when capacities were tiny and heads moved sluggishly, Raid 0 served a purpose but modern drives are good enough in both regard, so eliminate the risk. Servers continue using various levels of Raid successfully because the controllers, OS, drivers, drives and managers are stress tested for reliability beyond anticipated loads. PC costs cannot afford that luxury.

Some SSDs are problematic with some chipsets/SATA controllers and SSD controllers themselves are evolving at the bleeding edge. There's just no sure combination at this point, so DIY'ers are doing it on trial and error. Most are okay but some corner cases exist. If you have a vendor with refund or exchange privileges, you can play.

Collapse -
by MarkFlax Forum moderator / February 3, 2011 8:31 PM PST
In reply to: That's find for sata.

Installed Intel's Rapid Storage Technology Chipset drivers without problem.

Scary, I'm going to have to lie down in a darkened room now! Happy

Many thanks again Bob for your guidance.


Collapse -
Ohh, and my internal hard drive
by MarkFlax Forum moderator / February 3, 2011 8:31 PM PST
In reply to: Done.

is no longer being offered as an ejectable device.


Collapse -
That's good.
by R. Proffitt Forum moderator / February 3, 2011 10:32 PM PST

And what I expected. Yes you do get another icon on the bar but you can control that too.

You also need to know that CDBUNERXP can't find a CD/DVD recorder on all the machines I've tested with without this Intel driver.

And my machines run faster so it appears I want this installed.

Collapse -
Sadly, I spoke too soon
by MarkFlax Forum moderator / February 4, 2011 2:52 AM PST
In reply to: That's good.

Although the system soft restarted a couple of times, (once after install, second time after hardware found), on my next cold boot it failed to load Windows. Windows logo loading screen failed to progress.

A hard turn off and restart brought me to the Windows Repair utility and that offered me a System Restore which I accepted. That worked but it removed the SATA Chipset drivers and Intel control panel.

I'm not sure why this happened, but I will attempt the same again.

The event viewer showed no problems, strangely, except the hard close down. The repair entries found no problems that I could see.


Collapse -
I had a mystery machine that did that with NEW parts.
by R. Proffitt Forum moderator / February 4, 2011 4:24 AM PST

Since we were just tinkering in the SATA area it makes me think of this other cranky machine that found after much too much troubleshooting HDDs with out of date FIRMWARE.

This about the second time in ten years this has cropped up but all in 2010 so far.

Collapse -
Could well be
by MarkFlax Forum moderator / February 4, 2011 5:14 AM PST

And this is hard work for me and a whole new area of research.

This is a new hdd, a Seagate Barracuda 7200.12 Model: ST31000528AS, Serial: 9VP8WVY0, Firmware: CC38.

Searching around I have found a firmware update available at this link;

Yet again this is scaring me to death! The link has the usual 'notes of impending doom' with "If the firmware upgrade installation instructions are not followed properly, the firmware upgrade could be data destructive and/or render your hard drive inoperable"

I have 3 other Seagate Barracuda 7200.12 drives like this, two of which were provided by the manufacturer as replacement drives.

I'm going to have to do it though aren't I?


Collapse -
AFTER YOU BACK UP your stuff.
by R. Proffitt Forum moderator / February 4, 2011 6:01 AM PST
In reply to: Could well be

Let me lead with when this one hit it was an area I rarely expected problems.

-> I used the bootable CD ISO method but had to flip the BIOS to IDE emulation mode. But try it without changes to the BIOS.

Be sure there are no other drives attached but the one to update.

Yes, it's scary but the tool Drive Detect software if I remember showed the drive BIOS version in RED if there was an issue.

-> After the changes the machine began to behave. The theory is that some bad read occured and Windows threw a fit.

Collapse -
Firmware updated
by MarkFlax Forum moderator / February 4, 2011 9:31 PM PST

Everything backed up, there wasn't much as this is a new install of Win 7 onto a new disk.

I ran the Seagate firmware updater. There was no option to run it from CD as Seagate offered this updater.exe as a windows GUI and not an iso. However it all worked. Ran the .exe and the system restarted and proceeded with identifying the hardware and updating the firmware before loading Windows.

Then a restart and Windows loaded properly. New hardware found, (the hdd), and that asked for a restart which went smoothly.

Now to try the Intel Rapid Storage Technology Chipset drivers again.

Just a note about the Intel install. I tried to re-run it last night but it stalled during installation. I had to do a hard shutdown, (again), and reboot, and started investigating. I found a number of logs in Intel's Program folders for the failed attempt, and it was showing numerous 'skip' lines. I suspected that I should have uninstalled the Intel software thru the Control Panel > Programs and Features. I did that, and all the logs and Windows\Temp files went.

Will be attempting the install again soon.


Collapse -
MY XP PC ...
by Kees_B Forum moderator / February 4, 2011 5:52 AM PST

also has an option to remove the SATA c:-drive. I never used it, but I expect it will be refused because there are files open on it. I always accepted that as a XP-SATA issue.

Now you say it, I checked it doesn't happen on my new W7 PC. That's a nice, but rather unimportant detail. Could be W7, could be the motherboard, could be a BIOS setting. Who cares? I don't. It works fine.

So I wonder why you care. Just set it to 'better performance' and 'enable write caching' (not clear to me what the difference between these settings is). And never do a quick removal (you shouldn't do that with power on, of course, so that's an easy one) and don't disconnect the from the power (not much outages in Derby, I suppose) without shutting down first.
What am I missing?


Collapse -
Why am I doing this?
by MarkFlax Forum moderator / February 4, 2011 10:18 PM PST
In reply to: MY XP PC ...

Or should that read, "Why I am doing this" Happy

This is a custom specified Alienware built machine, less than 2 years old, which started with 2 SSDs in RAID 0, in addition to two, 1TB standard SATA drives, and Vista 64 bit Ultimate.

From day 1 the SSDs have been a problem with intermittent failure to load Windows, resulting in complete failure to load and RMA back to Alienware twice to resolve the issue. Each time they returned it with a fresh install of Vista, but no indication of what they had to do, despite me asking them to tell me. I suspect the issues were TRIM related, (lack of TRIM on Vista), needing a complete wipe of the SSDs to return the pages to empty. In between the two RMAs I had several phone conversations with their help desk about this, but they were unable to offer any advice. The system is still under warranty but I suspect I have voided that now by discarding the SSDs.

I don't blame Alienware at all. I knew this was an experimental setup when I customised it at the order stage. This type of Desktop is an enthusiast's machine with "Tools Free" access to the inside of the case, but I am certainly not an enthusiast, nor technically minded. So I knew the risks and accepted that. But this was/is a high end system packed with components, quad-core, 12GB RAM, liquid coooled, dual graphic cards, and SSDs, (and a pretty case), and since it is possible this will be my last system I wanted one that would beat the competition initially, and then 'keep up' up with it for a while to come. We already see off-the-shelf systems with dual-core and 8GB of RAM, and now we are seeing SSD boot disks, so I am still ahead of the game, but only just, and the rest of the world will catch up in a couple of years or so. Just guessing of course.

But, and again I am guessing, my SSDs are experimental. They were not common when I purchased this. I know SSD technology has improved to account for the TRIM related problems but mine are older and cannot be firmware upgraded. Intel has a utility that replaces Windows 7 own TRIM controls for better lasting SSD use, but it is too new for my SSDs. I couldn't continue with these SSDs so I have removed them.

That's why I installed Win 7 on one of my 1TB normal drives, but since this is an all SATA machine and since the Win 7 disk is retail, it doesn't have the necessary SATA controllers to manage the SATA drives correctly. You're right that I could have continued as I was, but it really didn't feel right.

Your XP system probably showed the SATA drive as removable because XP didn't have native SATA support. I am guessing again, Happy

So that's why. This has got to last me for some time and I need it to be right.

I can't remember the last time we had a power cut here in Derby. Well over two years ago.

It has all been hard work for me, and always frustrating, but again I am not complaining, (well, not out loud), and I am learning as I go.

Now to try and reinstall the Intel SATA technology again!


Collapse -
I see your problem immediately
by Steven Haninger / February 5, 2011 1:50 AM PST
In reply to: Why am I doing this?

It's in the brand name. Buy something made on planet Earth and stop wrecking the world economy by sending money out of our solar system. Happy

Collapse -
Now you tell me!
by MarkFlax Forum moderator / February 5, 2011 2:40 AM PST

I'll remember that in future. Happy


Collapse -
Madness I say.
by R. Proffitt Forum moderator / February 5, 2011 1:37 AM PST

As I deal more and more with firmware on systems I am not happy with what I'm seeing. The very idea that parts like the HDDs needing a firmware update is not a good sign.

-> Your SSD could have failed for a similar reason.

There is more firmware in some RAID controllers and of course the BIOS with a minefield of guessing which one is going to have the least issues.

And there's the rub. I've yet to find anyone claimed they fixed every bug.

Collapse -
3rd time lucky it seems.
by MarkFlax Forum moderator / February 5, 2011 2:53 AM PST
In reply to: Madness I say.

Well installing the SATA chipset and RTS seems to have worked this time. Still mystifying though.

The install forced a restart as expected but again Windows halted and the logo screen. This time though after a hard shut down and restart instead of allowing Win 7 to diagnose problems, I selected to boot normally, and that worked. I wonder if I should have done that the first time.

Several hours later, after numerous manual restarts including a few cold boots it seems to be holding up.


Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


The most beautiful phone ever has one wildly annoying issue

The Samsung Galaxy S8's fast speeds and fantastic curved screen make it a top phone for 2017, but the annoying fingerprint reader could sour your experience.