Samsung forum


Samsung TV: Smart hub not working (no apps)

by BeccyS77 / February 3, 2012 1:17 AM PST

I have purchased a Samsung TV and successfully connected it to my wired network (have checked in the menu that I have internet connection) - but when I press the smart hub button, all I see are the 9 default icons on the bottom (favourites, channel, music, videos etc) and nothing else. There is a banner at the top that says "new samsung apps" but when I click on this, I just get "connecting" in the middle of the screen and that stays like that for over 10 mins (so I guess it crashed?). The only way to exit this is to turn the TV off. I also have the word "recommended" under the "new apps" banner but this is empty. Does anyone know why I can't see any of the available apps, or the web browser button which should be available on my model (at least that's what the bloke in the shop told me!). At the minute the smart hub menu is completely useless....

Discussion is locked
You are posting a reply to: Samsung TV: Smart hub not working (no apps)
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Samsung TV: Smart hub not working (no apps)
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Samsung TV: Smart hub not working (no apps) -
by Samsung_HD_Tech Samsung staff / February 3, 2012 5:09 AM PST

BeccyS77 -

Collapse -
Tv type #
by BeccyS77 / February 3, 2012 3:25 PM PST

The number on the back says ue40d5520. Thanks for any help you can give

Collapse -
Tv type #
by Samsung_HD_Tech Samsung staff / February 14, 2012 1:29 AM PST
In reply to: Tv type #

BeccyS77 -

Collapse -
Smart hub not working
by ivo10000 / February 5, 2012 8:40 PM PST

I have a very similar problem with my Samsung TV D 6000 series. However, I successfully used over 30 applications including Web browser. Then the web browser icon was suddenly not operational (I could still access web browser thru favorites icon).
Trying to remedy this I madde a Reset of Smart TV using the blue button. Now I have only 11 basic applications and cannot install any additional ones, neither use the Search field. Checking the properties of Smart TV (thru the blue button) it still lists 34 applications, although there are no corresponding icons. The web browser icon is there but not operational, but I can still access web browser thru favorites icon. I have also installed the latest firmware but to no avail.
Any help would be very appreciated.

Collapse -
by BeccyS77 / February 10, 2012 4:29 PM PST
In reply to: Smart hub not working

I am going to ring Samsung today, I'll post what I find out

Collapse -
Another update, got it working.. I think!
by BeccyS77 / February 11, 2012 6:34 PM PST
In reply to: Smart hub not working

I got these instructions from Samsung. My menu didn't exactly match their description but I was able to follow it through. First time around I did the two things in the email and it still didn't work, so I left the usb in the tv and then restarted my router again, made sure I had Internet connection by pressing menu on the remote and then going to network. Then when I switched tv on/off and went to smart hub, it asked me to update again, which I did. Then it started downloading the apps etc. looks ok now. Hope this helps!!
Instructions from Samsung are below...

Collapse -
Smart hub not working
by ivo10000 / February 13, 2012 6:22 PM PST

Thank you for publishing your solution. Alas, it didn't work for me, so I have still no access to applications or search. Beware of Smarttv Reset!

Collapse -
Smarthub problems
by BeccyS77 / February 13, 2012 9:28 PM PST
In reply to: Smart hub not working

Sorry it didn't work for you - I don't think ours is fully working yet as we don't have a web browser button - I will stay away from the blue reset button - thanks for the warning. Are you in the UK? I found an alternative telephone number rather than the 0330 one Samsung gave me - it may be cheaper - it's 01932 454358. The lady I spoke to was very pleasant and helpful - hopefully someone there can give you the answers you need. Good luck, hope you get it sorted.

Collapse -
Smart hub not working
by ivo10000 / February 14, 2012 5:02 PM PST
In reply to: Smarthub problems

Today all of a sudden SmartTV started updating and it now works as previously. I assume that the Big Brother (or central server) needs some time after the basic reset (Exit button) to react. Even the web browser icon now works correctly (this might be due to the helping hand of St.Valentine).
Regarding your web browser: the leaflet I received with my TV set specifically states that web browser in Europe is available only with models 6500 and up. Not much help, I'm afraid. Then again it's rather slow and cumbersome. Gmail is not working properly and Samsung says they are not responsable for other applications (?). Gmail is obviously something very exotic to them.

Collapse -
Glad it's working :)
by BeccyS77 / February 14, 2012 9:23 PM PST
In reply to: Smart hub not working

Crazy isn't it. We bought our model TV as the guy in the shop said it would do everything, including web browsing - which is apparently not true! That'll teach me to believe what they say in-store! Glad you are back up and running. Hopefully this thread will help others out who have the same problem (or at least give them hope that one day it might just update and spontaneously start working again!). There seem to be quite a few people out there struggling with the same thing but not many online solutions. I had to trawl about to find a UK contact number to call - it really should be easier to find access to over-the-phone assistance rather than online help which is pretty useless.
Samsung take note!!

Collapse -
what is the solution
by tsentissi / April 19, 2012 7:31 PM PDT
In reply to: Glad it's working :)

Hi All,
I have the same issue, with samsung, please can you send me the steps to resolve this issue.
Many thanks

Collapse -
What issue?
by Kees_B Forum moderator / April 19, 2012 7:42 PM PDT
In reply to: what is the solution

What issue?

You reply to a post by BeccyS77that doesn't mention having had any issue. All she says it's glad that something started again to work suddenly. So, according to that post, all you should do is wait till it's OK again.


Collapse -
by tsentissi / April 19, 2012 8:12 PM PDT
In reply to: What issue?

I have check my internet connection with my TV it's ok
when i go to Smart hub TV
i can't search any new application
i have only the default one.


Collapse -
Smart hub not working
by ivo10000 / April 20, 2012 6:19 PM PDT
In reply to: information

What is your model number (and country)? Not all Samsung TV models offer the same SmartTV capabilities. This is specified on the special SmartTV leaflet you might have got with your TV set.

Collapse -
Help with the update above
by nmccallister / May 8, 2012 6:51 AM PDT

I have followed the instructions to download and install the update onto a dongle. Now what do I do with the dongle ????

Collapse -
Here you go...
by Samsung_HD_Tech Samsung staff / May 9, 2012 5:39 AM PDT


It depends on your model precisely where it's located, but it out to be a USB port on the back of the TV normally. Just so you know, this forum is meant to mainly support US products and customers. . So while I can't help you directly, if you want Samsung help, here's the Samsung UK portal for support:

But we got a nice little community here, and they might have a few other suggestions to help you out.

Hope this helps you!

-- HD Tech

Collapse -
I am in the US ..
by nmccallister / May 9, 2012 8:07 AM PDT
In reply to: Here you go...

my TV does have usb ports on the side and the back. Do I just plug in the dongle and power on the TV ??

It's a Series 7 750.

Collapse -
by BeccyS77 / May 10, 2012 12:37 AM PDT
In reply to: I am in the US ..

Only just revisiting this thread - yes, I think I just put the dongle in and turned on the TV...

Collapse -
Dongle Visible
by nmccallister / May 10, 2012 3:04 AM PDT
In reply to: Dongle

The file has been installed on the dongle - Folder T-MST5DEUC and file

When the TV checks the dongle it gives back a message that there is no file on it.

I have verified the presence of the file and actually re-installed it on the dongle.

Collapse -
That's not what happened here.
by R. Proffitt Forum moderator / May 10, 2012 3:20 AM PDT
In reply to: Dongle Visible

Here I went to the UK site to get the firmware and it's some .exe file. Ran that and on my USB stick is the folder "image" with 9 files inside.

You should call Samsung and have them walk you through this.

Collapse -
Samsung Smart Tv Led 32inch, apps unusable
by nogba87 / November 28, 2012 12:59 AM PST


i bought a 32 inch smart tv last week, i have connected the tv to the internet succesfully via wireless connection.

when i go to the smart hub to use the default apps on screen (eg samsung apps kids etc) i click on an app and on the top right hand corner i have "CONNECTING" on all the time and nothing happens.

can you help me out on this, how can i use the apps and browse the internet on my smart tv.

Collapse -
by R. Proffitt Forum moderator / November 28, 2012 1:17 AM PST

Please try to avoid cross posting.

Collapse -
by mrcitruso / August 19, 2012 3:58 PM PDT

I have a similar problem. Samsung 750 series smart tv. Cineplex and Cinema now apps are not loading. I think it does not have divx loaded on this tv. Ive called both samsung and Cineplex they both blame each other for the problem. I have gone to the brick best buy,m and future shop all there tvs paly these apps so *** is wrong with mine and why can I not find an answer?

Collapse -
I'd start with a new post.
by R. Proffitt Forum moderator / August 19, 2012 11:46 PM PDT
In reply to: help

And supply the exact model, how it's connected to the internet along with the transaction number from your call.

I have a few tips about the networking but can't tell if your issues have been addressed in any way. That is, did anyone talk to you about firmware updates, deleting and reinstalling apps and more.

It is best to put this into YOUR new discussion.

Collapse -
I have boughtUE46ES6710 and having the same issue..please he
by Venky0330 / January 10, 2013 6:17 AM PST

I have recently bought UE46ES6710 and having the same issue..please apps arenot working although connected to internet but still showing as error message internet is not connected..also downloaded apps and itv player are automatically deleted.

Collapse -
Smart hub broken on a tv that worked fine for 6 months
by Chris2013 / March 3, 2013 9:14 AM PST

I have had my Samsung television for about 6 months and never had any problems with it until today.

I opened Smart hub only to find out every application I have will not connect. I double checked the settings on the network, and when I test it through the network settings, it says it is connected just fine. Even though it says it is connected, all applications within smart hub show "connecting" for about 60 seconds before stating the television is not connected to the internet.

When I checked for updates, it stated a newer version was available, so I downloaded it. (It would connect to internet to download the update)

Problem solved? I think not!!!

I downloaded the most recent update, went back into smart hub only to find all the apps I had downloaded were now gone. Just the factory applications were there, of which none will connect to the internet yet.

This sounds to me like Samsung had a faulty firmware update causing everything to crash.

Collapse -
Smart Hub Deleted all the apps automatically
by contactronak / March 3, 2013 9:50 AM PST

I'm facing the same issue since yesterday. Suddenly all the apps are gone without any warning. Now I can't even go inside Smart Hub. All it says is there is no network connection ERROR_UPDATE_003. The network status from menu says I'm connected to internet.

Tried Smart Hub reset and TV reset both, nothing helped. I updated to latest firmware also but to no avail.

Collapse -
Me too
by Kpb564 / March 3, 2013 9:27 PM PST

I have a series 8 55" and today my smart hub just loaded up with no apps at all. No bloatware - nothing. It won't update, I can sometimes install an app but if I can it disappears again. Pulling the plug is sometimes the only way I can get back to TV, and resetting the smart hub doesn't work. I did run a firmware update for the TV, and my smart hub is occasionally saying an update is available, but it won't let me press ok - the cursor stays on the few remaining icons in the background. Not happy.

Collapse -
Got the apps back....
by kram099 / March 3, 2013 11:29 PM PST
In reply to: Me too

So last night I went into the Smart Hub and HBO Go was getting errors that it would not connect. So I did a reset and it deleted all my apps though the Smarthub using the 0000 pin method. When I went to try to get new Apps nothing responded. I searched for an update wirelessly on my TV and it did find an update to the firmware. It updated and reseted the TV but the Smarthub still was not responding to get new apps. So I went into the web browser in the smarthub and after about 1-2 minutes it said that it was updating. Once it updated and I exited the browser all the old apps were there (HBO Go, Netflix,ect.). I went into HBO Go and it connected with out any issues. I just had to re-register the account.

Hope this helps in any way... I was having the same problems as you guys were.

Collapse -
Network Interference -- Apps can't connect
by Hurcomb / March 4, 2013 12:40 AM PST
In reply to: Got the apps back....

Model LN55C650 / Internet@TV vers 2.398-5.1.00277 Last night watching Netflix, picture froze. Once able to exit, could not connect to anything. Reset my Network by powering off and removing dongle numerous times to no avail. Reentered my security passphrase -- nothing. Hoping this morning all would be well but still no connection to network. Now it sees my network but am not sure it can connect even thou has correct password. At times while it had name in wireless prompt,, when trying to connect it seemed not to recognize any networks at all. When it does see the 2.4g network I use but no longer recognizes the 5g as it used to. Been quite a few months since I noted a firmware update happening. Do not know how to get it to find it to prompt firmware update check. Afraid to do a system reset as that's so many system and app ids to restore. Is there an easy way to find -- can I do this online on laptop or do I need to find on the Internet TV panel. Thanks for any advice or insights as to what might be happening.

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


The most beautiful phone ever has one wildly annoying issue

The Samsung Galaxy S8's fast speeds and fantastic curved screen make it a top phone for 2017, but the annoying fingerprint reader could sour your experience.