Resolved Question

Samsung Smart TV - UE32D5520

I recently purchased (within the last month) a Samsung Smart TV UE32D5520RX and have had no problems with it.

Earlier today when the TV was switched on I was asked by the TV if I would like to install a new software update that was available for the TV, to which i promptly said 'ok'.

The install completed with no problems, and the TV was left on for about another 4 hours after the install and everything was fine, no problems what so ever.

I then turned off the TV as I was heading out. A few minutes after turning the TV off I realised I had forgotten to set a programme to record and promptly turned the TV back on again.

At this point the 'Samsung Smart TV' splash screen / loading screen came into view and about 5 seconds later the TV turned itself off.
The TV then turned itself on again, and again displayed the 'Samsung Smart TV' logo and again 5 seconds later the TV turned itself off and then on again. And so on and so on for many minutes until I finally turned the TV off at the plug.

Given my experience with things like Microsoft Windows it seems to me that the TV had got itself in a loop of trying to boot its software / firmware and failing miserabley at it.

The problem I now have is that two hours later, and after leaving the TV unplugged, etc. etc. the TV still will not 'load'. In fact i tried doing a manual install via a USB stick of the firmware (which I have downloaded from the Samsung website) but the TV does not stay powered long enough for it to find and boot the firware update on the USB stick.

The only thing that changed from when I turned the TV on this morning (when it worked) to when I turned it on this afternoon (and it did not work) was the software update in the middle.

So has Samsung's own software update broken my TV? And simply, how can this be fixed?

Discussion is locked
AliH100 has chosen the best answer to their question. View answer
Reply to: Samsung Smart TV - UE32D5520
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Samsung Smart TV - UE32D5520
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

Best Answer

- Collapse -
Samsung Smart TV - UE32D5520


- Collapse -
Samsung Smart TV - UE32D5520

Thank you for the speedy response, and sadly I knew what your answer was going to be.

After much searching of the internet (and I mean a lot of searching, as it was not the easiest piece of information to find) for how to restore the original factory setting; I did find information about holding the exit button for 10 - 15 seconds, and unfortunately the TV only stays on for about 7- 8 before it restarts / reboots.

I do plan to call the local customer support in the morning when they are open, but I was interested to hear a response in the mean time which you have provided.

I would ask however why Samsung's own software update appears to have wiped out Samsung's own firmware? And I would suggest that this may be something Samsung should look into in case what appears to be a one off hic-cup (after finding nobody else on the internet having experienced this problem, which does not mean it does not exist of course) turns into a more widespread issue affecting every Samsung Smart TV worldwide.

- Collapse -
Samsung Smart TV - UE32D5520


- Collapse -
you are not alone

You are not alone same tv, same time, same update. (in uk)

I knew the update was botched the minute the tv didn't turn off. The only reason I allowed the update was in the hopes that they had fixed the psychotic smart apps. the last thing you want is a 10min update installing the apps you deleted 3 days ago everytime you press the smarttv button. just wish I could delete facebook! fyi samsung, new apps are not an update and you shouldn't force them on users. a message of availiblity is all that is neccessary if you must, otherwise what's the point of the appstore.

samsung were as helpful as ever. "sorry we're experienceing problem. We'll call you back within the hour". This was at 5pm friday and they close at 6pm, so as expected no call.

I expect their technical problem is a large number of shafted tv owners.

Like you, I found no helpful info on the internet for botch firmware installs. loaded usb with old and new firmwares in the hope it would look to usb on failed boot but no success.


- Collapse -
Same issue for me - update killed the TV

Just to add to this thread, earlier this year I tried to update my Samsung ue32d5520 using the auto update and it killed the TV. There were no outages during the update, as per previous poster it didn't reboot itself (left on for 2 days) and then eventually I turned it off and then on. Now boots up, displays the Smart TV logo for a few seconds, then reboots. Not on for long enough to hold down exit key for any length of time. When I contacted Samsung they said I had to take it to an authorised samsung technician (none within 30 miles) who would check it and if they confirmed that it was indeed the update that killed it, then they would consider next steps. If however the update wasn't the cause of the problem, then i'd be liable for the inspection costs. When i questioned how they would confirm the update killed it, they were non-committal. I have a local repair shop who could perform the same function, but they said there was no way they could tell samsung it was the update since there's no way to know, so suggested I'd be better off buying a new one as then at least I'd be covered by warranty, rather than gambling on samsung admitting fault and fixing their mistake.

Really disappointing, and i'd love to complain to trading standards or some such but there seems to be little point, so thought I'd add my comments to this as part of my personal therapy!

- Collapse -

I have the same set and have no problems with it, just wonder could you telnet into it and ftp the old firmware back in while it is in standby condition and it might come back to normal I suggested telnetting into it as it has an ethernet connection on the back maybe this is a long shot and find this weird it is possible that the firmware got trashed by a virus.

CNET Forums