Samsung forum

Question

Samsung Series 7 Chronos

I have had my Series 7 for just over a year but am finding loading videos a nightmare. YouTube videos take an age to load and in HD i can basically forget about it!

Anyone got any advice or having the same issues?

Discussion is locked
You are posting a reply to: Samsung Series 7 Chronos
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Samsung Series 7 Chronos
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
Re: video's

In reply to: Samsung Series 7 Chronos

That's interesting: a one-minute video that takes 5 minutes to play (assuming you mean 'play' when you say 'load').

This could be caused by a slow Internet-connection. So find a friend with a 100 mbps glass fiber connection and try again. Any ADSL or cable connection of at least 20 mbps should be fine for hd also.

What does the usual internet speed test say with you?

Kees

Collapse -
Internet speeds

In reply to: Re: video's

Well, i am living in China and my internet is a tad rubbish. Saying that, videos load/play/buffer quicker on my girlfriends much older laptop.

With my VPN on, the download speed is: 3.88 Mbps and Upload speed is: 3.94 Mbps
With my VPN off, the downlaod speed is: 4.91 Mbps and Upload speed is: 4.91 Mbps

I used the laptop is the UK (where I bought it) and i still struggled with video speeds and quality.

I think my drivers are up to date

Surely it can't be solely the internet?

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

SMART HOME

This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.