Samsung forum


Samsung SCH-S380C Wont notify me of messages

by TEQueens / January 1, 2013 8:04 AM PST

I just got this phone yesterday and it already is giving me problems. It doesnt notify me when I recieve a text message the little mail icon pops up by the battery but it doesnt ring or the view now or later thing doesnt pop up.
Theres no settings that you can go into and just click check on to get notifications. I went through everything.
I need help.
its a Samsung SCH-S380C
and im using a straight talk plan if that helps.
Please help me

Discussion is locked
You are posting a reply to: Samsung SCH-S380C Wont notify me of messages
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Samsung SCH-S380C Wont notify me of messages
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Message Alert Settings
by harleymonk / February 23, 2013 5:33 AM PST

Actually there is a message alert setting with a number of options.

From the main screen go to MESSAGES> click OK and scroll down to number 7: MSG SETTINGS> press OK and select number 1: GENERAL> click OK and scroll down to number 6: MESSAGE ALERTS> click OK and select the option you wish (once, every 2 minutes, every 15 minutes, off). If set to OFF you will get the message icon on the home page but no alert.

From the SETTINGS menu, you can select what ringtone you wish for message alerts.


Collapse -
Message alert settings
by pjkbd / April 8, 2013 6:52 AM PDT
In reply to: Message Alert Settings

Tried the above. Still does not work. No notification accept the mail icon. Any other ideas?

Collapse -
Are you TEQueens?
by R. Proffitt Forum moderator / April 8, 2013 7:09 AM PDT
In reply to: Message alert settings

If not, please start a new discussion so we are clear about who has the issue with what thing.

Collapse -
What difference does it make?
by aim_bame / May 6, 2013 2:21 PM PDT
In reply to: Are you TEQueens?

I found this thread from searching about the exact same problem I had for the same phone, maybe pjkbd did as well. I don't see any reason why we would have to "be clear about who has the issue" It honestly doesn't matter, why not just provide relevant information to the problem instead?

Collapse -
It matters.
by R. Proffitt Forum moderator / May 7, 2013 1:36 AM PDT

Please start a new discussion with the details. I know of an issue on Android and jumping into some old discussion can result in a less than fruitful discussion.

I have some ideas but please start a new post with the details of make/model/firmware rev and problem to get the best help.

Collapse -
It doesn't.
by aim_bame / May 7, 2013 5:19 AM PDT
In reply to: It matters.

The make and model are exactly the same as the original poster's phone. That's why I'm here. If someone is looking for information about a different phone in a thread for the Samsung SCH-S380C and they get some incorrect information then that is their own stupidity.

Also, I don't think I would really trust anything you said now anyways since you seemed to miss the fact that this particular model of phone doesn't run android at all. Your knowledge is useless to me, thanks for nothing.

Collapse -
Thanks for clearing that up.
by R. Proffitt Forum moderator / May 7, 2013 5:29 AM PDT
In reply to: It doesn't.

Folk have jumped into other discussions so my advice is to always give the details with simple statements such as "I have this phone and ..."

The ambassador is quite good here so why not try a new post and see if they reply?

Collapse -
Samsung SCH-S380-C
by coloradodon / September 24, 2014 9:37 AM PDT
In reply to: Message Alert Settings

I have had two of these same phones, as I ran over the first one with a Kenworth, OOPS. Neither of them would notify me of a message. I tried your advice on going through Messages, Number 7, Number 1, Number 6, and tried all of the settings, from off to every 2 minutes. Still no notifications, any help would be appreciated.


Collapse -
We have this phone on TracFone.
by R. Proffitt Forum moderator / April 8, 2013 7:08 AM PDT

Never found it to fail like this. Given the 20 bucks we paid for it, I doubt you can do anything but replace it.

Collapse -
by batpuma / May 26, 2013 2:40 AM PDT

I have the same phone and the same problem. Simply because this phone is stupid and is not even capable of alerting people they have a text message

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Want to see the future of car technology?

Brian Cooley found it for you at CES 2017 in Las Vegas and the North American International Auto Show in Detroit.