BayMjs,

I would recommend, if you haven't already, to edit the name of the input of the DVI port from "----" to "PC". That will enable the audio port and allow the sound to come through.

--HDTech