Thank you for being a valued part of the CNET community. As of December 1, 2020, the forums are in read-only format. In early 2021, CNET Forums will no longer be available. We are grateful for the participation and advice you have provided to one another over the years.

Thanks,

CNET Support

Alert

Samsung LED TV corrupts PVR (timeshift) connected USB HDD

Jun 19, 2012 2:11AM PDT

Hi gents, hi geeks, hi experts,

I don't want to discuss here about external USB HDD connected to read your DivX or MKV or Xvid files!
I don't want to discuss here about problems of USB sticks or USB keys of X or Y GB containing your files!
I don't want to discuss about external USB HDD for which the TV did not measure a suitable transfer speed (change the disc!)

==> I actually want to discuss here about the LED TV of series D6000, D6500, D7000 and D8000 not recognizing the USB external drive assigned to PVR and so timeshifting and TV recordings features, after a while (after a couple of weeks).
==> The EXACT problem description is that the TV does not recognize your PVR dedicated external USB HDD anymore after a while (a couple of weeks of utilization).

==> I experienced the issue with my EU46D6510 for several times now, with an external USB WD of 40 GB and another one of 60 GB, non powered but with external power capability (there is a DC plug on the HDD box). I now connected it with a universal AD/DC transfo, set on 5V 200 mA. I don't know yet if the HDD will work for a longer time (2012/06/19)...
==> These 2 WD discs were successfully checked by the TV for speed transfers.

==> There is absolutely no solution known and found on the Internet at the month of June 2012!
Neither solution found on Tome's Hardware or SamyGo expert forums for Samsung LED TVs and firmwares, neither solution given by any Samsung support center or forum (inculding this one Wink.

==> Powering the TV on and off and on etc. plus changing the USB port used behind the TV does not change anything to the issue.
==> We know that this bug affects Samsung LED TV of series D6000, D6500, D7000 and D8000 (according with your posts)
==> We know the USB HDD specifications given by the manual: 5400 rpm minimum.
==> We don't know if externally powered USB HDD change that issue or not?
==> We don't know if big sizes external USB HDD generate that issue or not (1 TB, 1.5 TB, 2TB, 3TB)?
==> We don't know if the "pre-formatting" file system (under Windows for instance, FAT or FAT32 or NTFS) is of any importance? (because you know that your TV is formatting it on another file system or you may not know :-P) (see the technical stuffs below)

Now some technical things... ;-P

*** The external USB HDD is formatted by your Samsung LED TV in XFS file system.
*** XFS file system is a Linux compatible file system, readable on Ubuntu. It seems also being a file system developped by Sillicon Graphics for a good use of video streamings.
*** I don't know if it does a quick formatting or a complete formatting of the HDD, because this does actually takes a couple of minutes only on my 40 GB WD. So discussing about Windows "pre-formatting" in NTFS or FAT32 or FAT format seems to me out of topic. I don't know if it is of any importance for the XFS formatting done by the TV.
*** You can boot an Ubuntu or PCLinuxOS live CD on your Windows machine in order to access to your TV formatted USB HDD.
*** You cannot read the recorded video files as they are DRM protected by Samsung (an un-understandable choice for legal public TV programs but anyway...). There are about 5 file extentions recorded by the TV for one recorded program and the .SRF file contains the DRM protected video. SamyGo offers tools to un-DRM your Samsung LED TV PVR.

>>> And the most important points are:
*** When my 2 WD external USB HDD of 40 and 60 GB were unrecognized, because this is it!!!, they were also unrecognized under Linux Ubuntu or PCLinuxOS sessions.
*** When the TV newly formats the USB HDD, these HDD were correctly recognized and mounted under Linux Ubuntu session.
*** After the USB HDD is unrecognized by the TV and also by the Linux system, a formatting under Windows makes the HDD discoverable again by the LED TV, that will again offers you to prepare the disc for timeshifting and recording (so formatting it in XFS file system).
*** I tried Ubuntu tool for XFS discs: xfs_repair (also xfs_check), but the command returned wrong magic numbers and also a wrong magic number for the second parsing, and that second parsing could not recognize the disc. I don't know after that check if the TV will recognize my WD again, because I am now testing with the second one permanently powered (the HDD is under power even when the TV is in standby).

>>> Issues may possibly come from:
*** The size of the HDD too small for timeshift + records. But you used 1 or 2 TB discs as well. But Samsung guy said the opposite when writing that you maybe use too big recent HDDs! And I maybe use too small ones?! (40 and 60 GB)...
*** I don't know if mixing timeshift and records is the origin of the problem on the disc, but we do not have the choice I think.
*** I don't know if after many hours of timeshifting the TV erases the XFS HDD file system information itself?
*** I don't know if shuting down the TV at the wrong moment may definitely corrupt the XFS file system on USB disc?
*** I don't know if plugging a USB key for seeing another video file may make the TV corrupting the plugged PVR USB HDD.
*** I don't know if at a certain moment a power disturbance is created on the TV USB ports? Particularly when I plugged or unplugged a USB Key or another USB HDD for reading video files.


In conclusion:
You see here how complex is that very bad issue, maybe a very bad bug in Samsung PVR code.
This is a shame that Samsung does not respond and did not implement a firmware upgrade for the TV until now.
You are very welcome to feed that thread if you can find any more detail, any possible fix, any workaround...

Thanks to all and wish you good luck with that problem (some people may have abandoned at that point after having read my post, I am sorry for them Wink. Yes it is a very complex problem, for which I have reach my tech limits.
Teknasia

Discussion is locked

- Collapse -
Ouch. Sorry but my bet is the reply will be.
Jun 19, 2012 3:49AM PDT

That this forum is USA only when it comes to replies from Samsung. And since no USA models do this recording I don't have much to add. But then again part of my work involves the code in DVRs (not Samsung) so I can share there are BIG ISSUES with such things.

Especially if the users pull the drive and attach them to PCs (and no, I don't care which OS.)

As this is not a US product I fear you won't see much more than to contact the Samsung office in your country.

WITH THAT OUT OF THE WAY....

For a consumer product you should never be asking the consumers to hook up to any PC. The HDD should be blanked and then used with the machines. As with all things DRM all bets are off as to use with a PC and if you tell them you are plugging it into a PC and looking at files they might write you off.

Sorry but what I know is not about this product but some other DVR but "I hear you."
Bob

- Collapse -
VFS - Samsung LED TV corrupts PVR connected USB HDD
Jul 14, 2012 4:18PM PDT

Many thanks for the posts!

It helped me solve my problem as the TV had corrupted my USB HDD XFS file system.

Here's how I did it:

- Boot Ubuntu (I used 64 bit, 12.04 LTS)
- Connected USB HDD: Ubuntu mentions it cannot mount my disk due to errors
- Switch to a Terminal window
- Launch "sudo xtf_repair -L /dev/sdb1" (adapt name of device, use dmesg to find out infos)

WARNING: this command zeroes the XFS log file and so there are risks to loose data.

(I first tried xtf_check and manual mount - both told me there were errors with the log file and thus xtf_repair -L was the only option)

I could then mount the disk in Ubuntu and reconnect the disk to my Samsung TV. It works and all recordings are back!

This might not work in all situations. Good luck!

- Collapse -
FIX: Samsung LED TV corrupts PVR connected USB HDD
Aug 6, 2012 8:32PM PDT
This fix actually works, but there is a slight typo in the instructions.
This is what I did:

- created a bootable USB stick and booted to Ubuntu 12.04 from the stick (instead of Windows)
- connected the corrupted USB HDD to a free USB port after Ubuntu had booted
- Ubuntu says something like "Cannot mount the drive I/O error..."
- open terminal
- typed "sudo xfs_repair -L /dev/sdc1"
* not xtf_repair as in original instructions
* Ubuntu puts USB storages in /dev/sdcX, where sdc was bootable USB stick and sdc1 the connected HDD.
- after all is done, I removed and connected USB HDD back to TV and voila: device connected and all recordings were still in place - even the latest that probably caused the corruption

Now, it is a totally different question should I have to go through this kind of hassle with 2.000€ TV. My decision is to take the TV back to dealer, as PVR usage is my primary way of watching TV.

Also, there has been suggestions that this procedure might empty the lookup table and thus delete all content, but as you cannot use the HDD otherwise, no harm done I guess.
- Collapse -
Thanks for this. If anyone wants to know what xsf_repair is
Aug 7, 2012 12:22AM PDT
- Collapse -
Thanks both of you for your test and steps
Aug 7, 2012 5:12PM PDT

Thanks for your try and for the steps list RKeller17
Thanks for your try also and for the clarified steps list Bersercci

- Collapse -
Thanks guys
Aug 9, 2012 8:55PM PDT

Have a D7000 since June 2011 and this problem has driven me crazy. So glad to have a solution for it, although it is ridiculous of course that it should be so. Keep my fingers crossed that the fix is permanent, but know that it will probably happen again. Samsung guys extremely unhelpful, but still think TV great, despite problem

- Collapse -
no problems found in xfs_repair
Nov 28, 2012 3:39AM PST

I had the same problem described in the main post before (solved by reformatting), but now I have a slightly different problem:
- My harddisk is detected by the tv
- I can open it, but the file list never get past the loading stage (the circle appears, but no files)
- The TV locks up and automatically reboots
- After this I can reapeat the process with the same result

I tried mounting the disk in linux and that worked without any problems. That is, I could see al the files and I got no error messages. After that I still ran xfs_check and that compleed with success as well.

Now I reconnected te disk to the TV and I still have the problem. The only ting I now know for sure is tat the disk itself is not corrupt. Any suggestions?

- Collapse -
From what I can tell.
Nov 28, 2012 3:41AM PST

You have to blank the drive and start over when it fails like this. This is extremely unpopular.
Bob

- Collapse -
fix
Dec 5, 2014 7:47AM PST

Had the same problem. Drive wasn't accessible, files were present when opened in linux, and in my case, record function still worked. This thread pointed me into the right direction, and I found fairly simple solution for retaining the data:


1. Open the drive in ubuntu or other linux installation (mounting it in windows, with something like fxs proxy, may also work). Next copy all the data in CONTENTS folder onto another disk.
2. Connect disk back to tv, let it format and make a short recording so config files will be created.
3. Open the drive in linux again and move copied CONTENTS folder back onto the other disk.
4. Thats all. All the recordings were again usable. I did get occasional drm error on some files, but simple tv turn off/on fixed that.

Problem in this case is probably a very minor error in one of the config files that samsung tv uses, so the fix may be even easier by only replacing defected one with old backup, or even deleting it. Something to keep in mind in the case it happens again.

- Collapse -
Check disk partitions labels prior to xfs_repair
Mar 14, 2016 2:47PM PDT

Thanks a lot for your post!!. They helped me to solve the same problem with a D8000 Samnsung Tv. Nevertheless, let me point something that hapened to me that could be useful for people experimenting the same problem.

I use a 500 Gb disk with two partitions, and the TV experimented the same problem with both many times. As most of the Tv shows recorded could be watched online, I just reformated the partition each time... but, finally, this was bothering me. So when it hapened again this afeternoon I tried to find a solution.

As said, my hard drive has two partitions with different sizes. The small one had this problem in the past but, it is working fine since it was filled up and has no new recordings. The big one failed (again) this afternoon. When I tried to use the xfs_repatir following the instructions here it didn't worked. So i did a fdisk o the drive and it showed that both partitions were labeled as NTFS (id 7). With the "t" comand I changed the partitions label to "linux" (id 83) and then xfs_repair worked perfectly.

I guess that this maybe hapened because the drive was partitioned in windows, and then the partitions formated to XFS by the TV. The thing is that even the partition working perfectly had a NTFS label, although the TV recognized it as XFS.

- Collapse -
A Possible Built in Fix
Oct 30, 2016 10:35AM PDT

After a weekend of trying the various Linux solutions I gave up and reconnected the drive to the television. Then I went to Media Play, where I could at least see the device, then I selected Tools -> Device Management -> Checking Device and upon selecting the device I was presented with a screen that allowed the errors on the device to be analysed and recovered. The drive was working again within 10 minutes. Happy

The television is a six years old UE46 C7000 so might be even older than the ones in question above and the drive was a 4TB usb hdd.

I hope that this post helps save someone hours of bother.