Samsung Blu-Ray cannot stream Netflix

Nov 21, 2011 6:03AM PST

I have a Samsung BD-D5700 Blu-Ray player. I've been using it for Netflix for 4-5 months now without issues, but recently it gives me a "we cannot play the title right now" error on everything I try to play. I called Netflix and the guy kept telling me that it was a network connection issue on my end. I've troubleshooted my connection and cannot find any problems. Restarted the modem & router, tried every port, wired and wifi, etc. The Blu-Ray player reaches the internet fine and can stream Pandora with no problems. It's only Netflix that doesn't work.

Discussion is locked

Reply to: Samsung Blu-Ray cannot stream Netflix
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Samsung Blu-Ray cannot stream Netflix
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
Netflix writes the app, runs the servers so
Nov 21, 2011 6:06AM PST

What this means is you call everyone for help. Including netflix.

- Collapse -
I have the same problem with a BD-5300
May 26, 2012 6:19AM PDT

I contacted Samsung Support - below is our "conversation":

Please wait for a Samsung Agent to respond.

You are now chatting with 'Simon'. There will be a brief survey at the end of our chat to share feedback on my performance today.

Your Issue ID for this chat is LTK56401095747X

Simon: Hi, thanks for reaching out to Samsung tech support. How can I help you today?
Visitor: My BD-5300-ZA stopped playing netflix videos. From what I've gathered I need to downgrade the firmware back to the original version, but I can't find it anywhere.
Visitor: The internet is working, all the apps are working (even netflix) but when it attempts to play it suggests i try back later.
Visitor: Can you help me find old firmware versions?
Simon: Please allow me to go through the inquiry.
Simon: I understand that you are having issue with the Netflix.. Is that correct?
Visitor: Yes.
Visitor: It was working fine until the last firmware update.
Simon: I'm sorry to hear that. Let's try to fix the issue.
Simon: Please follow the instructions below to reset the smart hub to isolate the issue.
Simon: Press the Smart hub on the remote.
Simon: Press the blue button the remote to open settings menu.
Simon: Use the arrow keys to select the reset and press reset.
Simon: You may asked for password press 0000.
Simon: The reset of smart hub will complete.
Visitor: Reset in progress
Visitor: Done.
Simon: Please check whether the issue persists.
Visitor: Checking
Visitor: Activating Netflix
Visitor: Loading
Visitor: "We're having trouble playing this title right now. Please try back later or pick a different title."
Visitor: I've tried several titles.
Visitor: Same message
Simon: Thanks for the information.
Simon: Please follow the below instructions to reset the player to isolate the issue:
Simon: With no disc in the player press and hold the Stop button on the front of your Blu-ray player for about 8 seconds or until the front display reads 'SETUP'. 'Resetting all settings to default values...' is displayed on your TV screen as the Blu-ray player powers off and resets.
Visitor: I will try that again as well. Hold on.
Simon: Please go ahead.
Visitor: Setting up internet on unit
Visitor: Internet is connected successfully.
Visitor: Initial Setup Complete
Visitor: Should I retry Netflix?
Simon: Yes, please check and let me know the status.
Visitor: Smart Hub is downloading.
Visitor: Installing
Simon: Please go ahead.
Visitor: Waiting on the unit
Visitor: Starting...
Simon: Thanks for the information.
Visitor: In the smart hub.
Simon: Please check whether the issue persists.
Visitor: Connecting to Netflix... "Starting"
Simon: Please go ahead.
Visitor: Waiting on the unit...
Simon: Thanks for the information.
Visitor: The smart hub is not functioning properly. The icons for the apps are not present. The names are all there, but the pictures for each icon are missing.
Visitor: I'll try rebooting the unit
Simon: Okay, please go ahead.
Visitor: "Starting" the smart hub.
Visitor: "Smart hub needs to update"
Visitor: Updating
Visitor: 1/11
Visitor: 2/11
Visitor: 3/11
Visitor: 4/11
Visitor: 5/11
Visitor: which is netflix
Visitor: 6/22
Visitor: oops 6/11
Visitor: 7/11
Visitor: 8/11
Visitor: 9/11
Visitor: 10/11
Visitor: 11/11
Visitor: Updated
Visitor: Starting Netflix
Visitor: "Loading" video
Visitor: Same message
Visitor: "We're having trouble playing this title right now..."
Simon: May I know whether other apps are working fine?
Visitor: They were before we started. let me check again
Simon: Please go ahead.
Visitor: Trying Pandora...
Visitor: I'll have to reactivate. Just a min.
Simon: Please go ahead.
Visitor: Loading.
Visitor: Playing music Happy
Visitor: Simply Irresistible - Robert Palmer
Simon: Thanks for the information.
Simon: Please disable the firewall on the router to isolate the issue.
Visitor: From what I've read online the problem is with this firmware upgrade and has something to do with how the unit communicates a secret code to Netflix.
Simon: As the firewall on the router will block the content that allow by the Blu-ray player so please disable the firewall to isolate the issue.
Visitor: The firewall is not active.
Simon: There are no reported issues with the firmware.
Visitor: There are on the discussion boards on the web
Simon: I understand, please contact the Netflix support as the other apps are working fine. Please try to contact them to isolate the issue.
Visitor: It is NOT a netflix issue.
Visitor: I would like the old version of the firmware please.
Simon: Samsung players and TV's does not have a back up feature to get the old firmware version.
Visitor: I'd like to report a problem with the firmware.
Simon: May I know the firmware version of the player?
Simon: With the disc tray open, press and hold the INFO button on the remote control. The System Information appears on the screen.
Simon: Please follow the above steps and let me know the s/w version of the player.
Visitor: 2012/03/22_001025
Simon: Would you mind holding a few minutes while I gather the required information for your request?
Simon: Thanks for holding.
Simon: I see that your player is updated with the new firmware version.
Visitor: That is correct, unfortunately.
Simon: Please try to un-plug all the network devices such as TV or computer, modem and router. Please try to connect only the player and check if the issue persists.
Visitor: If I unplug the modem and router the device won't have internet and then no apps will work.
Visitor: I will also lose this chat connection
Visitor: This is the only player in the house with a Netflix problem.
Simon: I understand, it means that to connect the modem, router with only player without any other sharing devices and check if the issue persists. You may disconnect the chat, please get back to us with the ticket ID: LTK56401095747X. We will go further steps to isolate the issue.
Visitor: Apparently, from reading extensively about my challenge before contacting chat, there are plenty of other Samsung customers who have experienced the same problem.
Visitor: I will, however I am 100% sure this is NOT a network problem.
Visitor: What are your chat hours? How long will someone be available today to respond on that ticket number?
Simon: We are available 24/7. We can process the chat further.
Visitor: What are the further steps?
Visitor: It seems to me that I've isolated the issue pretty far down the possibilities list. The problem presented immediately after firmware update.
Visitor: What are the further steps?
Simon: If the issue persists, I will forward your concern to the Samsung department.
Visitor: That is the only remaining step?
Simon: Yes, it is the only step should be done. As we have done will all the steps except that I provided above.
Visitor: I will go ahead and follow the instructions. Just to be clear, once I've done that - if the issue isn't resolved the only step left is to "forward your concern to the Samsung department"?
Visitor: As a customer what will I be able to do? I have a non-functioning unit.
Simon: Yes, you are right. Once it is done, please get back to us, I will forward your concern.
Simon: Please get back to us if the issue persists with the ticket ID: LTK56401095747X, we are available 24/7. We are here to assist you.

Obviously no assistance is actually provided. The next person to call, email or chat can now unequivocally respond to the lie "this is the first time we've received notice of this issue".

- Collapse -
Just so you know.
May 26, 2012 7:05AM PDT

Netflix and Samsung servers are not 100% reliable. It appears that the companies that are selling this are trying to avoid the longer conversation about this issue.

Sorry but until the makers get beat up enough I fear they will not share when there is a server or other issue.

- Collapse -
worked for Netflix
May 26, 2012 11:23PM PDT

We had gotten a ton of frustrated calls about Samsung players. Most people would be yelling at us on phone, but I would have them try playing Netflix on another player, and 99% of the time it would work unless the connection itself was messed up. I know it is frustrating to get ping-ponged back ad forth, but most other devices we can get working with deactivation and reactivation.... Samsungs always seem hard to get working, and we have to refer back so Samsung quite a bit because there is nothing we can do over the phone with the customer to fix it. I wouldn't place much of the blame at Netflix's feet, though. I witnessed idiotic decisions of their's internally, but they do tend to work well on most devices. The common call in issues are usually actually the users net, or the app got corrupted and needs reinstalled, etc.... not things done by Netflix. The main Netflix issues are things like doing away with vacation holds and deferring cancellations, billing difficulties on prepaids, etc.

- Collapse -
worked for netflix
Jan 31, 2017 1:16PM PST

So is it an issue specifically with samsung players, or is it netflix?

- Collapse -
Netflix freezes my system completely.
Jan 31, 2017 1:14PM PST

I have the HT-J5500W model I just sent in, it keeps freezing during Netflix playback. I have to unplug the player to fix it and then plug it back in. It freezes the entire unit up when netflix quits working. I got a email back saying the unit was fixed, that the issue was it wasn't connecting to the network, and thats not the issue with my system so i'm probably getting it back even with a new board in it the same issue still exists.

PS even though its under warranty, if you need to send it in and they send a label, UPS charges you $15 to go to your home and pick it up. So samsung pays shipping and you pay UPS to get it.

- Collapse -
Same issue on my BD-D5700
Jun 2, 2012 3:14AM PDT

Up untill yeaterday I never had a problem. S/W version 2012/03/22_0010025.

Netflix is the only thing having the issue. It will load all the available titles but will not play any of them.

Reseted everything, my Blu-Ray player (unplugged it), my network, did a hard reset of the player. Nothing fixed the problem.

Still get "We're having trouble playing this title right now"

Any ideas?

- Collapse -
Samsung HT e5500 and netflix connection problem
Sep 6, 2012 10:12AM PDT

This has been really frustrating, because I was really liking my Samsung home theater system until a few weeks ago. Suddenly, Netflix would not stream video. I could open the app, click on a movie, the movie would open, I'd click "play" and then the message "we cannot play this title right now, please choose another or try again later". Unfortunately, I tried a ton of different titles and I always got the same message.
Now the crazy part was, it was playing without a hitch for a month and a half or so and I had done NOTHING to the set up to make it suddenly stop working. So, I jumped on the forums and started reading page after page of trouble with all different models of Samsung players, and the frustrations that people experienced with customer service.
I decided to just try a few of the things other consumers suggested- first of all, I went into SETTINGS and changed the time zone to the appropriate one. For some people, this was all they needed to do to fix the problem. Not me. Next, I tried plugging and unplugging the BD player and the router, the longest I left if off was around 2 hours (as suggested in one of the forums). No go. I did this a bunch of times, and always went back to check that my time zone setting hadn't changed. I was fairly ready to give up- but I saw a suggestion to deactivate and reactivate the netflix app. The way to do this on the remote in the netflix app is press up up down down left right left right up up up up. Bingo, the window opens and you have the option to deactivate, which I did. Then I shut down the BD player and unplugged it, and unplugged the router for about 10 minutes. After that, I plugged everything in, logged into netflix, and pressed a title. I have NO IDEA WHY, but netflix seems to be in working order once again.

- Collapse -
RE: opelnyc
Sep 8, 2012 1:32PM PDT

Deactivating and reactivating the Netflix app worked for me! Thanks so much!!! Been messing around with this problem for days, and this was the only thing that worked.

- Collapse -
Sep 11, 2012 3:22PM PDT

I would have been up all night trying to figure this out! Thank goodness I didn't call some tech support desk at Samsung. Your suggestion with the arrow buttons up down left right,etc steps worked perfectly. Saved me so much time. When I first read it, it sounded crazy, but lo & behold, it worked fine. I didn't power off or disconnect anything, I just deactivated the account and reactivated with Netflix log in credentials, went back to my queue & selected my tv show & it started playing right away. I joined this forum just so I could say thank you.

- Collapse -
Sep 17, 2012 12:03PM PDT

How did you learn the thing about the arrow keys? OMG the "cannot play this title" thing has been driving me nuts! Though it has been keeping my son from watching that horrid "Johnny Test" show, so the breakage had a positive side effect... But tonight he wanted to watch "Blue Planet," and that's when I decided to get serious about finding a solution. Deactivating and reactivating fixed everything. I'm going to have to save that little incantation somewhere. Thank you!

- Collapse -
looks good
Nov 16, 2012 1:32AM PST

I have this player. When I purchased in Feb, 2012, it played Netflix great. Even nice and clear over wifi. The main reason we bought it was to use netflix and ditch cable. After a few months of flawless operation, I got the dreaded "..can't play now..try later". So I did the rounds, re-install netflix, update firmware, call netflix, call samsung..everything except this little number.
I'm going to try this when I get home since several claimed victory. I hope it works. I'll report back. Its been since April or May that this player has sat and done just about nothing. Maybe occasional dvd. ...

- Collapse -
Arrow Keys Work
Nov 16, 2012 11:21AM PST

I have a Model #: BD-D5700/ZA wireless blue ray player. Feb 2012. stopped working a few months later. ...

I read it here first. I tried the arrow sequence above. At first it didn't work, I did it too fast. (this aint ps3 here),
I did slower while the netflix app was loaded. I got an info screen with my Name, some versions info, and highlighted box saying Deactivate. I selected, confirmed and back to player menu. Hit netflix button, loaded, and did new device activation. Tried playing something and ****, it works!! It hasn't worked since april or may. And i've tried and tried. Called everyone and internet searched. Some how missed this thread earlier. Maybe my 4 yr old wouldn't have cracked my vizio screen....ughhh. But at least netflix works again. Hope it lasts.
I thought about the deactivation a while back on my own. In netflix online, there used to me a way to see devices and remove/delete/deactivate. Netflix stopped using it they told me. But at least its hidden in the player.

The bottom line here, is this "cannot play title now, try again later" is obviously a bug in samsung product. Its not our internet connections, its not our weak wireless, its not even netflix, well partly. Its a bug between the communication between samsung and netflix's server. Its how the software is written in the player/tv.
There are less reports for errors from other mfr. Sony is rated well for netflix, and never fails. How come my iphone, windows vista, osx 10.4.11 all play netflix without ever a single problem. Everything plays close to HD or HD over wireless. even when router is burried on the floor under clothes. Netflix is tight, and works really well. It is soo not them.

And yes, the damn thread is over 361 days old, but is still on top of google search. Keep this **** Alive!

- Collapse -
The fix is in
Nov 30, 2015 6:03AM PST

My friend was having a similar but different problem. For her Netflix would play for 2 minutes and then lock up.

While the exact arrowkeys did not get us to the needed setup screen, the key to fixing this was two fold:
1. Change time zone on the DVD player to the correct time zone.
2. By whatever means you can get to your Netflix settings and log out.
3. Unplug the DVD. Plug back in and log in to Netflix with your credentials. If you are not being asked for your email and password you were never logged out.

She was so happy that this fixed it so she could finish her binge watching of Friday Night Lights.

- Collapse -
Worked for my LG TV too!
Feb 2, 2013 11:59AM PST

Didn't think it would go anywhere but I tried your Nintendo trick just for the heck of it and it worked! After a power outage my Netflix would get as far as just about to play the video when it would give that error. Even on my LG TV it worked. At first I didn't think it was working cause the arrows would move you around in the interface, but just ignore that and try it a few times. THANKS!

- Collapse -
Feb 24, 2013 1:46PM PST

Where exactly do you do the trick with the arrows? I keep trying that, but all it does is move me through the app

- Collapse -
Yes it moves through the app.
Feb 24, 2013 1:48PM PST

The maneuver is called the KONAMI code because of it's origins.

Your old gamer knows why it's called that but you have folk today that ask why. My question is why is this done this way?

Silly. Come on, it's time to stop this nonsense and put it into a menu.

- Collapse -
didnt work.for me
Mar 17, 2013 6:46AM PDT

I did.everything followed the instructions and the deactivation work.fine but when I logged and tried a movie still got same error message

- Collapse -
Sep 10, 2013 9:35AM PDT

Can't believe it myself, but it worked for me also.

- Collapse -
Fixed! :)
Apr 14, 2014 1:45AM PDT

2014 and still happens, after upgrading firmware on a BD-F5100 the "deactivate" trick worked fine, thanks! Trying to figure it out where to keep the "up up down down left right left right up up up up" sequence Happy

- Collapse -
I came on with the same problem on BD-5300
Sep 20, 2015 10:24AM PDT

Seeing all the comments going back three years...I thought a quick solution should have been part of the Samsung update by now. Your remedy did the trick. I had tried several of the aforementioned options and believe shutting down my router for 15 minutes made the difference, along with reset of Netflix App.

- Collapse -
Empty Black Screen of Death.
Nov 18, 2015 8:16PM PST

My problem on mine (HT-H4500) is that when I try to open the Netflix app, nothing happens. The player freezes and has to be turned off and back on again. I've tried the hard resets, the konami code, nothing has worked and so far Samsung has had nothing that helps. Anyone have any ideas for me?

- Collapse -
Only to call it in.
Nov 19, 2015 7:14AM PST

There are priors where Samsung does remote resets and some calls to change a board in the TV.

- Collapse -
Blank feozen Screen
Sep 3, 2016 4:55AM PDT

My tv screen also go blank on pressing the Netflix app. Was working perfectly but now for 3weeks i cant use it. On same network, i can play Netflix on phone and tablet. Anybody who got a solution for this?
Note: I have tried the up up down down procedure on the blank screen with no success!

- Collapse -
Samsung Blu Ray Player Netflix Disconnect Reconnect
Dec 3, 2015 11:55PM PST

I just had a similar issue. I have an older Samsung Blu Ray player and I just finally got the instant que to pick up my list from Netflix. Then tonight I turned it on and went to the Netflix app. I watched an episode of LOST, which played completely through. Then I tried to watch the rest of the movie Snowpiercer and for some reason it kept pausing after like two minutes. I figured that I had just lost my wi fi connection, because the internet provider that I have called COX, gave me a modem which frequently loses the wi fi connection for some reason (I'll have to call customer service some day, but we all know what fun that is.) So I went onto my computer and repaired my internet connection by clicking on the computer icon/wi fi icon (I have a super old computer.) I tried to play Snowpiercer again, but it kept pausing. So I figured maybe I'll do what I did for the Blu Ray player to originally recognize my list from the Netflix website. So, I didn't have to do the up, up, right right thing (which is funny that it is similar to the code for Contra for the old NES to get 30 lives) anyway...I just pressed the info options button on my universal remote (my friend who gave me the player lost the old one, had to buy a new one, take that back, and buy another one at Best Buy) anyway, sorry I'm kind of rambling; so I pressed the info options button and it took me to a screen where deactivating the player was an option. I selected that and it gave me a code to punch into the blank entry when I logged on to And, now Snowpiercer works without pausing. Hopefully I don't have to constantly do this. If I do, it is a small price to pay to watch movies through my player and t.v. as watching them on my old laptop makes them choppy and buffering as heck. But I think the real problem might lie in my modem; that every time I have to repair the internet connection I might have to disconnect and reconnect my Blu Ray device. IDK. I can't remember whether I had to fix my internet connection before this happened with the player as it happens constantly. Maybe this helped someone, but your post helped me remember what I did to get the player up and running in the first place. Thanks.

- Collapse -
opelnyc netflix reset
Jan 31, 2017 1:18PM PST

I tried the arrow method and it doesn't work.

- Collapse -
Netflix Does NOT Write the App
Jul 14, 2012 4:13AM PDT

In conversations with a Netflix supervisor who is in the wrong career field stated that "Netflix is a streamer of movies" and denied any involvement by Netflix in creating the apps that are on these Blu-Ray players. Netflix recommended I reach out to Samsung.

- Collapse -
It's a long discussion so let's start a new one.
Jul 14, 2012 5:13AM PDT

There is plenty of reasons for it not to work and since "once the app launches" Samsung is not taking responsibility if it's not their app, the discussion turns to what consumers expected and how this is a repeat of the Windows ecosystem. That is, you don't call Dell when your Netflix app fails. Well you could try that.

- Collapse -
Samsung DVD Players Cannot Stream Netflix
Sep 21, 2012 1:02PM PDT

Netflix was streaming perfectly one day, and the next I got the "We cannot play this title at this time," or whatever, error. Netflix still streams perfectly on my two Macs, so it's clearly a breakdown of the Samsung device. I've tried all of the suggestions in this and other forums, but I'm not going to call some help desk in India and get a runaround from someone reading corporate b.s. off their screen.

So, I'm going to buy a Roku box and just use the 5700 to play DVDs and remind myself never to buy anything by Samsung again.

- Collapse -
Me too.
Sep 22, 2012 1:55AM PDT

Just last night my PC coughed up that message. Guess Friday nights can overtax the hamster farms.

CNET Forums

Forum Info