Samsung forum

General discussion

Samsung Blu-Ray BD-p1590 connects to network, not internet?

We just hooked our Samsung BD-P1590 to our 2wire DSL modem via ethernet cable. After plugging in the machine and turning it on, it updated the firmware. I followed the network setup instructions and a connection test says our network is working properly. None of the applications will connect and they all say I am not connected to the internet. My dsl is working fine on our computers (wirelessly via apple airport), I disconnected and reconnected everything and that didn't help. I also made sure the time was set correctly because that was mentioned a lot on the forums. Anything else I can do?

Post a reply
Discussion is locked
You are posting a reply to: Samsung Blu-Ray BD-p1590 connects to network, not internet?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Samsung Blu-Ray BD-p1590 connects to network, not internet?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Samsung Blu-Ray BD-p1590 connects to network, not internet?

In reply to: Samsung Blu-Ray BD-p1590 connects to network, not internet?

tanknsophia,

Try plugging in a thumb-drive. I don't have the exact specs for the BD-P1590, but I believe it is similar to the BD-P1600, which doesn't have onboard memory. The streaming content needs a place to buffer, and a thumb-drive should provide that space.

--HDTech

Collapse -
UGHH

In reply to: Samsung Blu-Ray BD-p1590 connects to network, not internet?

I've had the same identical problem, tried inserting a thumb drive but to no avail. I've spend the entire day trying to troubleshoot this problem. Any other ideas?

Collapse -
Samsung Blu-Ray BD-p1590 connects to network, not internet?

In reply to: UGHH

My brother had the same issue. Spend a couple of hours on the phone with him trying to debug it.

It worked when it set it up and then stopped working after a few weeks. I tracked the problem down to the DHCP info. Apparently, the player forgot/confused the IP address, etc. I had him set the IP info manually, then reset the machine, and then set it back to DHCP. It re-aquired the IP and other info and seems to be working fine now.

Collapse -
Network, not internet?

I you are an AT&T customer...

Before you take everyone else's advice about resetting your router, your modem, your DVD player or your network cables, try this:

Go into network settings and change the DNS setting from Auto to Manual, then change the DNS server from your router's address to 8.8.8.8

If you wait on hold for an hour like I did, that is the advice Samsung network support will give you. It is your internet service provider that is blocking your DVD player's ability to connect to the Internet! Sweet, huh? While you're at it, give your ISP a flaming scathing piece of your mind, because, for what we pay for Internet service, this kind of disservice is a petty crime!

U-Verse had better not disable THIS fix, or it's time for a serious boycott!

Collapse -
network, not internet

In reply to: Network, not internet?

Thank you so much!!! Huge help!! It took me more then a week to work on it.

Collapse -
Awesome information on Blu-ray connection

In reply to: Network, not internet?

You're wonderful. That fix worked perfectly. Thank you. I'm up in running in a matter of minutes.

Collapse -
8.8.8.8 got me connected to my player immediately!

In reply to: Network, not internet?

Thank you so much for spending the time with ATT and posting this information. This fix worked 4/2017. It's hard to deal with either of the 2 oligarchy internet providers I have to choose from. Hard to boycott them when they're the only game in town and have you on a 12 month price lock.

Collapse -
Connects to local network but not Internet

In reply to: Samsung Blu-Ray BD-p1590 connects to network, not internet?

Symptom: network connect wizard shows connection to local network but not to Internet. Provider is AT&T.

DHCP on Auto; assigns valid IP address, etc on local network. OK

DNS on Auto; assigns AT&T gateway (router) as DNS Server. Usually 192.168.1.254 Not OK.

Fix: let DHCP assign IP (on Auto). Change DNS to Manual and enter 8.8.8.8 as DNS. This bypasses AT&T as your DNS provider and replaces it with Google for lookups on this device.

You should now have valid connection to your local network and to Internet for this device. This will not affect anything else on your network.

Why does this work? Beats me. AT&T DNS should work fine but does not. The only explanation I can figure is that AT&T can somehow identify this type of player, sees it as a nuisance (because it WILL be used for high bandwidth streaming), and "loopbacks", ie "blocks" DNS requests from the device.

Think of DNS as the "phone directory" for the Internet. You request www.netflix.com and your DNS service translates the name to the IP address for www.netflix.com allowing your device to connect. It should not matter wether you use AT&T or Google DNS, but it DOES in this situation. Usually your own ISP's DNS will be most efficient for lookups.

At first glance, it seems that the problem with this player is being caused by AT&T intentionally in order to limit bandwidth demands on their network. If so, it would seem to be a dirty trick to play on their customers. I personally use Comcast as my ISP and recommend them.

I have only seen the problem referenced in this discussion with a Samsung BD and AT&T as the ISP. Helping my neighbor connect connect his BD to Netflix originally brought me to this post. If anyone can explain the technical reason for this, I would be interested in knowing. I certainly would not want to impugn AT&T as an ISP without a valid reason.

Good luck, hope this helps.

Collapse -
Charter is doing this as well...

In reply to: Connects to local network but not Internet

I sat on the phone with Samsung for a long time all while doing an online search and came upon this. I put in the 8888 code and it worked! Thank you!! I have Charter internet. What a coincidence that I canceled my cable service but kept my internet and all of a sudden I can't connect to my blu ray?? HA! I think they did this on purpose. So, it's not just ATT doing this.

Collapse -
Same issue

In reply to: Charter is doing this as well...

I have tried to do the same but it isn't working. Any ideas?

Collapse -
I'm having the same problem with Brighthouse/Spectrum

In reply to: Same issue

My BD-P1590 doesn't pass the internet connection test, can't update the filmware, Pandora and YouTube won't open anymore because they say there is no internet connection (direct cable connect), but I can stream Netflix just fine. I've had this player for more than 8 years and it just started doing this (no change in modem, router, etc. I tested two Ethernet cords and no help.) Samsung sent me a filmware update, but it doesn't load (but I can play music/movie CD's just fine. The 8.8.8.8. method didn't work for me. Any ideas?

Collapse -
Maybe time for a new player?

In reply to: I'm having the same problem with Brighthouse/Spectrum

I have the same issue... Tried the same tricks (DNS to 8.8.8.8) to no avail. Captured packets when this happened. It turned out that the way this player determines Internet connectivity is quite interesting. Of course it pings the gateway, and then it queries the IP address for Yahoo.com and then ICQ.com. Next thing you know, it attempts to browse the homepage of yahoo.com and icq.com using HTTP (tcp port 80). I don't know when it started, but nowadays everyone in the server world is migrating to https (tcp port 443), so these websites are redirecting whoever tries to connect to port 80 over to https services of 443. Of course, the p1590 follows the instruction and attempts to establish that new connection to 443, only to find out its TLS encryption method is incompatible with the servers, and then terminates the connection. When it concludes that neither site (yahoo.com and icq.com) can maintain a connection, it declares Internet disconnected. The only way to solve this, is to either disable the mechanism of having to successfully browse a certain webpage, or enable a more modern TLS service, both of which requires building new firmware. If my analysis is correct, then none of the p1590s can connect to Internet today, unless someone installed his own DNS server or DNS proxy (sometimes quite doable on home router) to map yahoo.com or icq.com to his/her own functional webserver where http service is still accepted.
If none of the above makes sense, then you probably only need to know my conclusion: time to invest on a new smart player

Collapse -
Your brilliance is stunning

In reply to: Maybe time for a new player?

I like the way your mind works!
They haven't updated the firmware since 2012. Although what you said is slightly over my head, I get your point. I agree, I'm going to have to live with it until I'm ready to invest in a new player. Many thanks!

Collapse -
Solved!

In reply to: Maybe time for a new player?

Thanks for the info. It helped me get to a solution.
I used wireshark to inspect the traffic from the Samsung, and found that it tried to connect to the following web servers while testing for an Internet connection:

www.worldtimeserver.com
www.worldtime.com
www.icq.com
www.internic.net
www.yahoo.com

As you described, some of these don't exist, and some redirect to https (which also doesn't work, since the TLS code in the samsung is badly out of date).
In my case, since my domain is danara.ca, it also tried www.worldtime.com.danara.ca
which failed in the DNS lookup. Since I control that domain, I created an entry for that hostname and set it to 192.168.1.1 which is the internal address of my router (and serves a login page via http).

I rebooted the samsung, and was able to launch netflix.

This workaround could work for others. If you can set a default domain that can be picked up by your blu-ray player, and have something in your network that is serving http on 192.168.1.1 then go ahead and use my domain (danara.ca). Otherwise, you can use the same technique with another domain and a different IP address. If other people use different IP's to solve it, please share the hostname here so folks without a dns server can apply the same fix. I also sent an e-mail to the owner of worldtime.com and asked if they would please enable the site and serve a blank page via http, so that our devices will work again.

Collapse -
I need help

In reply to: Solved!

Please, do you have a tutorial how to this? I have searched but I don't know how to or even where to create an entry to the hostname you said... And I have found nothing how to do it. I have the same problem, hours and hours trying to find a solution and nothing...

Collapse -
Charter/Spectrum Customer

In reply to: Charter is doing this as well...

I have to say the manual mode for DNS 8.8.8.8 worked for me this afternoon. And I have to say THANK YOU!
I didn't expect it to be that simple after maunally entering ISP & that didn't work. It's truly unfortunate that Samsung doesn't keep up with new firmware on these systems cause they last for several years & let's face it, technology changes rapidly. This is well after the initial posts about this problem, so truly many thanks. Anyone sles out there searching this issue, good luck cause this works!

Collapse -
Awesome information on Blu-ray connection

In reply to: Connects to local network but not Internet

That fix worked perfectly. You're wonderful. So glad that I found this site/source. You got me up and running in a matter of minutes. Also...in more than 3 years after this post. Happy

Collapse -
Update

In reply to: Awesome information on Blu-ray connection

Oops...Not 3 years. Sorry, looked at a different post before this one. Lol

Collapse -
Try another connection

In reply to: Samsung Blu-Ray BD-p1590 connects to network, not internet?

I had the same issue since Aris - The router firmware upgraded and/or Comcast started filtering content or connection from the Blue Ray device. I was nit able to fix the wired (Ethernet) connection, but the BlueRay Samsung should allow you to also connect via Wireless. That seemed to work for now. If there is a fix for the Ethernet connection, since it runs faster, that would be nice.

Hope this helps resolve issue or attest approach it from another way.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

GIVEAWAY

Enter to win* a free holiday tech gift!

CNET's giving five lucky winners the gift of their choice valued up to $250!