General discussion

Samsung BD-P1600 Firmware Update Problem

I was having trouble playing a new Blu-ray disc I picked up so I decided to upgrade the firmware to the latest version 2.08 (I believe previously I had 2.04). It didn't want to update via the internet (complained about a connection problem, despite having no trouble pulling data off Youtube), so I went through the USB update procedure instead.

It verified the new firmware fine, but then it got stuck on the screen that says:
Firmware Update
Now processing...
Please, do not turn off the power.
The power will be off after the update is complete

The front panel says USB-UP

I imagine the unit is probably bricked, right? Is there any point in leaving the unit on until I can talk to a support tech? Is there any chance that enough of the update completed that it can boot far enough to attempt the firmware update again?

Discussion is locked
Follow
Reply to: Samsung BD-P1600 Firmware Update Problem
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Samsung BD-P1600 Firmware Update Problem
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Samsung BD-P1600 Firmware Update Problem

Mask of Destiny,

It's probably not bricked, but the firmware update doesn't appear to have completed successfully.

If you've already unplugged the unit, power it back on to see if it will load. If it does, check the version number.

If not, hold down the FF>> button for about 15 seconds and it should perform a reset. This should load the latest firmware update it has, and start from factory settings. If it didn't complete the update, try updating it again. If it did, you should be all set.

--HDTech

- Collapse -
Worked

Pulling the power worked. Settings were wiped, but otherwise the device was fine. Firmware was still the old version, but I was able to successfully update via the internet.

I actually ended up calling phone support before you got a chance to reply and they gave similar (though less thorough) advice, but I forgot to update this post. Thank you though.

- Collapse -
Worked

Mask of Destiny,

Glad to hear it worked. Happy to help.

--HDTech

CNET Forums

Forum Info