Samsung forum

General discussion

Samsung 52" LCD TV (LNS-5296DX) has sound but no picture

by vanlezer / February 14, 2010 2:09 AM PST

It's Vanlentines Day, of course, my Samsung 52" LCD TV suddenly has no picture but sound is fine. Of course the $3300 I paid is out of warranty. I switched to HDMI2 which is also Samsung Blu-Ray player is still same.

I have the back cover off and verified and replaced one capacitor (1000uF) which looked bad, the others are fine.

Still has sound but no picture. I called Samsung support and they're pretty much useless, just asked me to push the Menu button to see anything comes on then tell me to contact service repair. Don't think I will buy anything Samsung again.

Anyone have another troubleshooting tip besides the capacitor issues?

or any electronics wizzard out there who knows how to troubleshoot the BN44-00150A power supply board? I do have multi-meter in hand.

Sincerely thanks...

Discussion is locked
You are posting a reply to: Samsung 52" LCD TV (LNS-5296DX) has sound but no picture
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Samsung 52" LCD TV (LNS-5296DX) has sound but no picture
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
No video
by jw650 / February 14, 2010 5:50 PM PST

I have a different model. Its service manual gives a pin-out for a 30-pin connector but YMMV.

The Troubleshooting section suggests sound+no video is likely to be a problem with the main board rather than the power one, and recommends looking mostly at waveforms rather than voltage levels. The one suggested fault common to all sources (tuner and external inputs) is the cable from main board to panel - the manual suggests checking this is connected properly. Otherwise, the guide points to main board replacement, then the panel itself.

Collapse -
Samsung LCD 52" (LNS-5296DX) has sound but no picture, video
by vanlezer / February 15, 2010 2:07 AM PST
In reply to: No video

I measured no voltages coming out of CNI-801 and CNI-802 from the Power Supply board.

Not sure what the voltages should be but looks like no power going to the Inverter boards to the left and right of the TV...hmmm....

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

Does BMW or Volvo do it best?

Pint-size luxury and funky style

Shopping for a new car this weekend? See how the BMW X2 stacks up against the Volvo XC40 in our side-by-side comparison.