Windows 10 forum

Question

Runtime Broker using high memory and cpu usage

after upgrading to windows 10 my laptop fan always working fast ...
when i checked this issue, i see runtime broker in task manager with high resourse usage ...
when i click on end task, everything be normal... but runtime broker run itselft immediately ...
i googled this issue but i couldn't find a useful solution.
please help me to solve this issue ...
sorry for bad english Grin

Discussion is locked
You are posting a reply to: Runtime Broker using high memory and cpu usage
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Runtime Broker using high memory and cpu usage
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
What laptop? FULL MODEL NUMBER!!!

In reply to: Runtime Broker using high memory and cpu usage

I can't tell why folk skip the details or supply a series but not the full model number so here's the usual.

After any OS updates you go to the maker's web site for drivers specific to your PC.

This seems to be hitting folk hard.

Collapse -
HP

In reply to: What laptop? FULL MODEL NUMBER!!!

hp pavilion dv6-6c01se
windows updates downloaded automatically graphic drivers and etc ...
and i think all drivers are ok ...

All Answers

Collapse -
Answer
It appears what worked for 8, works for 10.

In reply to: Runtime Broker using high memory and cpu usage

Collapse -
Answer
Disable Runtime broker and other non-useful Processes

In reply to: Runtime Broker using high memory and cpu usage

Hi, you can tweak few windows settings to lower down overall windows 10 CPU usage. I have solved it by doing these.

Disable Runtime broker by doing this. Believe me, its not a critical process

Step 1: - Press windows key + i to open system control panel.Click on system.
Step 2 – Now, click on Notifications & actions in the left menu.
There is an option in the right side, saying show me tips about windows. Turn it off.

Adjust system for best performance
Step 1: – Search view advanced system settings in start menu search box.
Step 2: – Now, click on view advanced system settings.
Step 3: – Now, choose adjust for best performance. Finally choose apply and then click ok. Finally restart your PC.

Disable Background apps running on windows 10
Go to Settings -> Privacy -> Background apps and turn all of them off.

Update Outdated drivers
Sometimes this may also be the cause

Link removed by moderator.

Post was last edited on May 5, 2016 6:35 AM PDT

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

GRAMMYS 2019

Here's Everything to Know About the 2019 Grammys

Find out how to watch the Grammy Awards if you don't have cable and more.