Networking & Wireless forum

Question

Router + AP on same subnet, having issues

by GasMan320 / May 18, 2011 5:59 AM PDT

Hi everyone,I'm so glad I found this forum. I have been pulling my hair out trying to figure out a solution to my problem and so far haven't gotten anywhere.My setup is this:I have a D-Link DIR-655 router connected to my 2Wire DSL modem. The DIR-655's IP address is 192.168.1.1 and it is the DHCP server. It has wireless turned on and the SSID is Home Net. I then have another router, a Netgear WNDR3700v2 setup as an access point. It has a static IP (192.168.1.3) which is outside of the DHCP range of the DIR-655 router and has its own DHCP turned off. I have it connected to the DIR-655 via a Belkin Gigabit Powerline adapter. The wire goes from LAN to LAN ports so the Netgear does not have anything in its WAN port. The Netgear's SSID is the same as the DIR-655's (Home Net) so that my parents don't have to constantly change which network their phones or computers are connected to based upon where they are.Ok, so now my problem is this:If I connect to my DIR-655 (the router) via WiFi and then go out of that router's WiFi range and into the range of the Netgear's (the AP) WiFi range, and try to connect, I am able to connect to the WiFi network but the AP has trouble getting a DHCP for the client from the DIR-655 (the router) and therefore browsing from the AP doesn't work at all. It doesn't just stop working on that single phone, it stops working completely on all wireless clients. I thought at first that maybe my PowerLine adapters are messing up and I found that if I unplug the adapter from the wall and then plug it back in, all of a sudden, the AP's able to work perfectly, hand out IP addresses from the router's DHCP, and anyone connected to the AP can surf the web. So I started thinking the Powerline just keeps messing up and constantly needs to be powercycled.But then, I thought what if I don't powercycle the Powerline adapter but instead just unplug the ethernet cable that goes from the powerline to the DIR-655's LAN port and then plug it back in again after a few seconds. As soon as I did this, once again the AP's internet started working again and it was able to contact the DIR-655 router and a wireless client connected to the AP could now ping the DIR-655 router.Thank you for reading so far. My question is, why is this happening? What happens when I momentarily unplug the ethernet cable that connects the router and the AP? How can I make my setup so that this doesn't happen? Any help would really be appreciated. Thank you!

Discussion is locked
You are posting a reply to: Router + AP on same subnet, having issues
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Router + AP on same subnet, having issues
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
That's one advanced setup.
by R. Proffitt Forum moderator / May 18, 2011 6:05 AM PDT

All I can offer is I would not setup or support such a system. I will offer that I might consider using the more accepted "use a router as a access point" noted in this forum's sticky are at http://kb.netgear.com/app/answers/detail/a_id/965/~/using-wpn824,-wgr614,-or-wgt624-routers-as-an-access-point

There are routers that do lock up when a Vista machine is near but that's an old issue cured with firmware or if not, replacing the bad router.

As to "why is this happening?" I can't tell you but I do see the problem and have had to cure far too many with firmware, replacements or revamping the network.,
Bob

Collapse -
Clarification Request
Test without power line
by bill012 / May 18, 2011 6:49 AM PDT

I would try to run your same configuration without the powerline adapter.

You could take a long cable and see it works. You could also move your "AP" closer and use short cable and simulate only being able to see the "AP" by turning the radio off in the router.

As mentioned it could be firmware in the routers or the powerline. I would load the latest versions on all.

A number of years ago I used a different brand of power extenders and it had a very low limit of mac addresses. I tried to hook a switch at the far end it would just stop when I connected more than 3 machines. You could test for this by using the WAN port on the remote "AP" and enabling the DHCP for a different range that your main router is using. I would recommend you only use this to test since running router behind a router tends to make file/printer sharing a challenge to configure.

Collapse -
Update
by GasMan320 / May 18, 2011 8:39 AM PDT

Thank you for the reply. I do have a correction to make to my original post -- it seems as if only the device (iPhone in this example) that roams is the one whose internet stops working.

If the iPhone goes from router's wifi zone to AP's wifi zone, the iPhone's wifi stops working. Getting an auto-assigned IP address takes quite a while, but eventually an IP address is assigned, yet the router is still not pingable nor is there internet access on the phone. However, another client that has not been moved from the AP's wifi zone, can continue to access the internet with no problems.

So do you think the problem is the Powerline adapters or do you think this has something to do with the iPhone hardware or do you think this has something to do with my router setup? I am definitely going to try running a long cable and isolating out the variable of the Powerline. Also I tried changing the Netgear WNDR3700v2 router that I am using as the AP with another router running DD-WRT and had the same issue, making me think either its the iPhone hardware or the powerline adapter that is causing the issue.

Another question I have is, is roaming generally issue-free when doing this kind of setup or am I just running into a "normal" problem? By this setup I mean a router connecting to an AP via ethernet, with both router and AP wifi SSID's being the same.

Thank you again.

Collapse -
Keeping the iphone as the problem.
by R. Proffitt Forum moderator / May 18, 2011 8:53 AM PDT
In reply to: Update

If I was tasked with fixing that, I would populate the installation Apple's own routers for a test.

Having the same SSID proved to be problematic and I found some gear confused (some call that a bug!) by this. I moved to SSID names like ZONE1, ZONE2 etc. and told the devices to autoconnect when needed.

Let me be clear that seamless roaming is not implemented today. It's a wish they would do that.
Bob

Collapse -
Roaming
by bill012 / May 18, 2011 10:56 PM PDT
In reply to: Update

The ability to move from one access point to another with no delay and no disruption is quite the challenge. The largest issue is how to quickly transfer the security credentials and keys between access points without compromising security. The main implementation I have done uses special cell phones that will switch from access point to access point using VoIP and then switch to the cell network if you walk out of range. It does this all with no disruption. Very complex and very expensive. It is the preferred implementation to use the same SSID.

It appears you would be more than happy to wait the couple of seconds it takes to renegotiate the security if the network part would work.

I would bet one of your devices has the MAC address of your iphone on the wrong port. If we take a common layer 2 switch it will add any mac address it sees coming in to a port, when it sees the same mac address coming in a different port it is support to add it to that one and remove it from the other. The switch will also remove the mac address from a port if it does not see traffic, generally 5 minutes but it varies. There is no way to say for sure if your equipment combination follows these standards, to save money they may cut corners.

It all going to depend if there are commands on your equipment that will let you see these tables. If you can ask it to display the list of mac addresses it knows and which ports it has learned them on it would help.

The other thing that could get you is if any of the mac or IP addresses are changing. Then you have ARP type issues. If the mac address of your iphone or the mac address of the gateway would change you could have ARP table issues. The timeout for a ARP entry is generally 4 hrs. If you can force clear the ARP tables with a command it should relearn it. In theory you should only be worried about arp tables on the main router and on the phone itself.

I am still going to bet the powerline stuff is doing something to you. Many people run with 2 devices like you are and have no issues.

Collapse -
It worked!
by GasMan320 / May 19, 2011 6:08 AM PDT
In reply to: Roaming

Thank you again for all of the help.

I tried running a cat6 cable directly between the router to the AP without the Powerline adapters and it started working perfectly. If I walk around the house while running a constant ping to the main router's IP, it times out only for 1-2 seconds while it seamlessly switches between the router and the AP's wifi zones!

It seems as if the Powerlines really cannot handle the auto-sensing feature when a cable is being used for a LAN-to-LAN connection. What's weird is that with the Powerline the internet still would work, it just wouldn't work if I left that zone and then returned back to that zone (after having connected to the router's wifi zone).

I'm so glad I got this working, but now the nerdy side of me is wondering about the how's and why's of why it wasn't working before. Do you experts think it was just the powerline not being able to auto-sense the cable or did it have something to do with arp tables and ports?

Thank you!

Collapse -
Autosense.
by bill012 / May 19, 2011 10:44 PM PDT
In reply to: It worked!

It is unlikely it is the autosense part since it works for other machine. Since nothing physically changes between your routers and the powerline equipment when you move your laptop around the duplex/speed part should be fine. Unplugging the ethernet cable may fix it because it is flushing other tables in its memory, sort of a partial reboot.

I am pretty sure the powerline runs as a kind of switch. It should have no concept of IP addresses and ports. (not 100% sure I have not used your model). It should use only mac addresses.

I would investigate the number of total mac addresses the powerline can have and what the timeout values are. The tricky part about these powerline devices is that they are designed to run more than just 2 units. I have little knowledge of how this actually works. Unlike a real switch these devices seem to use the mac address of the powerline units themselves to direct other traffic.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?