Windows Vista forum

Question

Right click not responding at all.

by anothershellie / September 1, 2011 4:56 AM PDT

Right click is gone. I can't find a solution to this online or in forums. I've tried switching mouses, checking the mouse settings in control panel, I got to the task manager by ctrl+alt+delete and tried a couple of things I've been successful with before, but no good this time. No viruses or malware detected. My laptop is a Dell Inspiron 1525, Vista Home premium 32 bit. I never use the touch pad, but tried it, and only get a short menu, with some things greyed out. A right click shortcut Shift+F10, works on some things, but not on the internet b/c The right click menu flashes for a split second, but I can't access it. I tried system restore to create the date for yesterday, before this started, no luck there. Have unplugged, removed battery, plugged in again.
I hope some of you computer savvy folks will reply, I really don't know what else to try. Throwing the laptop out the window is not an option, although I am getting the urge!
Thanks,
Shellie
<input id="gwProxy" type="hidden"><!--session data--><input onclick="jsCall();" id="jsProxy" type="hidden"><div id="refHTML"></div>

Discussion is locked
You are posting a reply to: Right click not responding at all.
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Right click not responding at all.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Answer
You didn't list System Restore.
by R. Proffitt Forum moderator / September 1, 2011 4:59 AM PDT

I'd use that to a day it worked.

Collapse -
Thanks for the quick reply
by anothershellie / September 1, 2011 5:14 AM PDT

Thanks for the quick reply! My post was probably so long and jumbled together, you maybe didn't see that I tried system restore. I did it back to yesterday when the right click was fine. BTW, I forgot to mention I also checked out the Device manager, and it said "this device is working properly".<input id="gwProxy" type="hidden"><!--session data--><input onclick="jsCall();" id="jsProxy" type="hidden"><div id="refHTML"></div>

Collapse -
Actually it read hear as if
by R. Proffitt Forum moderator / September 1, 2011 5:43 AM PDT

I read it now and see you tried to "create" a restore point to yesterday and not that you restored to a day or more when it worked.

Research ShellMenuView and use that to examine what's in the rightclick menu.
Bob

Collapse -
TY for the help
by anothershellie / September 1, 2011 8:59 AM PDT

Bob, I see what you mean. In my mind, when I said "no luck there", it was a briefer way of saying...it didn't solve the right click problem even when I had set the system restore date to yesterday before the problem started.

I'll check out what you suggested, thanks for the help.
Shellie

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?