Windows Vista forum

General discussion

restorig original TCP IP dll

by luigi456 / September 15, 2007 2:20 AM PDT

I have troubles with a database server (sql anywhere) over Vista Home Premium. When it starts a socket error occurs, it seems that the socket cannot be created and a never ending loop runs. The log file reports Error 10057 setting SO_UPDATE_ACCEPT_CONTEXT many times.
I would try to restore original dlls of TCP IP that are probably be overwritten by a Netgear Wireless Adapter.
How to do that?
Or there's another way to solve such a problem?

Discussion is locked
You are posting a reply to: restorig original TCP IP dll
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: restorig original TCP IP dll
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
MySQL running. However...
by R. Proffitt Forum moderator / September 16, 2007 5:34 AM PDT

I had to kill UAC and configure the firewall. Have you done that?

Bob

Collapse -
MySQL running. However...
by luigi456 / September 16, 2007 5:19 PM PDT

Yes, Firewall and UAC was stopped before install of software. The SQL Anywhere server console reports:


Running Windows Vista Build 6000 on X86 (X86_64)
Server built for X86 processor architecture
2048K of memory used for caching
Minimum cache size: 2048K, maximum cache size: 1491064K
Using a maximum page size of 8192 bytes
Starting database "servoy_repository" (C:\Program Files\Servoy\database\servoy_repository.db) at Mon Sep 17 2007 09:04
Database recovery in progress
Last checkpoint at Mon Sep 17 2007 03:09
Checkpoint log...
Performance warning: Database file "C:\Program Files\Servoy\database\servoy_repository.db" consists of 47 disk fragments
Transaction log: servoy_repository.log...
Rollback log...
Checkpointing...
Starting checkpoint of "servoy_repository" (servoy_repository.db) at Mon Sep 17 2007 09:04
Finished checkpoint of "servoy_repository" (servoy_repository.db) at Mon Sep 17 2007 09:04
Recovery complete
Database "servoy_repository" (servoy_repository.db) started at Mon Sep 17 2007 09:04
Database server started at Mon Sep 17 2007 09:04
Trying to start SharedMemory link ...

SharedMemory link started successfully

Trying to start TCPIP link ...

Starting on port 2638

--------


So the database is open but the TCP IP connection stucks, the CPU goes to 100% usage and nothing more appens.
The same thing with the developer edition of SQL Anywhere, not only with Servoy.
I also tried to change the port, but still the same error.
If I tell to server not to use TCPIP the starting process goes to the end, but is not possible to connect to database.
So it seems that the problem is the socket creation, but why?

Collapse -
I can't answer.
by R. Proffitt Forum moderator / September 16, 2007 11:40 PM PDT

Why? I don't have that issue here. I noticed you "stopped" the firewall rather than configure it. There is that Norton (and others?) firewall that keeps working when stopped. I wonder if you have one of those.

Bob

Collapse -
Security
by luigi456 / September 16, 2007 11:53 PM PDT
In reply to: I can't answer.

I've a Netgear firewall that is configurated to assure security to all PCs on my LAN, and NOD32 for viruses.

Collapse -
To me...
by R. Proffitt Forum moderator / September 17, 2007 1:47 AM PDT
In reply to: Security

It appears you don't have a full grip on the firewall issue. You noted the one in the router but don't respond about how you configured the UAC or the machine's firewall.

Sadly I don't think I can help you since you seem a little unfocused.

Bob

Collapse -
firewall
by luigi456 / September 18, 2007 4:42 PM PDT
In reply to: To me...

Firewall is a separate hardware. The UAC is down, as Windows firewall.
What is unfocused?

Collapse -
Unfocused as in...
by R. Proffitt Forum moderator / September 19, 2007 12:35 AM PDT
In reply to: firewall

You are not trying it the way others have found it to work. Since you are doing it your way and not configuring the firewall I can't compare notes.

Maybe you should try a newsgroup that is for MySQL as well.

It's like a formula. You change the formula and the results may not be the same.

Bob

Collapse -
Unfocused as in...
by luigi456 / September 21, 2007 3:19 AM PDT
In reply to: Unfocused as in...

I unistalled SQL Anywhare, I activated Windows firewall, UAC and all security stuff, as are default. So I've installed sql Anywhare and the proplem still exactly the same.
I don't understand what should I ask in a mySQL forum, my problem is with sybase.

Collapse -
Which is not what I did.
by R. Proffitt Forum moderator / September 21, 2007 3:21 AM PDT
In reply to: Unfocused as in...

Sorry I feel I can't help you. While my setups work you may need someone with similar experiences to do the configuration for you.

Sorry, but you can read on your Sybase groups about this issue with firewalls and more. I've noted it but you may need someone to adjust it for you since my hints are not enough.

Bob

Collapse -
back to first question...
by luigi456 / September 22, 2007 1:46 AM PDT

Ok, but... do you know how to restore original tcpip dlls?

Collapse -
In the case of Vista...
by R. Proffitt Forum moderator / September 22, 2007 2:07 AM PDT

Reinstall the OS if http://support.microsoft.com/kb/929833 and it's use of SFC /SCANNOW does not replace the DLL.

I find it sad that you are struggling here and can't duplicate or "try it my way." I have a bad feeling that you may end up with a Geeksquad receipt.

Bob

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!