Computer Help forum

Resolved Question

Restored files are read only

by George D3 / March 6, 2013 11:41 PM PST

I lost my operating system and all my programs when I tried to restore from a mirror image. I reinstalled Windows 7 professional and all my programs. When I reloaded my data backup all the files appeared as Read Only. I can get at them by giving each one a new name and saving it to a different file than My Documents. With thousands of files this is going to be a long drawn out process. Does anyone know of an easier way to do this or know of a software program that will complete the process for me. Thanks.

George D3 has chosen the best answer to their question. View answer
Discussion is locked
You are posting a reply to: Restored files are read only
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Restored files are read only
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Best Answer chosen by George D3

Collapse -
Tried "Taking Ownership"?
by Grif Thomas Forum moderator / March 7, 2013 12:04 AM PST
Collapse -
removing Read Only for properties
by George D3 / March 8, 2013 11:27 PM PST

Thanks, never had this problem before and it's nice to know there is a forum where there are others with more knowledge about computers inner workings.

Collapse -
Answer
If the problem is ...
by Edward ODaniel / March 7, 2013 3:08 PM PST

one of ownership restricting your ability to save the files Grif's suggestion is all you need.

On the other hand if it is because you restored data files from optical media that thus got copied to the hard drive with the Read attribute set you can reset that attribute easily.

Open a command prompt and navigate to the folder(s) the files are located in and type this command ATTRIB -R then press the enter/return key and all the files will be re-set.

If the files are located in several sup folders navigate to the top level folder and type this command ATTRIB -R /S /D then press the enter/return key and now all the files in the top level folder as well as all its subfolders and the sub folders themselves will have the attribute removed.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!