Desktops forum

General discussion

Replacing AMD Sempron LE-1300 2.3GHz - need advice

by cnetmich5 / June 21, 2010 12:00 AM PDT

Hello, all.

First time posting here. I have a pc with Sempron LE-1300 2.3 Ghz and at the time bouight this, I did not know better... It is awfully slow even for simple web-stream videos and it is just too slow for my minimal usage on this computer.

I would like to have your advice on what better/faster CPUs that I can replace with, without causing headache - I want something that I can simple replace and done with. I have 2 Gb ram, running Vista but can get Win7 if that helps on this issue.

Thank you much for your advice in advance.

Discussion is locked
You are posting a reply to: Replacing AMD Sempron LE-1300 2.3GHz - need advice
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Replacing AMD Sempron LE-1300 2.3GHz - need advice
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
I have a Sempron 1.8GHz and it is fine.
by R. Proffitt Forum moderator / June 21, 2010 12:03 AM PDT

It does everything I want it to. HOWEVER I learned to not use ATI video cards since the drivers seem to peg the CPU. I went with a Nvidia 9500GT 512MB video card and even 3D games play well.

In my opinion it's likely to be "not the CPU."

Collapse -
I have NVIDIA GeForce G210
by cnetmich5 / June 21, 2010 12:19 AM PDT

I am not sure whether this is a problem for me. On sidebar, CPU is almost always 100% in use when I tried to run a few pages of websites... Ram is about half in use.

Collapse -
Is that G210 "on board"?
by R. Proffitt Forum moderator / June 21, 2010 2:16 AM PDT

The card I use is a card. You may be seeing the effects of on board video. If you can reveal some details I'll fire my 1.8GHz Sempron up and compare CPU load.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?